Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

TMS upgrade failed: Unable to communicate with system

Dear all,

 

The endpoint are failed to upgrade from the TMS.

Based on the System Upgrade Activity Status, it reports as follows,

Unable to communicate with system

Event Postponed to 2014-xx-xx.

The event repeats for 48 times, and upgrade event is deleted finally.

 

Based on TMS page, the connectivity of the endpoint is Reachable on LAN.

The setting can be modified and the configuration templates can be updated by the TMS.

TMS configuration: Secure-Only Device Communication : OFF(Sorry, i have missed the information)

 

Endpoint configuration:

Provisioning 

Address: <TMS IP>

ExternalManager protocol: HTTP

 

Best Regards,

Benjamin 

 

Everyone's tags (1)
7 REPLIES

Interesting that the external

Interesting that the external manager protocol is http and your tms config is secure only.

Could you tell us a bit more about your deployment.

Which TMS version do you run, which endpoints do you try to upgrade, which are the software versions you are trying to upgrade from and to?

 

Any more info in the logs of the TMS or the endpoints?

 

 

Please remember to rate helpful responses and identify

Cisco Employee

Sounds very much like bug:

Sounds very much like bug: CSCug21218

<B>Symptom:</B>

Unable to upgrade systems from TMS

<B>Conditions:</B>

HTTP is disabled on the TMS server

Optional: Secure device communication only
Optional: HTTPS only is enabled on the endpoint.

<B>Workaround:</B>

Enable HTTP on the TMS server

I don´t know about the TMS version you are on but this was an issue before as I remember because I created this bug on TMS 14.1.1. TMS 14.3 should resolve the issue, but you can utilize the workaround. 

/Magnus

New Member

Dear Magnus, Thanks for your

Dear Magnus,

 

Thanks for your sharing.

The TMS version is 13.2 

 

Best Regards,

Benjamin 

New Member

Hi Magnus,I am having the

Hi Magnus,

I am having the same issue, running TMS 13.2.2.  I did a quick packet capture from TMS and I see that all traffic is effectively all in tlsv2 (https) when I try the software upgrade for an Ex60 running tc7.1.  How do you "Enable HTTP on the TMS server" exactly?  Secure device communication setting is also OFF.

 

Cheers,

 

Andre

New Member

Andre - I have the same issue

Andre - I have the same issue running TMS 13.2.2.  I have Secure Device Communication setting OFF. 

Did you find out how to enable HTTP on the TMS server exactly?

thanks!

New Member

Dear Martin, I am sorry that

Dear Martin,

 

I am sorry that some information is missed.

TMS configuration: Secure-Only Device Communication : OFF(Sorry, i have missed the information)

 

TMS version is 13.2.

Target endpoint EX90: 5.1.7 ->5.1.11

 

Best Regards,

Benjamin

Cisco Employee

Hi Benjamin,With TMS 13.x and

Hi Benjamin,

With TMS 13.x and TC 5.x, the upgrade mechanism consists of TMS trying to do a HTTP POST to the endpoint with the entire software image. Endpoint software images are large, typically ~200 MB, could it be that a firewall or something in the network is killing the connection before the upload completes?

I recommend getting a Wireshark trace of a failed upgrade to troubleshoot your problem futher.

Regards,
Kjetil

356
Views
0
Helpful
7
Replies
CreatePlease login to create content