Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

TMSPE Migration Fails - Failed to create group

Hi,

On running the Migration tool after the TMSPE install, I get 1 warning, and 1 error. It seems from below that {ame} is the problem here but where do I edit it out with the recommended replacements? I can't see {ame} anywhere in the FindMe Provisioning template or anywhere else in TMS...

WARNING:

Invalid caller id pattern for group mycompany could not be migrated: {ame}@mycompany.co.uk. Legal replacement values are {mobile_phone} and {office_phone}.

ERROR:

Failed to create group for {display_name=[mycompany], display_name_pattern=[{display_name}], video_uri_pattern_inherited=[false], video_uri_pattern=[{ame}@mycompany.co.uk], device_uri_pattern=[{ame}.{device.model}@mycompany.co.uk], device_uri_pattern_inherited=[false]} URL: /groups The exception returned from API was The argument

video_uri_pattern={ame}@mycompany.co.uk

is invalid Status: InvalidArgument Status Code: 1005.

The exception message is: POST

http://localhost:8788/ur/groups returned a response status of 400 Bad Request

Failed to create group for {display_name=[mycompany], display_name_pattern=[{display_name}], video_uri_pattern_inherited=[false], video_uri_pattern=[{ame}@mycompany.co.uk], device_uri_pattern=[{ame}.{device.model}@mycompany.co.uk], device_uri_pattern_inherited=[false]} URL: /groups The exception returned from API was The argument

video_uri_pattern={ame}@mycompany.co.uk is invalid Status: InvalidArgument Status Code: 1005.

The exception message is: POST

http://localhost:8788/ur/groups returned a response status of 400 Bad Request

Can anyone shed some light on this?

Thanks

Tom

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: TMSPE Migration Fails - Failed to create group

You could try to remove the device uri pattern and the findme patterns and then try to do the migration again. If its successful you can re-populate these fields easy once tmspe is up and running.

/Magnus

Sent from Cisco Technical Support iPhone App

7 REPLIES
Cisco Employee

Re: TMSPE Migration Fails - Failed to create group

Hi, it seems like its complaining about the caller id which is configured in the findme setting in tms provisioning directory on one of the groups.

If you go to the tms agent settings

In tms do you "hide" your findme Setting? If so try to "unhide" and then go back to the prov dir and see if you can see anything here now. Ame is part ofthe word usernAME or firstnAME or lastnAME is there something that might cause this placeholder to be "misread" by the migration tool?

Just throwing some thoughts..

/Magnus

Sent from Cisco Technical Support iPhone App

Community Member

Re: TMSPE Migration Fails - Failed to create group

Thanks for the advice - FindMe is not hidden in TMS Agent settings, and we only have one FindMe template:

We do have some unused XML templates referring to older versions - the provisioning guide recommended removing them but I can't see how.

Thanks

Tom

Cisco Employee

Re: TMSPE Migration Fails - Failed to create group

You could try to remove the device uri pattern and the findme patterns and then try to do the migration again. If its successful you can re-populate these fields easy once tmspe is up and running.

/Magnus

Sent from Cisco Technical Support iPhone App

Cisco Employee

Re: TMSPE Migration Fails - Failed to create group

Replication is disabled i assume so it wont affect the database on the vcs.

/Magnus

Sent from Cisco Technical Support iPhone App

Community Member

Re: TMSPE Migration Fails - Failed to create group

Yes correct - I'll give it a try

Community Member

Re: TMSPE Migration Fails - Failed to create group

And it worked...migration now complete!

I had to re-add the templates which was no bad thing since there are a few changes e.g. {mobilephone} is now {mobile_phone} in the new TMSPE...

Thanks again.

Tom

Cisco Employee

TMSPE Migration Fails - Failed to create group

Great

Thanks for letting us know

/Magnus

712
Views
0
Helpful
7
Replies
CreatePlease to create content