Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VCSE 7.1 to 7.2 Software error

Hi there,

i get the following message after upgrading VCSE 7.1 to 7.2

An unexpected software error was detected in httpserver.py: Handler="GetXmlHandler"

Incident Detail:

Traceback (most recent call last):

File "/share/python/site-packages/ni/xmlapi/utils.py", line 124, in wrapper

return func(self)

File "/share/python/site-packages/ni/xmlapi/utils.py", line 99, in wrapper

return func(self)

File "/share/python/site-packages/ni/xmlapi/handlers/getxml.py", line 128, in GET

self.insert_plugin_elements(plugin, parent_element)

File "/share/python/site-packages/ni/xmlapi/handlers/getxml.py", line 183, in insert_plugin_elements

elements = plugin.get()

File "/share/python/site-packages/ni/xmlapi/simpleadapter.py", line 169, in get

self._get_walk_recursive(self.xml_structure, record, builder)

File "/share/python/site-packages/ni/xmlapi/simpleadapter.py", line 137, in _get_walk_recursive

self._get_walk_recursive(value, record, builder)

File "/share/python/site-packages/ni/xmlapi/simpleadapter.py", line 145, in _get_walk_recursive

builder.data(str(field_value))

UnicodeEncodeError: 'ascii' codec can't encode character u'\xdc' in position 5: ordinal not in range(128)

And in TMS the connection to VCSE (with Version 7.2) remains with Ticket

#139 - The system is busy - The system is shutting down, or starting

Anybody know how to fix this?

Regards,

CCNP R&S
Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: VCSE 7.1 to 7.2 Software error

Any (reverse/transparent) proxy in between tms and vcs?

Do you have any external scripts accessing the API?

Do you have any "strange" = non asci characters in any of your configuraton fields (like local charsets, UTF-8, chinese, ....), if so I would try to remove them and replace it with 7-bit ascii. (especially if you have the letter "Ü" somewhere (any where in the config, systen name, search rule names, descriptions, .... Please remove everything which is not [a-z][A-Z])

A xconfig and xstatus via the admin CLI  (TSH) might help you to find these.

Please remember to rate helpful responses and identify

14 REPLIES
Cisco Employee

VCSE 7.1 to 7.2 Software error

Do you continue to see same alarm/error message even after VCS manual restart once again?

New Member

VCSE 7.1 to 7.2 Software error

Restart and Reboot, no difference in alarm/error.

CCNP R&S

VCSE 7.1 to 7.2 Software error

Hi Lone,

It would be good if you can open a TAC case for this!!this error requires in depth analysis of logs and probably will require you to collect system snapshot as well

Thanks

Alok

New Member

VCSE 7.1 to 7.2 Software error

Ok. i will do this.

CCNP R&S
New Member

VCSE 7.1 to 7.2 Software error

Hello,

Was this upgrade sucessfull ??

It looks like a image error. I would recommed you to download a new image and upgrade again and also try using English verison.

Thanks,

Rizwan

New Member

VCSE 7.1 to 7.2 Software error

Hi,

i redownloaded the version s42700x7_2_0.tar.gz but there is no difference. I dont think this would be an image error, because the version is running "stable"...except of the error above :-)

CCNP R&S

Re: VCSE 7.1 to 7.2 Software error

Any (reverse/transparent) proxy in between tms and vcs?

Do you have any external scripts accessing the API?

Do you have any "strange" = non asci characters in any of your configuraton fields (like local charsets, UTF-8, chinese, ....), if so I would try to remove them and replace it with 7-bit ascii. (especially if you have the letter "Ü" somewhere (any where in the config, systen name, search rule names, descriptions, .... Please remove everything which is not [a-z][A-Z])

A xconfig and xstatus via the admin CLI  (TSH) might help you to find these.

Please remember to rate helpful responses and identify

New Member

VCSE 7.1 to 7.2 Software error

The error was the non ascii. I used an "Ü" and the VCSE saved it as "\xdc" in config. I removed it and rerun the upgrade, everthing is fine. :-)

CCNP R&S

CCNP R&S
Gold

VCSE 7.1 to 7.2 Software error

Where in the VCS config were you attempting to use this "Ü" character?

- Andreas

New Member

VCSE 7.1 to 7.2 Software error

Hi Andreas,

under System->SNMP->Location

CCNP R&S

CCNP R&S
Gold

VCSE 7.1 to 7.2 Software error

And when exactly did this error message appear? What did you do to trigger it so to speak?

Thanks,

Andreas

Gold

VCSE 7.1 to 7.2 Software error

Thanks for the clarification, I have raised a defect for the VCS so that this can be addressed.

-Andreas

VCSE 7.1 to 7.2 Software error

Dafür vielen Dank :-)

Please remember to rate helpful responses and identify

Re: VCSE 7.1 to 7.2 Software error

Lonemaker: Thx for the feedback, rating and set the thread to answered. +5 for you as well!

Please remember to rate helpful responses and identify

1066
Views
10
Helpful
14
Replies
CreatePlease login to create content