Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Running Exchange 2010 PowerShell Scripts

Hello,

I have a PowerShell Script which calls PSSnapins for Exchange tools.  The Exchange Management Tools are installed on the Tidal Server

The Script works fine by itself, I have executed it as the tidal users on the Tidal Server. I have also created a batch file to execute the Powershell script, which also works on the tidal server.

However when I run the job in Tidal it doesn't run correctly by that I mean it will run the none Exchange pieces.  In the Output tab it shows:

Add-PSSnapin : The Windows PowerShell snap-in 'Microsoft.Exchange.Management.PowerShell.E2010' is not installed on this machine.

At E:\PowerShell\DailyChecks\Dag_daily.ps1:7 char:13

+ Add-PSSnapin <<<<  Microsoft.Exchange.Management.PowerShell.E2010

    + CategoryInfo          : InvalidArgument: (Microsoft.Excha...owerShell.E2

   010:String) [Add-PSSnapin], PSArgumentException

    + FullyQualifiedErrorId : AddPSSnapInRead,Microsoft.PowerShell.Commands.Ad

   dPSSnapinCommand

Add-PSSnapin : The Windows PowerShell snap-in 'Microsoft.Exchange.Management.Powershell.Support' is not installed on this machine

These Scripts also work via Windows Task Scheduler as written  I would really like to get these to work in Tidal.  We are Tidal 5.3.1. 

Any help would be greatly appreciated.

Lee Merrill

Everyone's tags (2)
2 REPLIES
New Member

Running Exchange 2010 PowerShell Scripts

I have struggled with a similar issue with Sharepoint snapin with performing a backup

I can give a couple of suggestions

Add snapin to default profiles

We also see a difference in 64 vs 32 bit oprerations

we had to add to both versions using a local profile.ps1 and adding a line

Add-PSSnapin "Microsoft.SharePoint.PowerShell" -ErrorAction SilentlyContinue

C:\Windows\System32\WindowsPowerShell\v1.0

C:\Windows\SysWOW64\WindowsPowerShell\v1.0

Execute remotely

Slightly different setup on our side

I am trying to invoke-command on the remote sharepoint server =

( you have to set up psremoting, etc)

Invoke-Command -ComputerName -scriptblock { E:\Backup\BackupSite.ps1}

Similarly I  can execute the backup.ps1 with no issue on the server but can't from the tidal job.

I'll let you know if we find a fix

I am thinking double hop at this point and need to trust for delegation, etc

Marc

New Member

Running Exchange 2010 PowerShell Scripts

Hi Marc,

Thanks for the Reply.  I have tried creating profiles global and user profiles neither worked for me.  I have also attempted the invoke-commands and remote-sessions to no avail.  I think this is an issue with Exchange 2010 being x64 and Tidal client being 32 bit.  If you have anyother ideas I am willing to try them.  Currently I am running the scripts via task scheduler in windows.

Again thanks for taking the time to respond.

Lee

2848
Views
0
Helpful
2
Replies
CreatePlease to create content