Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Schedule the Python script from Tidal

Hi,

I am not able to schedule any python script from Tidal. Its giving me error:

Launcher Error: startup dir error[/usr/local/bin/python test.sh]:- No such file or directory

Triton Agent Error -14

I scheduled the below command in job window under command section

/usr/local/bin/python /home/test.sh

but it gave me the above error....

But if i try to run any shell i am fine it runs as i can make shell script as executable and schedule from Tidal something like this:

/home/test.sh

Please let me know if we have some way to schedule any python/java program from Tidal

Thanks

Gaurav

Everyone's tags (1)
7 REPLIES
New Member

The problem is the space in

The problem is the space in the file name. I am still looking for a solution to the issue, but so far no luck. The only other option would be to change the file name to not have a space. Using an underscore instead of a space worked for us.

Hope you have tried enclosing

Hope you have tried enclosing the command within single or double quotes ?

'/usr/local/bin/python /home/test.sh'

"/usr/local/bin/python /home/test.sh"

New Member

I have tried and nothing

I have tried and nothing seems to work. Mine is:

/opt/TIDAL/order process/wait.sh

How about

How about

/usr/local/bin/python "/opt/TIDAL/order process/wait.sh"

Silver

Hi Gaurav,

Hi Gaurav,

Please check your path settings, type env

You may have to add /usr/local/bin/python to your PATH, type

setenv PATH $PATH\:/usr/local/bin ; export PATH

BR,

Derrick Au

Hi Derrick

Hi Derrick

If we are using the direct path to the program such as /usr/local/bin/python, then why do we need to add it to $PATH ?

Silver

It is not necessary to add it

It is not necessary to add it to the PATH but it will save on the typing in the long run. I usually do something simple like that to take my mind away from the problem, then later come to realize: using python to run a shell script (.sh) usually leads to a syntax error, so when start up file or directory is not found, then maybe Python isn't installed on that particular machine--try which python ;)

699
Views
0
Helpful
7
Replies
CreatePlease to create content