Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Problem migrating CUCM 7.1.5 to 9.1(2) (Jump Upgrade)

Hello all,

I am facing an issue when trying to upgrade from CUCM 7.1.5.30000-1 to 9.1(2) over UCS following the jump upgrade procedure.

I have installed 7.1.5 CUCM software on the UCS using the 9.1(2) ova. (two nodes cluster), and after that restored the CUCM backup.

I have loaded "ciscocm.refresh_upgrade_v1.3.cop" file before the upgrade on both nodes.

The connectivity with NTP server is good.

The upgrade file I am using is "UCSInstall_UCOS_9.1.2.11900-12.sgn".

The installation begins on Publisher but after three hours and when it is ending it fails. I have checked the installation logs and this is what it shows:

05/23/2014 17:45:51 component_install|(CAPTURE) Fri May 23 17:41:46 2014 cm-dbl-install DEBUG: cm-dbl-install [0]|<LVL::Debug>

05/23/2014 17:45:51 component_install|(CAPTURE) Fri May 23 17:41:46 2014 cm-dbl-install DEBUG: <--|<LVL::Debug>

05/23/2014 17:45:51 component_install|File:/opt/cisco/install/bin/component_install:756, Function: exec_progmeter(), /opt/cisco/install/bin/progmeter failed (1)|<LVL::Error>

05/23/2014 17:45:51 appmanager.sh|Internal Error, File:/usr/local/bin/base_scripts/appmanager.sh:269, Function: refresh_upgrade(), failed to refresh_upgrade infrastructure_post components|<LVL::Critical>

05/23/2014 17:45:51 post_install|File:/opt/cisco/install/bin/post_install:911, Function: install_applications(), /usr/local/bin/base_scripts/appmanager.sh -refresh-upgrade failed (1)|<LVL::Error>

05/23/2014 17:45:51 post_install|Exiting with result 1|<LVL::Info>

05/23/2014 17:45:51 post_install|INSTALL_TYPE="Refresh Upgrade"|<LVL::Debug>

05/23/2014 17:45:51 post_install|Process refresh upgrade failure|<LVL::Info>

05/23/2014 17:45:51 post_install|(CAPTURE) Mail notification cancelled - smtp server address for email not found! [/usr/local/platform/conf/platformConfig.xml]|<LVL::Debug>

05/23/2014 17:45:51 post_install|Retore grub.conf from grub.conf.recovery|<LVL::Info>

05/23/2014 17:45:51 post_install|Copy recovery file, /grub/boot/grub/grub.conf.recovery, to /grub/boot/grub/grub.conf|<LVL::Debug>

05/23/2014 17:45:51 post_install|Retore of grub.conf complete|<LVL::Info>

05/23/2014 17:45:51 post_install|Invalidate upgrade partition|<LVL::Info>

05/23/2014 17:45:51 post_install|Removing master RPM|<LVL::Debug>

05/23/2014 17:45:52 post_install|Removing /etc/opt/cisco/install.conf|<LVL::Debug>

05/23/2014 17:45:52 post_install|Invalidate any product configuration file|<LVL::Debug>

05/23/2014 17:45:52 post_install|Setting product and deployment version attributes in /etc/opt/cisco/install/conf/callmanager_product.conf to 0.0.0.0000-0000|<LVL::Debug>

05/23/2014 17:45:52 post_install|Cleanup refresh upgrade staging areas|<LVL::Debug>

05/23/2014 17:46:14 post_install|Parse argument status=upgrade.stage.error|<LVL::Debug>

05/23/2014 17:46:14 post_install|_set_upgrade_status_attribute: status set to upgrade.stage.error|<LVL::Debug>

05/23/2014 17:46:14 post_install|File:/opt/cisco/install/bin/post_install:580, Function: handle_refresh_upgrade_failure(), Refresh upgrade failed. Trying to reboot to currently active version.|<LVL::Error>

05/23/2014 17:47:19 hardware_check.sh|Initializing hardware library on boot|<LVL::Info>

05/23/2014 17:47:19 ServerApiManager|In main with args -|initialize|- called file |/usr/local/bin/base_scripts/server_api_manager.sh| - and current mode=HSSI_Mode |<LVL::Debug>

05/23/2014 17:47:19 ServerApiManager||Method: initialize args: |- current mode=HSSI_Mode completed with code [0]|<LVL::Debug>

05/23/2014 17:47:19 ServerApiManager|In main with args -|initHardwareLibrary|- called file |/usr/local/bin/base_scripts/server_api_manager.sh| - and current mode=HSSI_Mode |<LVL::Debug>

05/23/2014 17:47:19 ServerApiManager|Sam_reset being called|

I think it is similar to this other case: https://supportforums.cisco.com/discussion/12181161/cucm-vm-715-912-migration-error#comment-9719721

 

Can anyone help me with this? I am stuck on the migration.


Thanks!!

 

Héctor

Everyone's tags (1)
2 REPLIES

Just for the record. I found

Just for the record. I found the solution to my problem. Checking more logs I read this:

 

The installation has encountered a unrecoverable internal error. For further assistance report the following information to your support provider.

"/usr/local/cm/script/cm-dbl-ontape_backup-install RU PostInstall 9.1.2.11900-12 7.1.5.30000-1 /usr/local/cm/ /common/component/database /common/log/install/capture.txt " terminated. Exceeded max time (240)

The system will now halt.

 

So I accessed the Dissaster Recovery Section on CUCM and deleted the tape backup device that was configured there. After deleting it the upgrade went well.

 

VIP Purple

Hi , thanks for sharing .How

Hi ,

 

thanks for sharing .

How did this Tape option strike you?

 

regds,

aman

815
Views
0
Helpful
2
Replies
CreatePlease to create content