Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

4.0.2 https admin

I've configured my 4.0.2 Unity system to use https. All appears to work properly except that when navigating from the main window to a detail window (any of them, it doesn't matter), I get an alert that the page contains both secure and non-secure items that I have to dismiss. It doesn't seem to matter wther I accept or reject the warning as the resultant display is the same. If I reject the non-secure items, I get a brief "action Canceled" in the pane. If I accept them, I get an insecure connection (no lock icon). Browser is IE 6.0

3 REPLIES
New Member

Re: 4.0.2 https admin

I'm getting this error too in 4.0.4 when navigating to a subscriber view.

I've checked all the sources of the obvious elements on the page and they all appear to be https - but something obviously isn't.

I have set the virtual directories WEB, JAKARTA, and STATUS to require SSL connections - I even tried forcing it on the whole site just as a check - still the same error.

Looking at the source on the subscriber page that the selection screen brings up the only obvious reference to a non https entry i can find it:

var bStayLocal = true;

// part a)

if (strHomeServer != "") {

strHomeServer = strHomeServer.toLowerCase();

// part c)

// Do we recognize home server as ourself, or alternatively as our cluster partner?

bStayLocal = (strHomeServer == "server.mydomain.com");

}

if (bStayLocal) {

highTop.location.href = highTop.location.pathname + '?' + strExtra;

}

else {

// Please note! Following string is broken up to avoid CheckSACode.pl

highTop.open("http" + "://" + strHomeServer + "/Web/Sa/FrameASP/SubsFrame.asp?" + strExtra);

}

}

(the "server.mydomain.com" i replaced - it did reference our server - but it references the windows DNS name of the box wihich is not the public certificvate domain name...not sure if that's an issue?

- Ken

New Member

Re: 4.0.2 https admin

Has this been solved already? I'm having the same problem with 4.0(4)sr1

Arief

New Member

Re: 4.0.2 https admin

It has not - we continue to experience the problem.

We are upgrading to 4.0(5) next week but I'm not confident the problem is likely to be fixed in a point upgrade - inspection of the code leads us to believe that some of the query calls are using http:// calss we can't get rid of - I hope 4.0(5) solves it - if not I will probably have to open a TAC case on it.

In the interests of time around graduation we've been living with it for the moment :-/

I take it you're having the same problem?

Ken Johnson

Mgr. Network Services

LeTourneau University

http://www.letu.edu

---------------------

Dir. Marketing Communications

Cisco IP Telecommunications User Group

http://www.ciptug.org

92
Views
0
Helpful
3
Replies