Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

After deleting Exchange accouns Unity version 3 or 4 fails, help requested!

Greetings,

I administrator my company's inherited Unity voice mail system. It was originally setup in 1999(!) and runs on NT 4 with IIS and Exchange 5.5. It has been working fine for the last two years I've administered it but today a big problem started. Recently it refused to create new voice mail accounts stating that there were no more licenses. Another employee told me that was because Unity does not delete old accounts on the Exchange side. So lo and behold there were a couple of hundred accounts of people I've never seen before! I carefully deleted accounts in the Exchange administration tool and ever since then Unity has refused to start. It will try to start itself when manually told to but gives up within 15 seconds. I made very sure that I did not delete any known admin accounts. I don't have the error log in front of me right now but every hour or so there will be 4 alerts stating that the Exchange IMAP service could not be started or logged into. The first log of the problem stated something like AvComponent Manager has an error. I've googled for a solution to this of course but nine year old systems are pretty scarce! I have telco support and will be able to rely on them for some support but if the community here has any leads or ideas on how to help with this it would be _greatly_ appreciated.

Andrew

5 REPLIES
Cisco Employee

Re: After deleting Exchange accouns Unity version 3 or 4 fails,

1st, the hint they gave you is only half right, Unity indeed does not delete the Exchange mailboxes, but that has nothing to do with the licenses.

Only the subscribers that are in the system have to do with that, you can have twice the mailboxes and users in AD and if you still have free subscriber licenses you can add more

2nd if you deleted the Unity_ mailbox or user that is the problem, you should NEVER mess around with that account since Unity uses it not only for starting but also is used to send the VMs left by users who are not subscribers

Check this guide:

Cisco Unity 3.1(x) and 4.x: AvCsMgr Service Fails to Start

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_tech_note09186a00800949dc.shtml

Also make sure you have all the services running with the right accounts

Appendix: Cisco Unity 3.1 Services

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/unity/42/upgrade/guide/ex/ru_570.html

BTW, maybe u already know this but Cisco support for Unity 3.x is gone so TAC won't support this

HTH

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: After deleting Exchange accouns Unity version 3 or 4 fails,

HI HTH,

Thanks for your response! I narrowed down the problem. Although the Unity_ user was intact but the Mailbox cannot be found when I look for it in the User Manager. I checked other users and it shows up fine for them. This would indicate why the AvCsMgr won't start. Would creating a new Mailbox fix this issue or should the account be carefully recreated?

Thanks!

Andrew

Cisco Employee

Re: After deleting Exchange accouns Unity version 3 or 4 fails,

HTH = Hope This Helps

That's the issue, the account needs to have it's mailbox in exchange, that's outlined in the link i already posted

Verify the Unity_ Exchange Mailbox Is Configured Correctly

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_tech_note09186a00800949dc.shtml#topic2-6

HTH

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: After deleting Exchange accouns Unity version 3 or 4 fails,

Alright, deleted the account and Mailbox and the recreated accounts have been made but the Mailbox is still not found in the User Manager. As I am using NT4 without AD the process is a bit different than those instructions, I try to delete the Mailbox in the MS Exchange Administrator and it fails to to delete the user account, so I delete that and recreate the user and than manually create the Mailbox and no dice.

EDIT: Never mind, about that problem, I was able to fix it by creating a new NT account from within the MS Exchange Admin tool. Unity still won't start so I'm troubleshooting.

New Member

Re: After deleting Exchange accouns Unity version 3 or 4 fails,

Well tinkering around for another hour hasn't helped anything. Would Deleting the MAPI Profile be the next logical step to try?

206
Views
0
Helpful
5
Replies
CreatePlease login to create content