Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

BulkEdit and MWI

I have a dual integration with Unity, one to CM and also to a Nortel PBX with PBXLink. When I created the mailboxes, I noticed that there were some MWI issues before the cut, so I used bulkedit to disable MWI for all 3800 subscribers in Unity. I thought that when I was ready to cut I could just go back into BulkEdit and add the MWI code X in the messages tab and re-enable the MWI functionality. Unfortunately it did not make that change. Is there a way to globally re-enable MWI for the subscribers?

6 REPLIES
Cisco Employee

Re: BulkEdit and MWI

Unity Version?

Bulk Edit Version?

When you say it didn't make the change, what do you mean? User's don't have "x" in their MWI field? I just tried it on my install here (both my 4.1 and 4.2 test installs) and it worked ok - the database is changed and the SA shows it right away. Is this not the case on your setup?

New Member

Re: BulkEdit and MWI

Unity 4.0.5, and downloaded the latest from your web site. When i say nothing changed. The BulkEdit says that the users were updated, but going to the subscribers, the USE MWI for Message Notification is not checked and there obviously cannot input anything in the extensions field untile that option is checked.

Cisco Employee

Re: BulkEdit and MWI

Hmmm... not sure how that can be. the checkbox is active if there is a value in the MWI extension field in the NotificationMWI table in SQL - if BulkEdit is adding that value it should show up.

I'd have to look at the logs from BulkEdit and try this on a 4.0(5) system, but looking at the code this should not be version specific.

New Member

Re: BulkEdit and MWI

Let me know if I can provide any other information for you Jeff.

Thanks,

Freddie

Cisco Employee

Re: BulkEdit and MWI

Trying this on a 4.0(5) system in the lab and it works there as well. I'm a bit puzzled at why you'd be having problems right off hand. Go ahead and send me the full BulkEdit log for a run where you tried to enable MWI using "X" to me (lindborg at cisco dot com).

New Member

Re: BulkEdit and MWI

Jeff,

I had a similar issue with Bulk edit for MWI in Unity 5.0. First of all, if I add subscriber using template that has MWI enable and then disable them in Bulk edit, the SA page won't refresh the setting untill I do a search of subscriber again(meaning if I have my SA page open before I bulk edit MWI). It looks to me a bug in Unity or IE not refreshing the DB(DB is changed after bulk edit).

Secondary and very interesting thing is, if I just bulk edit the MWI, in SA page, the check mark is gone,however,in MWI extension field, there is an empty box with no MWI extension. So this enables Bulk edit to turn back on MWI with extension.

Now if you manually disable MWI through SA page, the check mark is gone, and the MWI field extension box is GONE!!!! SO if you try to use bulk edit to enable MWI, even the log says it success, it didn't update the datebase at all.

It looks a bug to me also.

146
Views
0
Helpful
6
Replies
CreatePlease to create content