Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

busy tone in Live Record

Hi dears

I have a 2811 router with NM-CUE module on it and I run CME 8.6,

I have a problem for live record,

When I press live record key I only hear busy tone,                  

no device is using 100 and 130 EX

This is all my config:

CME# show run

ip dhcp excluded-address 210.10.10.1 210.10.10.100
!
ip dhcp pool MPS
network 210.10.10.0 255.255.255.0
default-router 210.10.10.1
dns-server 8.8.8.8 4.2.2.4
lease 7
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
!
voice-card 0
!
username test privilege 15 password 0 test
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 210.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
ip address X.X.X.X 255.255.255.248
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
!
interface Integrated-Service-Engine1/0
ip unnumbered Loopback0
service-module ip address 10.10.10.2 255.255.255.0
Application: CUE Running on NME
service-module ip default-gateway 10.10.10.1
no keepalive
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/CME8.6/GUI
!        
ip nat translation timeout 600
ip nat translation syn-timeout 20
ip nat translation max-entries 2147483647
ip nat inside source list NAT-MPS interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 X.X.X.X
ip route 10.10.10.2 255.255.255.255 Integrated-Service-Engine1/0
!
ip access-list standard NAT-MPS
permit 210.10.10.0 0.0.0.255
deny   any
!
dial-peer voice 100 voip
destination-pattern 100
session target ipv4:10.10.10.2
dtmf-relay cisco-rtp
no vad
!
gatekeeper
shutdown
!        
telephony-service
conference hardware
no auto-reg-ephone
max-ephones 42
max-dn 144
ip source-address 210.10.10.1 port 2000
service phone videoCapability 1
system message LAb_CUE
cnf-file location flash:
live-record 130
voicemail 100

max-conferences 8 gain -6
web admin system name test secret 5 $1$d2o2$gAlkeZgStbsZOo8tiuHqJ/
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp 7960 May 27 2012 16:49:53
!
ephone-template  1
softkeys connected  Hold Endcall Confrn LiveRcd Park Trnsfer Join
!
ephone-template  2
softkeys connected  Endcall LiveRcd
!
ephone-dn  1  dual-line
number 101 secondary 102
pickup-group 10
label sale
name sale
allow watch
!
ephone-dn  2  dual-line
number 103 secondary 104
pickup-group 10
label manager
name manager
allow watch
!
ephone-dn  50  octo-line
number 130
label live
description live-record
name record
call-forward all 100
call-forward busy 100
call-forward noan 100 timeout 3

!        
ephone  1
device-security-mode none
video
mac-address 0021.70DD.EFEF
ephone-template 1
type CIPC
button  1:1
!
ephone  2
device-security-mode none
video
mac-address 0024.BEC3.EFEF
ephone-template 2
type CIPC
button  1:2
!
line con 0
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
privilege level 15
transport input telnet ssh
line vty 5
transport input all
transport output all
!
scheduler allocate 20000 1000
ntp server 210.10.10.1
end
===================================================================
CUE# show run

system language preferred "en_GB"
software download server url "ftp://127.0.0.1/ftp" credentials hidden "6u/dKTN/hsEuSAEfw40XlF2eFHnZfyUTSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmP"

log trace local enable

site name local
site-hostname 210.10.10.1
web credentials hidden "c9yem6kD1vK+vbW+7/JZ+knfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmP"
end site

license agent max-sessions 9

privilege ViewHistoricalReports create
privilege ViewRealTimeReports create
privilege ManagePublicList create
privilege local-broadcast create
privilege vm-imap create
privilege ViewPrivateList create
privilege manage-users create
privilege manage-passwords create
privilege broadcast create
privilege ManagePrompts create

groupname Broadcasters create

username test create

privilege ViewHistoricalReports description "Privilege to view historical reports"
privilege ViewRealTimeReports description "Privilege to view realtime reports"
privilege ManagePublicList description "Privilege to manage public lists"
privilege local-broadcast description "Privilege to send local broadcast messages"
privilege vm-imap description "Privilege to manage personal voicemail via IMAP client"
privilege ViewPrivateList description "Privilege to view private list"
privilege manage-users description "Privilege to create, modify, and delete users and groups"
privilege manage-passwords description "Privilege to reset user passwords"
privilege broadcast description "Privilege to send local or remote broadcast messages"
privilege ManagePrompts description "Privilege to create, modify, or delete system prompts"
privilege ViewHistoricalReports operation report.historical.view
privilege ViewRealTimeReports operation report.realtime
privilege ManagePublicList operation voicemail.lists.public
privilege ManagePublicList operation system.debug
privilege local-broadcast operation system.debug
privilege local-broadcast operation broadcast.local
privilege vm-imap operation voicemail.imap.user
privilege ViewPrivateList operation voicemail.lists.private.view
privilege manage-users operation user.pin
privilege manage-users operation user.configuration
privilege manage-users operation user.notification
privilege manage-users operation group.configuration
privilege manage-users operation user.remote
privilege manage-users operation user.mailbox
privilege manage-users operation user.password
privilege manage-users operation system.debug
privilege manage-passwords operation user.pin
privilege manage-passwords operation user.password
privilege manage-passwords operation system.debug
privilege broadcast operation broadcast.remote
privilege broadcast operation system.debug
privilege broadcast operation broadcast.local
privilege ManagePrompts operation prompt.modify
privilege ManagePrompts operation system.debug

groupname Administrators member admin
groupname Broadcasters privilege broadcast

restriction msg-notification create
restriction msg-notification min-digits 1
restriction msg-notification max-digits 30
restriction msg-notification dial-string preference 1 pattern * allowed

backup server url "ftp://210.10.10.1/flash:" credentials hidden "EWlTygcMhYmjazXhE/VNXHCkplVV4KjescbDaLa4fl4WLSPFvv1rWUnfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmP"

calendar biz-schedule systemschedule
open day 1 from 00:00 to 24:00
open day 2 from 00:00 to 24:00
open day 3 from 00:00 to 24:00
open day 4 from 00:00 to 24:00
open day 5 from 00:00 to 24:00
open day 6 from 00:00 to 24:00
open day 7 from 00:00 to 24:00
end schedule

ccn application 100 aa
description "100"
enabled
maxsessions 24
end application

ccn application autoattendant aa
description "autoattendant"
enabled
maxsessions 24
script "aa.aef"
parameter "dialByExtnAnytime" "false"
parameter "busOpenPrompt" "AABusinessOpen.wav"
parameter "dialByExtnAnytimeInputLength" "4"
parameter "operExtn" ""
parameter "welcomePrompt" "AAWelcome.wav"
parameter "disconnectAfterMenu" "false"
parameter "dialByFirstName" "false"
parameter "busClosedPrompt" "AABusinessClosed.wav"
parameter "allowExternalTransfers" "false"
parameter "holidayPrompt" "AAHolidayPrompt.wav"
parameter "businessSchedule" "systemschedule"
parameter "MaxRetry" "3"
end application

ccn application ciscomwiapplication aa
description "ciscomwiapplication"
enabled
maxsessions 24
script "setmwi.aef"
parameter "CallControlGroupID" "0"
parameter "strMWI_OFF_DN" "8001"
parameter "strMWI_ON_DN" "8000"
end application

ccn application msgnotification aa
description "msgnotification"
enabled
maxsessions 24
script "msgnotify.aef"
parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
parameter "DelayBeforeSendDTMF" "1"
end application

ccn application promptmgmt aa
description "promptmgmt"
enabled
maxsessions 24
script "promptmgmt.aef"
parameter "appManagementScript" ""
end application

ccn application voicemail aa
description "voicemail"
enabled
maxsessions 24
script "voicebrowser.aef"
parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
end application

ccn engine
end engine

ccn reporting historical
database local
description "se-10-10-10-2"
end reporting

ccn subsystem email
end subsystem

ccn subsystem fax
end subsystem

ccn subsystem sip
gateway address "210.10.10.1"
end subsystem

ccn trigger http urlname msgnotifytrg
application "msgnotification"
enabled
maxsessions 2
end trigger

ccn trigger http urlname mwiapp
application "ciscomwiapplication"
enabled
maxsessions 1
end trigger

ccn trigger sip phonenumber 100
application "voicemail"
enabled
maxsessions 4
end trigger

network location id "112"
no enable
end location

service phone-authentication
end phone-authentication

service voiceview
enable
end voiceview

voicemail callerid
voicemail message mandatory-expiry
voicemail broadcast recording time 300
voicemail default messagesize 240
voicemail notification restriction msg-notification
voicemail operator telephone 100
voicemail live-record beep duration 50
voicemail live-record beep interval 30
voicemail live-record pilot-number 130
voicemail live-reply enable
voicemail live-reply calling-number-rule location-extension
voicemail live-reply network-precedence calling-number-rule

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: busy tone in Live Record

You will also need to configure the dial-peer for SIP like this:

dial-peer voice 100 voip

session protocol sipv2

session target ipv4:10.10.10.2

codec g711u

no vad

dtmf-relay sip-notify

destination-pattern 100

Then also add:

voice service voip

sip

bind all source interface

That should get calls working to CUE.  Then MWI won't work with the current config so I usually like to use unsolicited notify like this.

sip-ua

mwi-server unsolicited

7 REPLIES
Cisco Employee

Re: busy tone in Live Record

On your dial-peer 100 set codec g711u since cue only supports g711.

Sent from Cisco Technical Support iPhone App

Cisco Employee

Re: busy tone in Live Record

Also does voicemail access work pressing the messages button? It doesn't look like it would from the config. I would setup a sip bind interface as well as set the dial peer to cue to be session protocol sipv2.

Sent from Cisco Technical Support iPhone App

New Member

busy tone in Live Record

Hi dear Joe

Thank you for your guide

I change dial peer 100 config to this:

dial-peer voice 100 voip

destination-pattern 100

session target ipv4:10.10.10.2

dtmf-relay cisco-rtp

codec g711ulaw

no vad

But it does not work yet, when I press the messages button I hear busy tone and show me a lable "unknown number".

Cisco Employee

Re: busy tone in Live Record

You will also need to configure the dial-peer for SIP like this:

dial-peer voice 100 voip

session protocol sipv2

session target ipv4:10.10.10.2

codec g711u

no vad

dtmf-relay sip-notify

destination-pattern 100

Then also add:

voice service voip

sip

bind all source interface

That should get calls working to CUE.  Then MWI won't work with the current config so I usually like to use unsolicited notify like this.

sip-ua

mwi-server unsolicited

New Member

busy tone in Live Record

Thank you very much for guide

I changed my config as the same your said

Button messages can be connect to voice mail, but does not work or record, I hear "inter your id"

And when press live record I hear "there is no mail box associated to the this extension, goodbye".

Cisco Employee

busy tone in Live Record

Now it sounds like the only things left are to create a mailbox for the user who is trying to initiate live record and make sure the live record number is configured in CUE.

New Member

busy tone in Live Record

Hi dear Joe

I have 5 agents exactly, they have some calls from out of here, I mean other people call them,

I want my live recorder saves all of those conversations,

Can you please guide me about the exact commands that I should use?

Every thing are ok and only the Voice recorder does not work.

Thank you very much

670
Views
0
Helpful
7
Replies
CreatePlease login to create content