cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1225
Views
0
Helpful
8
Replies

Calls going out displaying extra digits to called party

zrunner626
Level 1
Level 1

I have calls going out of one of our offices that have extra digits appended to the end. Instead of caller id showing the 10 digits of the calling party, it shows 15 repeating the last 5 digits again. If my number was 1234567890, it goes out 123456789067890. Obviously that looks strange and the called party often times doesn't answer. I've been comparing with some of our other sites but I don't see anything obvious. I'm new to voice, I've looked at the dial peer and translation rule on our gateway for that site. Where else should I be looking for this problem. AT&T says they aren't sending the extra digits.

Thanks

1 Accepted Solution

Accepted Solutions

This:

voice translation-rule 2
 rule 1 /^2..../ /2147651234/

Is changing "2147651234" calling number to "214765123451234" by replacing "214765" with "2147651234". This is likely meant to be replacing a 5-digit extension starting with 2 with the equivalent 10-digit DID. I would try the following instead:

voice translation-rule 2
 rule 1 /^2....$/ /2147651234/

The dollar sign will ensure that the rule only matches on 5 digits, not on more.

-Jameson

-Jameson

View solution in original post

8 Replies 8

Jaime Valencia
Cisco Employee
Cisco Employee

Start by running some debugs to find if you're the one sending those extra digits, or if you're actually sending the right ANI and somewhere along the way it's being modified.

HTH

java

if this helps, please rate

Which debugs would your run?

Thanks

debug voice ccapi inout is probably your most useful debug here, but It would really depend on how your gateway is set up.

 

Is it MGCP, H323, SIP? Is your PSTN connectivity via ISDN / SIP?

 

For example, if your gateway is H323 connected to ISDN, you can also run debug isdn q931

 

If you have a SIP gateway / PSTN provider, then use debug ccsip messages

 

If you post your config and debug outputs, we can be of more help.

 

Regards

Sean

Here is the log from a test call after enabling the debugs. Sequence# 095713 includes the extra digits. Thanks for the help.


095693: Sep 30 09:48:53.467 CST: //-1/00E60F465903/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=Dallas Main Number
   ----- ccCallInfo IE subfields -----
   cisco-ani=2147651234
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=1
   dest=917139074321
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=-1
   cisco-rdnplan=-1
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

095694: Sep 30 09:48:53.467 CST: //-1/00E60F465903/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x4A04DDA4, Call Info(
   Calling Number=2147651234,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=917139074321(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=101, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=27508
095695: Sep 30 09:48:53.467 CST: //-1/00E60F465903/CCAPI/ccCheckClipClir:
   In: Calling Number=2147651234(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
095696: Sep 30 09:48:53.467 CST: //-1/00E60F465903/CCAPI/ccCheckClipClir:
   Out: Calling Number=2147651234(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
095697: Sep 30 09:48:53.467 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
095698: Sep 30 09:48:53.467 CST: :cc_get_feature_vsa malloc success
095699: Sep 30 09:48:53.467 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
095700: Sep 30 09:48:53.467 CST:  cc_get_feature_vsa count is 3
095701: Sep 30 09:48:53.467 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
095702: Sep 30 09:48:53.467 CST: :FEATURE_VSA attributes are: feature_name:0,feature_time:1309707448,feature_id:27508
095703: Sep 30 09:48:53.467 CST: //27508/00E60F465903/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=2147651234(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=917139074321(TON=Unknown, NPI=Unknown))
095704: Sep 30 09:48:53.471 CST: //27508/00E60F465903/CCAPI/cc_process_call_setup_ind:
   Event=0x4B77BFD0
095705: Sep 30 09:48:53.471 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 917139074321
095706: Sep 30 09:48:53.471 CST: //27508/00E60F465903/CCAPI/ccCallSetContext:
   Context=0x4E138418
095707: Sep 30 09:48:53.471 CST: //27508/00E60F465903/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 27508 with tag 101 to app "_ManagedAppProcess_Default"
095708: Sep 30 09:48:53.471 CST: //27508/00E60F465903/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
095709: Sep 30 09:48:53.475 CST: //27508/00E60F465903/CCAPI/ccCallSetupRequest:
   Destination=, Calling IE Present=TRUE, Mode=0,
   Outgoing Dial-peer=91, Params=0x4E1276A8, Progress Indication=NULL(0)
095710: Sep 30 09:48:53.475 CST: //27508/00E60F465903/CCAPI/ccCheckClipClir:
   In: Calling Number=214765123451234(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
095711: Sep 30 09:48:53.475 CST: //27508/00E60F465903/CCAPI/ccCheckClipClir:
   Out: Calling Number=214765123451234(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
095712: Sep 30 09:48:53.475 CST: //27508/00E60F465903/CCAPI/ccCallSetupRequest:
   Destination Pattern=91[2-9].........$, Called Number=917139074321, Digit Strip=TRUE
095713: Sep 30 09:48:53.475 CST: //27508/00E60F465903/CCAPI/ccCallSetupRequest:
   Calling Number=214765123451234(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=917139074321(TON=Unknown, NPI=Unknown),
   Redirect Number=, Display Info=Dallas Main Number
   Account Number=Dallas Main Number, Final Destination Flag=TRUE,
   Guid=00E60F46-E5D0-A142-5903-1B030A0A023F, Outgoing Dial-peer=91
095714: Sep 30 09:48:53.475 CST: //27508/00E60F465903/CCAPI/cc_api_display_ie_subfields:
   ccCallSetupRequest:
   cisco-username=Dallas Main Number
   ----- ccCallInfo IE subfields -----
   cisco-ani=214765123451234
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=1
   dest=917139074321
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=-1
   cisco-rdnplan=-1
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

095715: Sep 30 09:48:53.475 CST: //27508/00E60F465903/CCAPI/ccIFCallSetupRequestPrivate:
   Interface=0x4B7C2F08, Interface Type=6, Destination=, Mode=0x0,
   Call Params(Calling Number=214765123451234,(Calling Name=Dallas Main Number)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=917139074321(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
   Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE, Outgoing Dial-peer=91, Call Count On=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
095716: Sep 30 09:48:53.475 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
095717: Sep 30 09:48:53.479 CST: :cc_get_feature_vsa malloc success
095718: Sep 30 09:48:53.479 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
095719: Sep 30 09:48:53.479 CST:  cc_get_feature_vsa count is 4
095720: Sep 30 09:48:53.479 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
095721: Sep 30 09:48:53.479 CST: :FEATURE_VSA attributes are: feature_name:0,feature_time:1309709240,feature_id:27509
095722: Sep 30 09:48:53.479 CST: //27509/00E60F465903/CCAPI/ccIFCallSetupRequestPrivate:
   SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1
095723: Sep 30 09:48:53.479 CST: //27509/00E60F465903/CCAPI/ccCallSetContext:
   Context=0x4E127658
095724: Sep 30 09:48:53.479 CST: //27508/00E60F465903/CCAPI/ccSaveDialpeerTag:
   Outgoing Dial-peer=91
095725: Sep 30 09:48:53.483 CST: ISDN Se0/0/0:23 Q931: pak_private_number: Invalid type/plan 0x0 0x0 may be overriden; sw-type 13
095726: Sep 30 09:48:53.483 CST: ISDN Se0/0/0:23 Q931: Applying typeplan for sw-type 0xD is 0x1 0x1, Calling num 214765123451234
095727: Sep 30 09:48:53.487 CST: ISDN Se0/0/0:23 Q931: Sending SETUP  callref = 0x13D3 callID = 0x9354 switch = primary-ni interface = User
095728: Sep 30 09:48:53.487 CST: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8  callref = 0x13D3
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech  
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98397
                Exclusive, Channel 23
        Display i = 'Dallas Main Number'
        Calling Party Number i = 0x1181, '214765123451234'
                Plan:ISDN, Type:International
        Called Party Number i = 0x80, '17139074321'
                Plan:Unknown, Type:Unknown
095729: Sep 30 09:48:53.551 CST: ISDN Se0/0/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x93D3
        Channel ID i = 0xA98397
                Exclusive, Channel 23
095730: Sep 30 09:48:53.579 CST: //27509/00E60F465903/CCAPI/cc_api_call_proceeding:
   Interface=0x4B7C2F08, Progress Indication=NULL(0)
095731: Sep 30 09:48:55.295 CST: ISDN Se0/0/0:23 Q931: RX <- ALERTING pd = 8  callref = 0x93D3
        Progress Ind i = 0x8488 - In-band info or appropriate now available
095732: Sep 30 09:48:55.295 CST: //27509/00E60F465903/CCAPI/cc_api_call_alert:
   Interface=0x4B7C2F08, Progress Indication=INBAND(8), Signal Indication=SIGNAL RINGBACK(1)
095733: Sep 30 09:48:55.295 CST: //27509/00E60F465903/CCAPI/cc_api_call_alert:
   Call Entry(Retry Count=0, Responsed=TRUE)
095734: Sep 30 09:48:55.299 CST: //27508/00E60F465903/CCAPI/ccCallAlert:
   Progress Indication=INBAND(8), Signal Indication=SIGNAL RINGBACK(1)
095735: Sep 30 09:48:55.299 CST: //27508/00E60F465903/CCAPI/ccCallAlert:
   Call Entry(Responsed=TRUE, Alert Sent=TRUE)
095736: Sep 30 09:48:55.299 CST: //27509/00E60F465903/CCAPI/cc_api_get_called_ccm_detected:
   CallInfo(ccm detected=0)
095737: Sep 30 09:48:55.299 CST: //27508/00E60F465903/CCAPI/ccConferenceCreate:
   (confID=0x4E1EE068, callID1=0x6B74, gcid=0-0-0-0, tag=0x0)
095738: Sep 30 09:48:55.299 CST: //27509/00E60F465903/CCAPI/ccConferenceCreate:
   (confID=0x4E1EE068, callID2=0x6B75, gcid=0-0-0-0, tag=0x0)
095739: Sep 30 09:48:55.299 CST: //27508/00E60F465903/CCAPI/ccConferenceCreate:
   Conference Id=0x4E1EE068, Call Id1=27508, Call Id2=27509, Tag=0x0
095740: Sep 30 09:48:55.299 CST: //27508/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
095741: Sep 30 09:48:55.299 CST: cc_api_get_xcode_stream : 4702
095742: Sep 30 09:48:55.299 CST: //27508/00E60F465903/CCAPI/cc_api_bridge_done:
   Conference Id=0x2A56, Source Interface=0x4A04DDA4, Source Call Id=27508,
   Destination Call Id=27509, Disposition=0x0, Tag=0x0
095743: Sep 30 09:48:55.299 CST: //27509/00E60F465903/CCAPI/cc_api_bridge_done:
   Conference Id=0x2A56, Source Interface=0x4B7C2F08, Source Call Id=27509,
   Destination Call Id=27508, Disposition=0x0, Tag=0xFFFFFFFF
095744: Sep 30 09:48:55.299 CST: //27508/00E60F465903/CCAPI/cc_generic_bridge_done:
   Conference Id=0x2A56, Source Interface=0x4B7C2F08, Source Call Id=27509,
   Destination Call Id=27508, Disposition=0x0, Tag=0xFFFFFFFF
095745: Sep 30 09:48:55.299 CST: //27508/00E60F465903/CCAPI/ccConferenceCreate:
   Call Entry(Conference Id=0x2A56, Destination Call Id=27509)
095746: Sep 30 09:48:55.299 CST: //27509/00E60F465903/CCAPI/ccConferenceCreate:
   Call Entry(Conference Id=0x2A56, Destination Call Id=27508)
095747: Sep 30 09:48:55.299 CST: //27509/00E60F465903/CCAPI/cc_api_caps_ind:
   Destination Interface=0x4A04DDA4, Destination Call Id=27508, Source Call Id=27509,
   Caps(Codec=0x1, Fax Rate=0x1, Vad=0x1,
   Modem=0x2, Codec Bytes=20, Signal Type=3)
095748: Sep 30 09:48:55.303 CST: //27509/00E60F465903/CCAPI/cc_api_caps_ind:
   Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),
   Playout Max=1000(ms), Fax Nom=300(ms))
095749: Sep 30 09:48:55.303 CST: //27508/00E60F465903/CCAPI/ccCallNotify:
   Data Bitmask=0x7, Call Id=27508
095750: Sep 30 09:48:55.303 CST: //27509/00E60F465903/CCAPI/cc_api_get_called_ccm_detected:
   CallInfo(ccm detected=0)
095751: Sep 30 09:48:55.303 CST: //27508/00E60F465903/CCAPI/cc_api_get_delay_xport:
   CallInfo(delay xport=FALSE)
095752: Sep 30 09:48:55.311 CST: //27508/00E60F465903/CCAPI/cc_process_notify_bridge_done:
   Conference Id=0x2A56, Call Id1=27508, Call Id2=27509
095753: Sep 30 09:48:55.811 CST: //27508/00E60F465903/CCAPI/cc_api_caps_ind:
   Destination Interface=0x4B7C2F08, Destination Call Id=27509, Source Call Id=27508,
   Caps(Codec=0x1, Fax Rate=0x80, Vad=0x1,
   Modem=0x0, Codec Bytes=160, Signal Type=2)
095754: Sep 30 09:48:55.811 CST: //27508/00E60F465903/CCAPI/cc_api_caps_ind:
   Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),
   Playout Max=1000(ms), Fax Nom=300(ms))
095755: Sep 30 09:48:55.811 CST: //27508/00E60F465903/CCAPI/cc_api_caps_ack:
   Destination Interface=0x4B7C2F08, Destination Call Id=27509, Source Call Id=27508,
   Caps(Codec=g711ulaw(0x1), Fax Rate=FAX_RATE_14400(0x80), Vad=OFF(0x1),
   Modem=OFF(0x0), Codec Bytes=160, Signal Type=2, Seq Num Start=8122)
095756: Sep 30 09:48:55.815 CST: //27509/00E60F465903/CCAPI/cc_api_caps_ack:
   Destination Interface=0x4A04DDA4, Destination Call Id=27508, Source Call Id=27509,
   Caps(Codec=g711ulaw(0x1), Fax Rate=FAX_RATE_14400(0x80), Vad=OFF(0x1),
   Modem=OFF(0x0), Codec Bytes=160, Signal Type=2, Seq Num Start=8122)
095757: Sep 30 09:48:55.819 CST: //27509/00E60F465903/CCAPI/cc_api_voice_mode_event:
   Call Id=27509
095758: Sep 30 09:48:55.819 CST: //27509/00E60F465903/CCAPI/cc_api_voice_mode_event:
   Call Entry(Context=0x4E127658)
095759: Sep 30 09:49:03.691 CST: //27507/E25C9BF99854/CCAPI/cc_api_call_disconnected:
   Cause Value=16, Interface=0x4A04DDA4, Call Id=27507
095760: Sep 30 09:49:03.695 CST: //27507/E25C9BF99854/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=16, Retry Count=0)
095761: Sep 30 09:49:03.695 CST: //27506/E25C9BF99854/CCAPI/ccConferenceDestroy:
   Conference Id=0x2A55, Tag=0x0
095762: Sep 30 09:49:03.695 CST: //27506/E25C9BF99854/CCAPI/cc_api_bridge_drop_done:
   Conference Id=0x2A55, Source Interface=0x4B7C2F08, Source Call Id=27506,
   Destination Call Id=27507, Disposition=0x0, Tag=0x0
095763: Sep 30 09:49:03.695 CST: //27507/E25C9BF99854/CCAPI/cc_api_bridge_drop_done:
   Conference Id=0x2A55, Source Interface=0x4A04DDA4, Source Call Id=27507,
   Destination Call Id=27506, Disposition=0x0, Tag=0x0
095764: Sep 30 09:49:03.695 CST: //27506/E25C9BF99854/CCAPI/cc_generic_bridge_done:
   Conference Id=0x2A55, Source Interface=0x4A04DDA4, Source Call Id=27507,
   Destination Call Id=27506, Disposition=0x0, Tag=0x0
095765: Sep 30 09:49:03.695 CST: //27506/E25C9BF99854/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
095766: Sep 30 09:49:03.695 CST: //27506/E25C9BF99854/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
095767: Sep 30 09:49:03.695 CST: //27506/E25C9BF99854/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
095768: Sep 30 09:49:03.695 CST: //27507/E25C9BF99854/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=16)
095769: Sep 30 09:49:03.695 CST: //27507/E25C9BF99854/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
095770: Sep 30 09:49:03.699 CST: //27507/E25C9BF99854/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
095771: Sep 30 09:49:03.719 CST: //27507/E25C9BF99854/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
095772: Sep 30 09:49:03.723 CST: //27507/E25C9BF99854/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x4A04DDA4, Tag=0x0, Call Id=27507,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
095773: Sep 30 09:49:03.723 CST: //27507/E25C9BF99854/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
095774: Sep 30 09:49:03.723 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
095775: Sep 30 09:49:03.723 CST: :cc_free_feature_vsa freeing 4E108850
095776: Sep 30 09:49:03.723 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
095777: Sep 30 09:49:03.723 CST:  vsacount in free is 3
095778: Sep 30 09:49:03.727 CST: %ISDN-6-DISCONNECT: Interface Serial0/0/0:0  disconnected from 2147662349 , call lasted 105 seconds
095779: Sep 30 09:49:03.731 CST: ISDN Se0/0/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x833F
        Cause i = 0x8090 - Normal call clearing
095780: Sep 30 09:49:03.759 CST: ISDN Se0/0/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x033F
095781: Sep 30 09:49:03.759 CST: ISDN Se0/0/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x833F
095782: Sep 30 09:49:03.767 CST: //27506/E25C9BF99854/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x4B7C2F08, Tag=0x0, Call Id=27506,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
095783: Sep 30 09:49:03.767 CST: //27506/E25C9BF99854/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
095784: Sep 30 09:49:03.767 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
095785: Sep 30 09:49:03.767 CST: :cc_free_feature_vsa freeing 4E109570
095786: Sep 30 09:49:03.767 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
095787: Sep 30 09:49:03.767 CST:  vsacount in free is 2
095788: Sep 30 09:49:13.991 CST: ISDN Se0/0/0:23 Q931: RX <- CONNECT pd = 8  callref = 0x93D3
        Progress Ind i = 0x8482 - Destination address is non-ISDN
095789: Sep 30 09:49:13.995 CST: %ISDN-6-CONNECT: Interface Serial0/0/0:22 is now connected to 17139074321 N/A
095790: Sep 30 09:49:13.995 CST: ISDN Se0/0/0:23 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x13D3
095791: Sep 30 09:49:13.995 CST: //27509/00E60F465903/CCAPI/cc_api_call_connected:
   Interface=0x4B7C2F08, Data Bitmask=0x1, Progress Indication=DESTINATION IS NON ISDN(2),
   Connection Handle=0
095792: Sep 30 09:49:13.999 CST: //27509/00E60F465903/CCAPI/cc_api_call_connected:
   Call Entry(Connected=TRUE, Responsed=TRUE, Retry Count=0)
095793: Sep 30 09:49:13.999 CST: //27508/00E60F465903/CCAPI/ccCallConnect:
   Progress Indication=DESTINATION IS NON ISDN(2), Data Bitmask=0x1
095794: Sep 30 09:49:13.999 CST: //27509/00E60F465903/CCAPI/cc_api_get_called_ccm_detected:
   CallInfo(ccm detected=0)
095795: Sep 30 09:49:13.999 CST: //27508/00E60F465903/CCAPI/ccCallConnect:
   Call Entry(Connected=TRUE, Responsed=TRUE)
095796: Sep 30 09:49:13.999 CST: //27508/00E60F465903/CCAPI/ccCallNotify:
   Data Bitmask=0x7, Call Id=27508
095797: Sep 30 09:49:13.999 CST: //27509/00E60F465903/CCAPI/cc_api_get_called_ccm_detected:
   CallInfo(ccm detected=0)
095798: Sep 30 09:49:33.319 CST: //27508/00E60F465903/CCAPI/cc_api_call_disconnected:
   Cause Value=16, Interface=0x4A04DDA4, Call Id=27508
095799: Sep 30 09:49:33.323 CST: //27508/00E60F465903/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=16, Retry Count=0)
095800: Sep 30 09:49:33.323 CST: //27508/00E60F465903/CCAPI/ccConferenceDestroy:
   Conference Id=0x2A56, Tag=0x0
095801: Sep 30 09:49:33.323 CST: //27508/00E60F465903/CCAPI/cc_api_bridge_drop_done:
   Conference Id=0x2A56, Source Interface=0x4A04DDA4, Source Call Id=27508,
   Destination Call Id=27509, Disposition=0x0, Tag=0x0
095802: Sep 30 09:49:33.323 CST: //27509/00E60F465903/CCAPI/cc_api_bridge_drop_done:
   Conference Id=0x2A56, Source Interface=0x4B7C2F08, Source Call Id=27509,
   Destination Call Id=27508, Disposition=0x0, Tag=0x0
095803: Sep 30 09:49:33.323 CST: //27508/00E60F465903/CCAPI/cc_generic_bridge_done:
   Conference Id=0x2A56, Source Interface=0x4B7C2F08, Source Call Id=27509,
   Destination Call Id=27508, Disposition=0x0, Tag=0x0
095804: Sep 30 09:49:33.327 CST: //27508/00E60F465903/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=16)
095805: Sep 30 09:49:33.327 CST: //27508/00E60F465903/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
095806: Sep 30 09:49:33.327 CST: //27508/00E60F465903/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
095807: Sep 30 09:49:33.327 CST: //27509/00E60F465903/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
095808: Sep 30 09:49:33.327 CST: //27509/00E60F465903/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
095809: Sep 30 09:49:33.327 CST: //27509/00E60F465903/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
095810: Sep 30 09:49:33.351 CST: //27508/00E60F465903/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
095811: Sep 30 09:49:33.355 CST: //27508/00E60F465903/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x4A04DDA4, Tag=0x0, Call Id=27508,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
095812: Sep 30 09:49:33.355 CST: //27508/00E60F465903/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
095813: Sep 30 09:49:33.355 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
095814: Sep 30 09:49:33.355 CST: :cc_free_feature_vsa freeing 4E108CB0
095815: Sep 30 09:49:33.355 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
095816: Sep 30 09:49:33.355 CST:  vsacount in free is 1
095817: Sep 30 09:49:33.363 CST: %ISDN-6-DISCONNECT: Interface Serial0/0/0:22  disconnected from 17139074321 , call lasted 19 seconds
095818: Sep 30 09:49:33.363 CST: ISDN Se0/0/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x13D3
        Cause i = 0x8090 - Normal call clearing
095819: Sep 30 09:49:33.399 CST: ISDN Se0/0/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x93D3
095820: Sep 30 09:49:33.399 CST: ISDN Se0/0/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x13D3
095821: Sep 30 09:49:33.403 CST: //27509/00E60F465903/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x4B7C2F08, Tag=0x0, Call Id=27509,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
095822: Sep 30 09:49:33.403 CST: //27509/00E60F465903/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
095823: Sep 30 09:49:33.403 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
095824: Sep 30 09:49:33.403 CST: :cc_free_feature_vsa freeing 4E1093B0
095825: Sep 30 09:49:33.403 CST: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
095826: Sep 30 09:49:33.403 CST:  vsacount in free is 0
 

 

So, from this, we can tell that your Call Manager is sending the correct number to the gateway. The gateway is matching outgoing dial-peer 91 and then something is happening. Do you have an outgoing translation on this dial-peer? Please upload your config.

 

Regards

Sean

...truncated

clock timezone CST -6 0
clock summer-time CST date Mar 11 2012 2:00 Nov 4 2012 2:00
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-participate wic 3
network-clock-select 3 T1 0/0/0

!
isdn switch-type primary-ni
!
!
!
voice service voip
 ip address trusted list
  ipv4 X.x.x.x x.x.x.x
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  call start slow
  h245 tunnel disable
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
!
voice class h323 1
  h225 timeout tcp establish 3
  h225 timeout setup 3
!
!
!
!
voice translation-rule 1
 rule 1 /911/ //
!
voice translation-rule 2
 rule 1 /^2..../ /2147651234/
!
!
voice translation-profile 1
 translate calling 1
!
voice translation-profile srst
 translate calling 2
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!

!
!
controller T1 0/0/0
 fdl both
 pri-group timeslots 1-24
!
controller T1 0/1/0
 fdl both
 channel-group 0 timeslots 1-24
!
controller T1 0/3/0
 fdl both
 channel-group 0 timeslots 1-24
!
controller T1 0/3/1
 fdl both
 channel-group 0 timeslots 1-24
!
ip tcp synwait-time 10

!
class-map match-any critical
 match ip dscp cs3
 match ip dscp af31
 match ip dscp af21
class-map match-any realtime
 match ip dscp ef
 match ip dscp af41
!
!
policy-map LAN
 class realtime
  set ip dscp ef
 class critical
  set ip dscp cs3
 class class-default
  set ip dscp default
policy-map WAN
 class realtime
  set ip dscp ef
 class critical
  set ip dscp af31
 class class-default
  set ip dscp default
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address x.x.x.x
!
interface Tunnel0
 ip address x.x.x.x
 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination x.x.x.x
!
interface Null0
 no ip unreachables
!
interface GigabitEthernet0/0
 description Dallas LAN
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip wccp 61 redirect in
 ip flow ingress
 ip pim sparse-dense-mode
 duplex auto
 speed auto
 no cdp enable
 no mop enabled
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address x.x.x.x
 ip wccp 61 redirect in
 ip flow ingress
 ip pim sparse-dense-mode
 service-policy input WAN
 service-policy output LAN
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 2
 ip address x.x.x.x
 ip wccp 61 redirect in
 ip flow ingress
 ip pim sparse-dense-mode
 h323-gateway voip interface
 h323-gateway voip bind srcaddr x.x.x.x
 service-policy input WAN
 service-policy output LAN
!
interface GigabitEthernet0/0.5
 description WAAS
 encapsulation dot1Q 5
 ip address x.x.x.x
 ip flow ingress
!
interface GigabitEthernet0/1
 description MPLS
 ip address x.x.x.x
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip wccp 62 redirect in
 ip flow ingress
 duplex full
 speed 10
 no cdp enable
 no mop enabled
 service-policy input LAN
 service-policy output WAN
!
interface Serial0/0/0:23
 description AT&T
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn outgoing display-ie
 no cdp enable
!
interface Serial0/1/0:0
 no ip address
 ip pim sparse-dense-mode
 shutdown
!
interface Serial0/3/0:0
 no ip address
 shutdown
 no keepalive
!
interface Serial0/3/1:0
 no ip address
 shutdown
 no keepalive

ip forward-protocol nd

control-plane
!
!
voice-port 0/0/0:23
!
ccm-manager music-on-hold
!
!
mgcp profile default
!
sccp local GigabitEthernet0/0.2
sccp ccm x.x.x.x identifier 2 version 7.0
sccp ccm x.x.x.x identifier 1 version 7.0
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/0.2
 associate ccm 2 priority 1
 associate ccm 1 priority 2
 associate profile 1 register CFB000f352db039
!
dspfarm profile 1 conference  
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 12
 associate application SCCP
!
dial-peer voice 100 pots
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
!
dial-peer voice 911 pots
 translation-profile outgoing srst
 destination-pattern 911
 direct-inward-dial
 port 0/0/0:23
 forward-digits 3
!
dial-peer voice 9911 pots
 translation-profile outgoing srst
 destination-pattern 9911
 direct-inward-dial
 port 0/0/0:23
 forward-digits 3
!
dial-peer voice 97 pots
 translation-profile outgoing srst
 destination-pattern 9[2-9]......$
 direct-inward-dial
 port 0/0/0:23
 forward-digits 7
!
dial-peer voice 91 pots
 translation-profile outgoing srst
 destination-pattern 91[2-9].........$
 direct-inward-dial
 port 0/0/0:23
 forward-digits 11
!
dial-peer voice 901 pots
!
dial-peer voice 9011 pots
 translation-profile outgoing srst
 destination-pattern 9011T
 direct-inward-dial
 port 0/0/0:23
 prefix 011
!
dial-peer voice 101 voip
 translation-profile outgoing 1
 preference 2
 destination-pattern [0-8]...$
 session target ipv4:x.x.x.x
 incoming called-number 9T
 voice-class codec 1  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 fax-relay ecm disable
 fax rate 14400
 ip qos dscp cs3 signaling
 no vad
!
dial-peer voice 102 voip
 translation-profile outgoing 1
 preference 3
 destination-pattern [0-8]...$
 session target ipv4:x.x.x.x
 incoming called-number 9T
 voice-class codec 1  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 fax-relay ecm disable
 fax rate 14400
 ip qos dscp cs3 signaling
 no vad
!
dial-peer voice 910 pots
 translation-profile outgoing srst
 destination-pattern 9[2-9].........$
 direct-inward-dial
 port 0/0/0:23
 forward-digits 10
!
!
!
!
gatekeeper
 shutdown
!
!
call-manager-fallback
 secondary-dialtone 9
 max-conferences 8 gain -6
 transfer-system full-consult
 ip source-address x.x.x.x port 2000 strict-match
 max-ephones 96
 max-dn 96 dual-line
 system message primary WAN is Down - Call 800318xxxx
 alias 1 6560 to 28841
 alias 2 0760 to 21599
 call-forward pattern .T
 time-zone 12
!

...truncated

This:

voice translation-rule 2
 rule 1 /^2..../ /2147651234/

Is changing "2147651234" calling number to "214765123451234" by replacing "214765" with "2147651234". This is likely meant to be replacing a 5-digit extension starting with 2 with the equivalent 10-digit DID. I would try the following instead:

voice translation-rule 2
 rule 1 /^2....$/ /2147651234/

The dollar sign will ensure that the rule only matches on 5 digits, not on more.

-Jameson

-Jameson

Thanks guys for the help!!