Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Can't End Active Calll on FXO port

When I first checked the ports they had a VPM_State of FXOLS_REMOTE_RELEASE. I couldn't get any calls to traverse those ports. I did a shut/no shut on those ports and now I have a VPM_State of FXOLS_ONHOOK, but it shows a Codec of g711ulaw and a VTSP_State of S_Connect, although there should be a call on that port. Weird, huh?

Next I check show call active voice brief and it shows a call leg that has a duration of over 3 days on that port. Why do I still have a call on that port if I do a shut/no shut? I can get the port to answer an incomming call, but it doesn't work. Right now I have that port busyout forced.

Anyone have any idea on how to clear the call short of rebooting the router? I'm going to end up doing that tonight anyway, but I want to get this working for the rest of the day. It's actually happening on 3 ports spread across 2 cards. So their 6 phone lines are down to 3 phone lines right now.

I tried to 'clear call voice causecode 32 id 132A' but the call leg still remains. Here is some of the output:

wwfhc-taylor-2821#sh voice call sum


============== ========= === ==================== ======================

0/1/0 g711ulaw n S_CONNECT FXOLS_BUSYOUT

132A : 119 42454960ms.1 +100 pid:0 Answer 7347575257 active

dur 3d00h tx:3066/514929 rx:2820/451200

Tele 0/1/0 (119) [0/1/0] tx:261781670/261781670/0ms g711ulaw noise:-65 acom:6 i/0:-68/-67 dBm

Community Member

Re: Can't End Active Calll on FXO port

You should be able to set the supervisory disconnect on the FXO port on the gateway.

Re: Can't End Active Calll on FXO port

Hi Jacob,

the above command might help

If nothing happen:

It is a bug in your ios

please upgrade to a newer version

wish this be helpful

Community Member

Re: Can't End Active Calll on FXO port

Yeah, I tried those commands and it didn't work. I'm running 12.4(24)T1.

I just upgraded to this version to resolve another issue; guess I'm going back down :)

Community Member

Re: Can't End Active Calll on FXO port

I can't believe I'm the only one having this problem. I see it on two different routers that I manager. TAC has no clue!!

Hall of Fame Super Gold

Re: Can't End Active Calll on FXO port

Buggy IOS, eg 12.4.22 YB5 should be better. It's a telephony-specific release and gets lot more testing.

Plus I have in a all-FXO site w/o trouble so far.

Note, TAC is not really much TAC unless you are adamant on keeping your case P2 all the time, and are talking to "escalation team".

Community Member

Re: Can't End Active Calll on FXO port

I'll give that code a shot. I was running 12.4.22 YB2 orginaially before I upgraded to 12.4.24T1. Let's hope YB5 has the fix for this bug. Thanks for your input!

CreatePlease to create content