Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CCM 5.1 and 2851 VG with 4 fxo

I am trying to configure MGCP so that I can use the fxo's on the VG to allow IP phone users access to long distance and on site extensions through CCM. This would be a 6 to get long distance and the extension to dial on site. I have configured the Gateway and added the fxo ports in Loop Start mode. What else do I need to do. I entered the MGCP, CCM-Manager and Config server commands on my VG. What else do I need to do? When I do a sh ccm-manager I get that the VG is still registering to the CCM. Any help would be great thank you.

3 REPLIES

Re: CCM 5.1 and 2851 VG with 4 fxo

Make sure you have service mgcpapp under the dial-peer and port configured as well on the router. The router if configured with a domain name (using command ip domain-name ABC.com) and the hostname of router is Router01. Then the MGCP gateway name inside Callmanager should be Router01.ABC.com. If there is no domain name configured in the router then your gateway name in CM should be Router01.

See if any of the above is true, if not revert back with your router config and a screen shot of your CM MGCP gateway configuration.

HTH

Sankar

PS: please remember to rate posts!@

New Member

Re: CCM 5.1 and 2851 VG with 4 fxo

I will try this now and reply with my finding s

New Member

Re: CCM 5.1 and 2851 VG with 4 fxo

Below are my configs of the VG. I plugged a phone line into port 0 and if I hit a 9 I get a dial tone but it wont dial anything after. busy after digits are dialed. Do I need to configure a destination-pattern on the dial-peer voice pots? Alos what do I need to do in CCM to allow for 5 digit inter-office dialing and long distance throught the PSTN. Users would dial a 9 to enter any of these two modes.

Here are my configs along with a sh ccm-manager

Current configuration : 3716 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname FallonVG

boot-start-marker

boot-end-marker

logging buffered 51200 warnings

no aaa new-model

resource policy

ip cef

ip domain name yourdomain.com

voice-card 0

no dspfarm

interface Loopback0

no ip address

shutdown

!

interface GigabitEthernet0/0

description "To Centroid Switch"

ip address 10.13.1.2 255.255.0.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

router ospf 100

no log-adjacency-changes

network 10.10.0.0 0.0.255.255 area 1

network 10.11.0.0 0.0.255.255 area 1

network 10.12.0.0 0.0.255.255 area 1

network 10.13.0.0 0.0.255.255 area 1

network 10.14.0.0 0.0.255.255 area 1

network 10.100.0.0 0.0.255.255 area 0

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

!

ccm-manager switchback immediate

ccm-manager redundant-host 10.33.1.3

ccm-manager mgcp

ccm-manager config server 10.13.1.3

!

mgcp

mgcp call-agent 10.13.1.3 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode cisco

mgcp validate domain-name

!

mgcp profile default

!

!

!

dial-peer voice 100 pots

service mgcpapp

direct-inward-dial

port 0/0/0

!

dial-peer voice 101 pots

service mgcpapp

direct-inward-dial

port 0/0/1

!

dial-peer voice 102 pots

service mgcpapp

direct-inward-dial

port 0/0/2

!

dial-peer voice 103 pots

service mgcpapp

direct-inward-dial

port 0/0/3

!

!

line con 0

privilege level 15

login local

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

SH ccm-manager

FallonVG#sh ccm-manager

MGCP Domain Name: FallonVG.yourdomain.com

Priority Status Host

============================================================

Primary Backup Ready 10.13.1.3

First Backup Registering with CM 10.33.1.3

Second Backup None

Current active Call Manager: None

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 16:28:07 UTC Jun 8 2007 (elapsed time: 1w5d)

Last MGCP traffic time: 17:30:32 UTC Jun 20 2007 (elapsed time: 00:00:27)

Last failover time: 17:30:32 UTC Jun 20 2007 from (10.13.1.3)

Last switchback time: 17:30:02 UTC Jun 20 2007 from (10.33.1.3)

Switchback mode: Immediate

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: 17:16:18 UTC Jun 8 2007

Last MGCP Fallback end time: 15:54:03 UTC Jun 12 2007

MGCP Download Tones: Disabled

FAX mode: cisco

Configuration Error History:

353
Views
10
Helpful
3
Replies
CreatePlease to create content