Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CM User Page CUCM 7.1(3b)SU2 in spanish

I have a cluster of 2 CUCM servers (publisher and subscriber) working with the CUCM version 7.1(3b)SU2. My LDAP users can open the CM User Options web page totally designed in english but my users want to choose the web page language by themselves. Additionally, we find that the Extension Mobility phone service is all fashioned in english although some users have previously configured the phone user locale in spanish. Can you help me with the procedure to change those languages for each user by the ccmadmin console and how users can choose this options by their own ccmuser web console?

If you need more information just ask me. Thanks in advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Well, the only way I can check this is by loading the spanish locale on my lab system.  No time to do that presently.  I believe 5.1.3 had a drop downlist to select the language (as did earlier versions).  7.x doesn't and from what I can gather if you modify your browser's language (via Tools menu on your browser not through CCMUser web page) then it should work.

Also, when you load a locale you must restart the cluster before the locale is initialized and available.  After you installed the locale did you reboot the servers in your cluster?

Outside of those two things I have no other suggestions at this time.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Hey, now that's some progress.  When you load a locale you need to load it on all servers in the cluster and you need to reboot the servers after you load the locale.  So, it is possible that you  need to restart  the publisher. Before doing that I would restart the tomcat service on the pub:

admin: utils service restart Cisco Tomcat

To see if that fixes the issue.  Then I would try to restart the publisher.  If that doesn't work, then I would reinstall the locale(s) on the pub.

HTH.

Regards,
Bill

Please remember to rate helpful posts.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

13 REPLIES
Hall of Fame Super Red

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Hi there,

You should be able to open this up for your users via;

Change the enterprise parameters for show locales (web/phone) in CCMUser to  = True

Cheers!

Rob

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

I was a little slow on this one! Rob's typing skills are bleeding over. +5 to Rob! To add some additional info:

Users can specify the language displayed in the CCMuser pages as long as you have the "Show Locale for Web page Settings" set to true (which is the default). These settings are programmable from the CCMAdmin web page: System>Enterprise Parameters. Note, setting the above will allow users to change it. It will not change it for them. They can change the language settings once they logon.

You can also bulk change the locale settings for end user accounts using the Bulk Administration Tool.

HTH.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Those parameters are enable by default at the ccmadmin web page:

True 
True 

However, the page language cannot be changed.

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Hmmm. I see what you mean. A change in the interface that I overlooked. My apologies. It used to be you could change the language displayed in the CCMUser pages at will. Without installing a locale. It looks like you need to have the Spanish Locale installed on your CUCM cluster. Have you done this? If so, test the following:

1. Modify your browser (IE, firefox, etc.) to prefer the appropriate Spanish locale. You will need to restart your browser

2. Then connect to the ccmuser pages to see if the appropriate language is displayed

If you do not have the appropriate locale installed on the CUCM cluster, then you will need to install it.

HTH.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Thanks for your time to check my problem.

When I install this CUCM version I install the next locales:

Option Name Status
cm-locale-es_CO-7.1.3.2000-1.copActive
localeinstallerActive

This let me configure the user or network locales in:

English, United States

Español, Reino de España

Español, República de Colombia

My users can change by themselves the phone language without a problem. The problem is when they want to use the CM user web console and the Extension Mobility service. Those ones are made in english.

I check with a Win XP OS laptop configured locally in spanish and my browsers are configured in spanish also but the CM user page can't be changed to english.

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

OK. So your end users can't change the CM user page to display Spanish and you can't change your CM user page to display English? Or is there a typo in the last post?

Were you able to try and modify your web browser (IE or Firefox) to use a different language? You have to make this modification in the browser itself. Unfortunately, I can't test this at the present moment to see if there are any twists. Sorry if I am asking questions on things you have already checked.

HTH.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Sorry Bill,

I meant that neither my users can surf this site in spanish nor me. Additionally I can't change the page language to spanish, they either.

I had installed the CUCM version 5.1(3e) a month ago in my cluster but we bought the licences to install the 7.1(3b) and finally we upgraded to 7.1(3b)SU2. Before the new installation the page language can be changed by each user, but now we can't do that. Me and my users could open this page in spanish before the upgrade but I don't know why we can't do it again.

Best regards,

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Well, the only way I can check this is by loading the spanish locale on my lab system.  No time to do that presently.  I believe 5.1.3 had a drop downlist to select the language (as did earlier versions).  7.x doesn't and from what I can gather if you modify your browser's language (via Tools menu on your browser not through CCMUser web page) then it should work.

Also, when you load a locale you must restart the cluster before the locale is initialized and available.  After you installed the locale did you reboot the servers in your cluster?

Outside of those two things I have no other suggestions at this time.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Hi Bill,

test opening the ccmuser page from the subscriber:

http:///ccmuser

And this page is already showed in spanish:

Opciones  de usuario de Cisco Unified CM
Nombre de usuario
Contraseña
 
Imagen de producto
Copyright  © 1999 - 2008 Cisco Systems, Inc.
All rights reserved.


This product contains cryptographic features  and is subject to United States and local country laws governing import,  export, transfer and use. Delivery of Cisco cryptographic products does  not imply third-party authority to import, export, distribute or use  encryption. Importers, exporters, distributors and users are responsible  for compliance with U.S. and local country laws.  By using this product  you agree to comply with applicable laws and regulations. If you are  unable to comply with U.S. and local laws, return this product  immediately.

A summary of U.S. laws governing Cisco cryptographic  products may be found at: http://www.cisco.com/wwl/export/crypto/tool/stqrg.html.
If  you require further assistance please contact us by sending email to  export@cisco.com.

But the publisher one isn't. How do you think I can fix this problem with the publisher page? Should I restart the cluster like you mentioned before?

Thanks,

Oscar

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Hey, now that's some progress.  When you load a locale you need to load it on all servers in the cluster and you need to reboot the servers after you load the locale.  So, it is possible that you  need to restart  the publisher. Before doing that I would restart the tomcat service on the pub:

admin: utils service restart Cisco Tomcat

To see if that fixes the issue.  Then I would try to restart the publisher.  If that doesn't work, then I would reinstall the locale(s) on the pub.

HTH.

Regards,
Bill

Please remember to rate helpful posts.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Oscar,

Were you able to resolve this issue? Could you post the resolution?

Regards,
Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Yes, I was able to solve the problem restarting the Cisco Tomcat Service. I appreciate your time and expertise devoted to solve my problem.

Regards,

Oscar

Re: CM User Page CUCM 7.1(3b)SU2 in spanish

Excellent news!  Thanks for letting us know and for taking the time to rate the posts/flag the answer.

Regards,
Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

870
Views
41
Helpful
13
Replies
CreatePlease to create content