Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Connection Message Shuttle Error

I am trying to run message shuttle for the first time. I am getting the error log below.

OpenSmtpConnection:
    DllDate: May  8 2014
    ChilkatVersion: 9.5.0.39
    UnlockPrefix: LNDBRGMAILQ
    Username: PKVTECHLAP01:danielch
    Architecture: Little Endian; 32-bit
    Language: .NET 4.0
    VerboseLogging: 0
    SmtpConnect:
      SmtpHost: 172.16.192.51
      SmtpPort: 25
      SmtpUsername:
      SmtpSsl: 0
      StartTLS: 0
      SmtpAuthMethod: NONE
      SmtpConnect:
        Need new SMTP connection
        No SMTP login provided.
        No SMTP password provided.
        Skipping SMTP authentication because no login/password provided.
        checkForExistingConnection: Elapsed time: 0 millisec
        Connecting to SMTP server 172.16.192.51:25
        smtp_host: 172.16.192.51
        smtp_port: 25
        smtp_user: NULL
        auth-method: NONE
        connect2:
          ConnectFailReason: Connection rejected
        --connect2
        Failed to connect to SMTP server.
      --SmtpConnect
      checkOrMakeSmtpConnection: Elapsed time: 0 millisec
    --SmtpConnect
    Failed to connect to SMTP server
    Failed.
  --OpenSmtpConnection
--ChilkatLog

 

Please let me know if I am doing something wrong?

12 REPLIES
Cisco Employee

Hi Chris,Check if you allow

Hi Chris,

Check if you allow connections from untrusted IP addresses and if these require authentication under SMTP Configuration > Server.

-Mateusz

New Member

I have attached my SMTP

I have attached my SMTP Server Page. I believe I have it set correctly?

Cisco Employee

"Connection rejected" is

"Connection rejected" is pretty clear... all the shuttle is trying to do there is establish if it can drop an SMTP message into the pickup folder on Connection - that's it - falling off a chair basic.  If it's being cut off at the knees because of a connection rejection it's either the server doing it for some reason (yes, your settings are correct) or there's a firewall or AV app or the like blocking the connection request. 

New Member

Thanks for the information. I

Thanks for the information. I will check but nothing should be blocking that to that network. If I can not get this working I can always use Cobras to move the message. Just hoping to take advantage of Connection shuttle to make things quicker.

Cisco Employee

well, the SMTP library (from

well, the SMTP library (from Chilkat) is identical between COBRAS and Shuttle and, in fact, the initial SMTP connection checks in Shuttle are actually shared between the two projects - the actual message transport is different (COBRAS is doing one at a time from a DB backup, Shuttle is working on many threads pulling from a pool of messages) but the actual SMTP connection and transport is line for line identical.

I'd be a little confused if COBRAS Import put messages via SMTP into the target server from the same client box you're testing against and Shuttle complained the SMTP connection was being rejected.

New Member

You are correct. I am getting

You are correct. I am getting an error when trying to move messages using Corbras also. Attached is the screenshot of the message.

Cisco Employee

That's an unrelated error -

That's an unrelated error - Looks like a dependency somewhere isn't being installed (i.e. a system DLL that's here on our test beds but not your install client) - Export doesn't use SMTP at all, it uses IMAP to pull messages out (same ChilKat suite, different library) so that would not be related to the issue you're seeing with SMTP connection with Shuttle.  Only COBRAS Import does SMTP drops for adding new messages in.

Not sure what your deal with Export there is - I just downloaded the current version onto a clean Win 7 x64 VMWare install and it installed and ran fine - you should probably investigate that separately rather than trying to pursue it on this thread and cluttering it up since it's not related (at least directly) to your first problem.

New Member

I was able to reinstall Cobra

I was able to reinstall Cobra export and corrected the issue. However when I tried to do the import I ran into the attach SMTP error. I have a dbuser setup without a mailbox and a role assigned to it as a remote user. Is there anything else I need for that user?

Cisco Employee

that was another screenshot

that was another screenshot of your SMTP server settings, not an error - but I'm assuming it's the same type of chilkat library flag saying the SMTP connection was terminated...

Remote Administrator for restore is fine - for giggles I just downloaded the current Import version onto the same Win 7 x64 and restored the backup (that had some messages) to a 9.1(2) server using an account that had just remote admin - the SMTP connection went through fine and the restored completed without errors.

something somewhere between the COBRAS import application and the SMTP port on the Connection server is stomping on the connection - there's really no way for the client to determine that - all it knows is it issues the connection requests and it's not going through and reporting it to you - so if the server is somehow in a bad state (haven't seen that before) or there's a proxy involved or something somewhere getting involved - I can't really offer more than that - COBRAS is one of the most heavily used tools on the site (hundreds of downloads on any given day) so if there were some basic message restore show-stopper hiding we'd typically know about it pretty quickly.  It's got to be something specific to your setup or a very unusual bug/state on the Connection side of the house.

New Member

Sorry here is the correct

Sorry here is the correct attachment.

New Member

I was able to resolve my

I was able to resolve my issue. Mcafee was blocking port 25 from my maching connecting to my unity server.

 

Thanks for all the responses.

New Member

In case this helps...Using

In case this helps...

Using COBRAS Import for Connection, I had the same issue with McAfee protection needing to be disabled on the server we were connecting from. It went unnoticed because the firewall was operating silently and we didn't notice the service in the taskbar at first.

Thanks for this thread!

606
Views
10
Helpful
12
Replies
CreatePlease to create content