Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUCI-Lync Visual Voicemail

I posted this in the IPT section but realized that may have been the wrong place. So here it is again... (If I get the correct answer from one, I'll post on the other)

* We're doing the latest CUCI-Lync with the CUCM 8.6 and UCxn 8.6 (I think 8.6 is the newest; whatever is newest).

* UCxn and CUCM users are integrated with LDAP; UCxn users were all imported from LDAP.

* We're using a 10-digit dial plan (not +E.164)

* I have Visual VoiceMail configured and working from the 7962 desk phones

Here's the problem:

In CUCILync, pressing the Messages button launches the audio voicemail sign-in.  I want to do Visual Voicemail from CUCI-Lync.  I've done all the tasks in these:

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cucimoc/8_5/english/installguide/config_servers.html#wp1063920

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_configuration_example09186a0080ba7d10.shtml#

There's no checkbox to enable this in the CUCI-Lync settings, either.

Any ideas?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

CUCI-Lync Visual Voicemail

These registry settings for VVM look correct.  However, it's also possible to over-ride these settings via the group policy registry keys.  I also noticed your CCMCIP server is not configured, which is required configuration for CUCM 8.6 integration.  The problem report includes details about your configuration which will help us understand your configuration and diagnose this problem.  I still recommend persuing this problem via your TAC service request.  Please attach the problem report along with a packet capture to your TAC service request, not this forum.

The following document includes directions for enabling detailed logging and creating a problem report.

CUCILYNC Troubleshooting

http://www.cisco.com/en/US/docs/voice_ip_comm/cucimoc/8_5/english/faq/b_faq_olh_85.html#reference_3734DE4BA32D4BFE89318636D4F23CEC

For the packet capture, from the client PC, start Wireshark capturing before launching MOC.  After launching MOC try accessing VVM.  Stop the packet capture.  A screen shot showing how you are accessing VVM, will ensure we aren't over looking something.

4 REPLIES
Cisco Employee

CUCI-Lync Visual Voicemail

Maybe you are missing these registry keys?

Specifying Voicemail and Visual Voicemail Registry Settings

http://www.cisco.com/en/US/docs/voice_ip_comm/cucimoc/8_5/english/installguide/config_clients.html#wp1089355

CUCI-Lync 8.5 uses IMAP to view and retrieve voicemessages from Unity Connection.  So, the next step is using Wireshark to confirm an IMAP connection is made to Unity Connection and what is happending with it.  If your still not finding the cause of the problem, I recommend opening a service request with Cisco TAC.  We will want to review the problem report from CUCI-Lync. 

Please do not post  your packet capture or problem report on the forum.  They may contain information which should not be available to the public.

New Member

CUCI-Lync Visual Voicemail

That's what I was hoping for, Joseph. But I've been through many iterations of the registry and no luck.

[HKEY_CURRENT_USER\Software\Cisco Systems, Inc.\Client Services Framework\AdminData]

"TftpServer1"="1.1.1.9"

"CcmcipServer1"=""

"LDAP_Server_1"="1.1.2.2"

"LDAP_UserLogonDomain"="cms.local"

"CtiServer1"=""

"AutomaticDeviceSelectionMode"="0"

"LDAP_Server_2"="1.1.2.3"

"VVM_SystemServer_0"="1.1.1.12"

"VVM_Mailstore_ImapPort_0"="143"

"VVM_Mailstore_ImapProtocol_0"="TCP"

"VVM_Mailstore_InboxFolderName"="INBOX"

"VVM_Mailstore_PollingInterval"="60"

"VVM_Mailstore_Server_0"="1.1.1.12"

"UseCUCMGroupForCti"="true"

"CcmcipServerValidation"="0"

I have a TAC case open, but we're in a holding pattern now so I'm doing as much diggin as possible until we pick it back up tomorrow.

Cisco Employee

CUCI-Lync Visual Voicemail

These registry settings for VVM look correct.  However, it's also possible to over-ride these settings via the group policy registry keys.  I also noticed your CCMCIP server is not configured, which is required configuration for CUCM 8.6 integration.  The problem report includes details about your configuration which will help us understand your configuration and diagnose this problem.  I still recommend persuing this problem via your TAC service request.  Please attach the problem report along with a packet capture to your TAC service request, not this forum.

The following document includes directions for enabling detailed logging and creating a problem report.

CUCILYNC Troubleshooting

http://www.cisco.com/en/US/docs/voice_ip_comm/cucimoc/8_5/english/faq/b_faq_olh_85.html#reference_3734DE4BA32D4BFE89318636D4F23CEC

For the packet capture, from the client PC, start Wireshark capturing before launching MOC.  After launching MOC try accessing VVM.  Stop the packet capture.  A screen shot showing how you are accessing VVM, will ensure we aren't over looking something.

New Member

CUCI-Lync Visual Voicemail

Resolved by removing my registry flub.

The problem was that the VM I'm using was once part of my lab domain, and I had pushed the registry entries contained in the HKCU\Policies branch of the registry. Those policies take precedence over any defined in the HKCU\Software folder, and my voicemail settings were not even being referenced.

2089
Views
0
Helpful
4
Replies
CreatePlease to create content