Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUCIMOC does not download AppDialRules

I am trying to integrate and  configure the CUCIMOC application with Office Communicator R2.  I have made a lot of progress, but I can't get the drag and drop dialling to work.  I have an AD user configured with and E.164 formatted phone number.  When I drag and drop the the contact in MOC to the conversation pane, all I get is a fast busy. FYI, dialing by dial-pad works fine.

I ran a Wireshark capture, and I saw that the SIP invite request has the entire E.164 phone number.  It did not get processed by my application dial rule.  Also, the when the client contacts LDAP for calling party identification, it only uses my 7 digit extension, i.e. it does not get processed by my directory lookup rule.

So I ran Wireshark again to capture the startup of the MOC/CUCIMOC combination.  It that capture, I see that the softphone downloads the my configuration xml file for the phone, but it never attempts to download the AppDialRules.xml or DirLookupDialRules.xml.  The files exist on the TFTP server in the CUPC directory, and I have restarted the TFTP service several times.  What needs to be done to have the client download and use these files?

Any help will be greatly appreciated

Robert Luechtefeld

3 REPLIES

Re: CUCIMOC does not download AppDialRules

Did you configure the COP file with the same application dial rules and upload this to CUCM?  Then restart the TFTP server, restart your CUCIMOC client.  It should download the rule set then.

anytime you make a change the dialing rule, it has to be reload on every node in the cluster, not just the Publisher.

Red

Re: CUCIMOC does not download AppDialRules

"it never attempts to download the AppDialRules.xml"  sound very unusual.  It should at least try regardless the file exists on server or not.

Michael

http://htluo.blogspot.com

New Member

Re: CUCIMOC does not download AppDialRules

I agree it should try to load the file, but it doesn't.  I see it download the configuration file from the TFTP server.  When should it attempt to download the AppDialRules.xml file, during the reboot process? 

I did run the COP file on all my servers including my TFTP server.  And I reset the TFTP service on my TFTP server.  The other servers do not have the TFTP service activated.  I have rebooted the PC multiple times while testing, and nothing seems to help.

I guess I could try to re-install the software tomorrow.

1364
Views
0
Helpful
3
Replies
CreatePlease to create content