Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

CUCM 5.1 and TSP configuration problem

Hy all,

i am using Call Manager version. I need to install TSP 5.1(1.3) version for a third-party TAPI application on Windows XP SP2 client.

Afer the installation and configuration of the TSP, I use the dialer application for test, but unfortunately i cannot find the Cisco Line.

I am used to Call Manager 4.1. So i repeated all the configuration on the new version of CM. This does't work.

In there anything missing on the configuration?

Could you help me?


New Member

Re: CUCM 5.1 and TSP configuration problem

You need to figure out if it is a permissions/config issue on Callmanager or an installation problem.

Turn on logging on the TSP and have a look at the files it produces (I think they go to c:\temp\cisco or something similar). That should give you a clue to where the problem is.

Also, did you install the wave driver after installation?

New Member

Re: CUCM 5.1 and TSP configuration problem

Seems there are quite a few people that are experiencing the exact same problems after going to CCM 5.x. Has anyone found a solution to this yet?

As far as the permissions goes, I don't belive it's the issue. When tracing, the TSP reports that "*ERROR* InstanceID not present in registry." I belive this is the underlying issue.

New Member

Re: CUCM 5.1 and TSP configuration problem

I had the same problem and went 10 rounds in the ring with Cisco TAC for an answer. Their response has been the same "we don't support TSP installs".

Thankfully, Chad Clayton, a Cisco employee hooked me up with these instructions. They worked perfectly:

Try this:

On the client:

1. Make sure you do a clean install on a system that had no TSP before.

2. After install go to control panel > Phone and Modem Options > advanced > select CiscoTSP001.tsp, click configure.

3. The user should be an end user in CallManager, make sure the password is correct.

4. Make sure the correct CTI manager IP address is present.

5. On the security tab I only provided the TFTP address.

6. other configuration settings are default

7. make sure you manually install the Wave drivers.

On CCMadmin:

1. Check that the end user has one controlled device

2. the user is part of the standard cti enabled and CCM End Users groups

3. the primary extension has been configured correctly

4. On the device: enable "Allow Control of Device from CTI", put the correct "Owner User ID"

5. On the line: enable "Allow Control of Device from CTI"

After all of the above has been configured/verified:

1. restart the CTI Manager service

2. reboot the client machine (was necessary for me to get it to work)


1. On the client go to C:\Program Files\Windows NT and open dialer.exe

2. go to edit > options.

Preferred line for calling: "phone"

line used for phone calls: "Cisco Line: ..."

3. click dial, select phone call, enter the digits of the number you are trying to dial

New Member

Re: CUCM 5.1 and TSP configuration problem

Do you find a solution for this? I have the same error message with CM 5.1

"ERROR - InstanceID not present in registry"

CreatePlease to create content