Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUCM 7.0.2 - Dual Forking, not working!

Hi There,

We currently run an OCS 2007 enterprise environment integrated via Direct SIP to a CUCM 7.0.2 environment. Everything is working fine with this integration, calls between Cisco and MOC devices all works well.

I'm trying to set up dual forking call (simultaneous ring feature) between these environments. I've followed this guide available from the cisco website,

Basically we require users to be able to receive calls in both their Cisco hard phones (7940) and their MOC clients on a single extension number.

At this stage calling from a MOC client to a Cisco device and viceversa as i said is working fine, the issue is to get the two to ring at the same time.

In a nut shell i have configured a cisco 7940 device with a directory number in this form, \+612XXXX4111 (e164 format) user id, remote destination, remote destination profile, a route pattern for 612XXXX4111 via the SIP trunk to OCS, in call manager as indicated in the guide. However when ringing the number internally, the MOC client rings but the Cisco device doesn't. I tried isolating the directory number and Cisco device for testing, by changing the directory number to 612xxxx4111, without the '+' and removing the route pattern temporarily; then the cisco device rang. So it seems that adding the plus in the directory number configuration field is the problem. When the '+' is in the directory number I can make calls from the Cisco device, the calling number as shown in the called device logs is 612xxxx4111 but when trying to dial it from this device it does not work. I'm not sure if someone has been trying this setup. I will really appreciate some help with this.... Also on the guide I'm not sure why two different numbers are used for the directory numbers and the remote destination, when the purpose of forking is to ring the same extension number.

Looking forward for any feedback on this.



New Member

Re: CUCM 7.0.2 - Dual Forking, not working!

CUCM actually uses different set of number/id to ring OCS.

So far, i tried the 2 methods below.

1) SIP URI (this is the new feature in cucm 7 and i suppose the official method)

You are suppose to setup the remote destination to ring "" thru the sip trunk towards ocs mediation server

Prior to that, you need to setup the SIP route pattern to point "" thru the sip trunk.

2) Add dummy numbers in front and strip it off before sending thru the SIP trunk. (The only way to do it in cucm6)

I.e extension 4122 ... RD set to 74122....

In route pattern, set 7.XXXX and point to the SIP trunk, strip predot

CreatePlease to create content