Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

CUCM 8.0 & Exchange 2010 DTMF Issue

Hi all,

I can't seem to get DTMF passing between CUCM 8.0 and Exchange 2010.  I've followed the guide posted in the documents section and did the integration.  I made the SIP trunk in Call Manager point to the Exchange server using RFC 2833 for DTMF Relay (Tried the RFC 2833 & OOB for troubleshooting sake with no luck).  I'm able to reach the exchange server, hear the initial exchange greeting and get the 'Hello (name), please enter your PIN'.  After that point the exchange server doesn't seem to recognize any digits.  This is in a lab environment on VMware, all firewalls disabled, etc.

Thanks in advance!

7 REPLIES
VIP Super Bronze

Re: CUCM 8.0 & Exchange 2010 DTMF Issue

What are you making the call from? Not everything supports generating RFC2833 DTMF.

The workaround is to require an MTP on the SIP trunk to Exchange which can provide the DTMF interworking.

Re: CUCM 8.0 & Exchange 2010 DTMF Issue

Thanks for the response Jonathan!

I'm currently running it in a lab environment and placing test calls with my IP Communicator.  I've selected the 'Require MTP' on the SIP Trunk to the exchange box.

Now that you mention MTP's, I didn't assign an MRGL to the SIP Trunk as I think if you don't assign CUCM resources to MRG's, they can still be used by default by the entire system.  I could be wrong on that one though.

VIP Super Bronze

Re: CUCM 8.0 & Exchange 2010 DTMF Issue

Well current releases of CIPC should support RFC2833, I just tried it on 7.0(5)1 and it worked so an MTP should not be required. Try unchecking the Require MTP box on the SIP trunk. Don't forget to reset it for the changes to take effect.

If that doesn't fix it, what are you using for the MTP: the IPVMS service included with CUCM; or, an IOS-based MTP? For some reason I believe that the IPVMS is not capable of doing DTMF interworking; however, I can't find a document to back that up at the moment. It may be worth trying an IOS-based MTP resource.

Re: CUCM 8.0 & Exchange 2010 DTMF Issue

Thanks again for the response Jonathan!

I'm going to play with the MTP setting on the SIP trunk and will let you know how it goes.

Re: CUCM 8.0 & Exchange 2010 DTMF Issue

Well after playing around some, couldn't figure it out.  I re-ran the Exchange 2010 setup and after a few reboots, seems to be working!  Looked to be an issue with the Exchange.  Thanks for the help!

New Member

Re: CUCM 8.0 & Exchange 2010 DTMF Issue

May by odl post but I have similar problem

We have SIP trunk with CME 8.6 and 10 SCCP (7960,7975) phones, also UM with Exchange 2010 , everything work perfectly until we added two SIP client phones.

SIP client phones 9971 and 7906 have issue with sending DTMF signals.

From both SIP phones I can call and receive calls but when I call some number with auto attended or voice mail on internal or external number I have problem to choose options ,

I hear DTMF tones but destination party does not.

I can leave message, which means that I have two way communication.

I notice this trying to access ours voice mailbox on Exchange 2010 I can make call but no DTMF command are recognized I cannot enter PIN for mailbox I hear DTMF tones but UM does not

everything is normal with SCCP clients phones , problem localized on SIP clients phones.

My configurations for SIP and those two phones are

voice service voip

gcid

no cti shutdown

callmonitor

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

call start slow

modem passthrough nse codec g711alaw

sip

header-passing

registrar server expires max 1200 min 60

early-offer forced

midcall-signaling passthru

voice register dn 1

number 101

call-forward b2bua noan 555 timeout 20

allow watch

name BOSS1

no-reg

label 101 BOSS1

voice register dn 10

number 110

allow watch

name SHOP

no-reg

label 110 SHOP

voice register pool 1

id mac 04C5.A4B0.3B0D

type 9971

number 1 dn 1

dtmf-relay sip-notify

username xxxx password zzzz

codec g711alaw

camera

video

voice register pool 10

id mac 001E.7A25.EEA4

type 7906

number 1 dn 10

dtmf-relay sip-notify

username xxxx password zzzzz

codec g711alaw

Configuration of voicemail dial-peer

dial-peer voice 555 voip

description ** Exchange Unified Messaging **

destination-pattern 555

session protocol sipv2

session target ipv4:192.168.2.203:5065

session transport tcp

dtmf-relay rtp-nte

codec g711alaw

fax rate disable

fax protocol pass-through g711alaw

no vad

Any idea what is wrong or do you how can I troubleshot the problem

New Member

Hi All,I don't know whether

Hi All,

I don't know whether it makes sense posting something for a 4 yrs old post.

But just to share my experience facing the same issue.

We had CM 10.5 & UM services running on MS Exchange 2010. Everything was working fine even the back door UM access through PSTN. No issue regarding the DTMF. But suddenly one day found DTMF or touchtone from PSTN is not working. UM doesn't recognize keystrokes pressed. But internally it is fine.

The server team checked their part but MS Exchange is fine.

I did check my UC part but no solution came up. Then went through this post & it clicked my brain.

Just created an MRGL with only MTP servers included in it. Add the MRGL to the SIP trunk reset it......Boom now DTMF is working fine...

Regards

Narayan Dev Sarma

 

 

1798
Views
13
Helpful
7
Replies
CreatePlease to create content