Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CUCP Ver.8.02 DeskPhone not working


I have two computers and both have CUCP 8.0.2 installed.  On one computer both soft phone and desk phone works fine. On another computer, both soft phone and desk phone are not working.  Since I log in with the same user name, I guess my CUPS setings should be good.

The error I received on the non working PC is "A phone initilazation error has occurred.  Failed to get configuration. [400]."

By the way, both PC are running Windows 7 64-bit.



  • Unified Communications Applications
Cisco Employee

CUCP Ver.8.02 DeskPhone not working

I was able to fix this same issue with the following fix.


CUCM - 8.51

CUPC - 8.51

Win 7 64bit


Call & Call with Video where both grayed out

In the Help/Show Server Health menu options the Call Control section was missing

In the Help/Show Server Health menu and click on the Notifications has the error

     A Phone Initilation Error has Occurred. Failed to get configuration. [400]


After making sure all configuration was correct with the CTI users I found that the Windows Firewall was at fault

Goto Control Panel/Windows Firewall - click the "Allow a program or feature through Windows Firewall". Be sure to take note at which network you are connected to (Domain network, Home or work, public). before you go to the allow programs or features section. Make sure the check box to the left of CUPC & Cisco Unified Client Services Framework is checked and that the check box under the network you are connected to is checked to the right of the CSF.

Click OK and close the firewall window.

In CUPC click FILE/EXIT (don't just click the X to close the window this does not EXIT CUPC)

OPEN CUPC - give CUPC time to register

If this fixes your problem then your CALL menu option should NOT be grayed out and your should have a PHONE section in your server health.

I have a 9 part video series on configuring CUCM/CUPC & AD at the follow address



New Member

CUCP Ver.8.02 DeskPhone not working

i'm facing same problem.

i followed the steps but it didn't worked, i even disabled the firewall totally, and also used pc at same network with CUCM but didn't work.

when i checked the "core.log" file it give me the following error in TFTP:

2012-02-28 12:55:55,356 INFO  [provider-runner] [ConfigService] [TFTPConfigReader.getFile(138)] - TFTP getFile: mode=[SECURITY], hostname=[X.X.X.X], timeout(ms)=[9000], numAttempts=[2], isAscii=[false], file info:

localPath=[C:\Users\hamed.adel\AppData\Local\Cisco\Unified Communications\Client Services Framework\Config]




2012-02-28 12:55:55,357 WARN  [provider-runner] [ConfigService] [TFTPConfigReader.getBackupFileFromCurrentFile(387)] - No existing file to back up C:\Users\hamed.adel\AppData\Local\Cisco\Unified Communications\Client Services Framework\Config\CSFUSER3.cnf.xml

2012-02-28 12:55:55,358 INFO  [provider-runner] [ConfigService] [TFTPConfigReader.getFile(175)] - Requesting [CSFUSER3.cnf.xml] from [] to [C:\Users\hamed.adel\AppData\Local\Cisco\Unified Communications\Client Services Framework\Config\CSFUSER3.cnf.xml]

2012-02-28 12:56:13,359 ERROR [provider-runner] [ConfigService] [TFTPConfigReader.getFile(213)] - Error retrieving TFTP file [CSFUSER3.cnf.xml] from []: Connection timed out. Connection timed out.











also below is the result of shell command "utils network capture port 69":

12:59:18.466103 IP Y.Y.Y.Y.60308 > CUCM.test.local.tftp:  27 RRQ "CTLSEPCS                                                                                        FUSER3.tlv" octet

12:59:24.473886 IP Y.Y.Y.Y.60309 > CUCM.test.local.tftp:  25 RRQ "CSFUSER3                                                                                        .cnf.xml" octet

12:59:48.562920 IP Y.Y.Y.Y.50388 > CUCM.test.local.tftp:  27 RRQ "CTLSEPCS                                                                                        FUSER3.tlv" octet

12:59:54.568457 IP Y.Y.Y.Y.50389 > CUCM.test.local.tftp:  25 RRQ "CSFUSER3                                                                                        .cnf.xml" octet


CUCP Ver.8.02 DeskPhone not working


You are likely running into firewall issues so you may want to turn off your
security software on the system or tftp should not be blocked.


CUCP Ver.8.02 DeskPhone not working

From the client PC just open a command prompt and type the following

tftp get -i get source CSFUSER3.cnf.xml

You should be able to download the config file.

If that doesn't work then this is not a CUPC problem but rather a connection problem.

As Shalu said if that fails disable the firewall and test again.



New Member

Re: CUCP Ver.8.02 DeskPhone not working

i tested this command and it didn't work the tftp it give me timeout.

as i mentioned i disabled the firewall, also i forget to said that i have cisco ip communicator on same pc and it is working  good and get its configuration which mean there is no problem with connection.

also is there any way to download the .cnf.xml file without using tftp (http or https)?, also how i could be sure that the files exist (for example list them using shell command or anything else)?.

also it may be server side as it happen with me at all pcs, and networks.

New Member

CUCP Ver.8.02 DeskPhone not working

also after i run "show network ipprefs all" command below was the result

Application     IPProtocol      PortValue       HashLimit (max:rate)            H-Status        ConnLimit       C-Status        Type            XlatedPort      Status          Description

ctftp           udp             69              -                               -               -               disabled public          -               disabled TFTP access to CUCM TFTP Server

ctftp           tcp             6970            2000:35/second                  enabled         -               disabled public          - disabled HTTP access to CUCM TFTP Server

also from "os administration>tftp file management" i couldn't find any phone configuration files (.cnf.xml)

it seem that there is big problem with TFTP what should i do i need these urgent as it affect my deployment to CUCM