Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CUOM and Service Monitor

Unified Operations Manager 2.0.1 has an option on the "Monitoring Dashboard" view to "Launch Service Monitor"

This just seems to launch the internal service monitor (which would be installed on the CUOM server during the CUom installation - we didnt licence the internal installation)

Since we installed Service Monitor on a seperate server per installation requirements for a large deployment we wanted to have have the option on the Monitoring Dashboard view launch our external Service Monitor.

Has anybody been successful in accomplishing this?

thanks

16 REPLIES
Silver

Re: CUOM and Service Monitor

Hi Bill,

I've seen this done, by modifying the web page.

It is a Javascript.. file is dashboards.jsp

You can put your own link.

It would be broken by upgrades etc, you would need to repeat the process after an upgrade.

Note: this is probably not Cisco supported. Maybe they have another method.

Cheers,

Tim.

Community Member

Re: CUOM and Service Monitor

Thanks a lot Tim - I'll look for the dashboards.jsp file to modify it.

Community Member

Re: CUOM and Service Monitor

Hi Bill,

I have the same problem.

Could you please tell me the line code you had inserted into dashboards.jsp to modify the launchSM() url?

I found the dashboards.jsp into this path

NMSROOT\MDC\tomcat\webapps\triveni\uii.

Thanks in advance!

Leonardo

Community Member

Re: CUOM and Service Monitor

Leonardo,

I've decided not to make any modifications to the code at this time, but I might in the future. We are still in the process of deploying Service Monitor and I want to wait till we know its working properly before modifying any code.

If you are successful in making the mod I'd also be interested in what you added.

Thanks

Bill

Community Member

Re: CUOM and Service Monitor

now i already can register the sensor to the service monitor, thanks everybody.

regards

afdilah

Community Member

Re: CUOM and Service Monitor

Hi Bill,

you have to modofy the line near to 2440 in NMSROOT\CSCOpx\MDC\tomcat\webapps\triveni\WEB-INF\screens\defaults\dashboards.jsp script:

href="javascript: launchSM();"

as is, with your url:

href="https://ccm-cusm/qovr/goHome.do" target=_blank

It's work fine ;)

PS: I have also configured the CUOM as SSO master. In this case no login is required for CUSM.

Hope this help.

Leonardo

Community Member

Re: CUOM and Service Monitor

Thanks Leonardo - much appreciated.

Bill

Re: CUOM and Service Monitor

You would think this would be a bug, you shouldn't have to edit dashboards.jsp to add a link to external Service Monitor from home page.

Community Member

Re: CUOM and Service Monitor

This issue has already been filed as the bug CSCsg70937. It will be fixed in CUOM 2.1 which is due out November 8th pending testing.

Community Member

Re: CUOM and Service Monitor

Hi,

i have a problem with service monitor.

my service monitor cannot recognize cisco 1040 sensor.

i already upload config file and software image for the sensor 1040 to TFTP server/CUCM.

my topology is

sensor(192.168.206.202) ---> TFTP/CUCM (192.168.206.11) ----> Service Monitor (192.168.253.146)

sensor information status said that

not communication with receiver.

and service monitor address is empty.

please need your advice.

regards

afdilah

Community Member

Re: CUOM and Service Monitor

well, first question is - did you configure the DHCP option 150 for 192.168.206.0 network to point to the cucm server?

can you ping the sensor 192.168.206.202 ?

Community Member

Re: CUOM and Service Monitor

yes i already config DHCP option 150,

sensor already got ip address 192.168.206.202

http://192.168.206.202

status : not communicating with receiver

current service monitor: --

tftp server :192.168.206.11

http://192.168.206.202/Communication

'unable to retrieve 'QOVDefault.CNF' from 192.168.206.11

i already upload the file

QOVDefault.CNF, QOV001120FFF548.CNF,QOV001120FFF4F0.CNF and SvcMonAA2_40.img to TFTP server 192.168.206.11

from service monitor :

configuration- sensor- management

i already add the sensor name and MAC address

but the registration status is 'waiting'

that the information i can give.

regards

afdilah

Community Member

Re: CUOM and Service Monitor

So its obtaining the boot image SvcMonAA2_40.img from the tftp server??

but not the cnf config file?

IF thats the case I think the CNF file is corrupt. I seem to remember having to create the CNF file on the tftp server instead of copying it over.

Its just a notepad file with the extension CNF I believe and we cut / pasted the info in the original cnf to the new cnf (notepad file)on the tftp server.

Community Member

Re: CUOM and Service Monitor

the information on config file is like this :

Receiver=192.168.253.146;;

ID=A000

Image=SvcMonAA2_40.img

LastUpdated=4_17_2008-1_31_45.46

CDPGlobalRunState=true

SyslogPort=UDP:5666

SkinnyPort=TCP:2000

the problem is service monitor cannot register the sensor. and the sensor cannot download config file and Image file from TFTP server.

any suggesstion for this issue?

regards

afdilah

Community Member

Re: CUOM and Service Monitor

Well, the only other thing I can suggest is to make sure your not blocking TFTP UDP port 69 in a firewall or ACL.

edit - removed suggesion to disable FW on sm server be casue the SM server is not involved.

Community Member

Re: CUOM and Service Monitor

If you are using a CUCM 5.x then you need to restart the TFTP service on the CUCM after uploading a file manually to the CUCM. Then the 1040 will be able to download the cnf and image files.

432
Views
13
Helpful
16
Replies
CreatePlease to create content