Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CUP6+CUCM6 Presence: Away/DND/OnPhone status works, Available does not

Hey gang, I am trying to nail down this last gremlin in my CUPS build. CUCM 6.1 on MCS7800 with 7970 and 7960 phones: the IPPM works, status works, on hook BLF etc all good. CUPS 6.0.5 on VMWare: Troubleshooter all green, LDAP replication appears good (bound to AD, as is CUCM). CUP Client: logs in all green, can make calls, link to desk phone, etc. CUP client sees "On the Phone" status as well.

The problem is mainly that while "On the Phone" and "Away" and also custom "Away" messages work perfectly in CUP Client, and in IPPM. However, "Available" does not work on any CUP client (mac/windows). If i choose Available (on the Mac Client), it is displayed on the client for 5-10 seconds before reverting to "No Presence". The windows client will not let me choose Available at all.

I have been fiddling with the SIP trunk but it seems to work in both directions for all status except Available. Has anyone seen this?

2 REPLIES
Red

Re: CUP6+CUCM6 Presence: Away/DND/OnPhone status works, Availabl

1) Reachability info has nothing to do with SIP trunk. SIP trunk is used for phone presence only.

2) In Reachability, Available and Away use two different methods to update CUPS (one uses PUBLISH SIP, the other uses SOAP).

3) To troubleshoot the problem, you need to do this:

a) set trace level to debug for SIP Proxy and PE (Presence Engine).

b) do packet capture on client and server

c) recreate the problem and get a and b.

Michael

http://htluo.blogspot.com

New Member

Re: CUP6+CUCM6 Presence: Away/DND/OnPhone status works, Availabl

OK I managed to solve this today. It turns out there was an issue with the user-Agent config on the CUPS. The "reachability version" of my (recent) CUPC UAs was incorrectly set to version 1 rather than version 2. Once this change was made, all missing (available, idle) status info began updating properly.

Note this was for CUPC v1.2.3 (Mac) and CUPC v1.2.4 (Win32).

180
Views
0
Helpful
2
Replies