Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUPC cannot login

I am currently setting up CUPS 7.0 with CUCM 6.0.

I have setup everything according to cisco delpoyment guide for cisco unified presence,

Below are the details:

Topology Background

1. VMware Infrastructure 3.5 ESX Server

2. CUCM 6.0 (1)

3. CUPS 7.0 (1)

5. CUPc 7.0

I have not yet setup LDAP.

In Presence Server Diagnostics--> systems Troubleshooter:

No errros except for the following:

Warn
Warn
Warn

I have setup the following:

AXL user in CUCM/ Assign license capabilities to Users/create SIP trunk on CUCM/SIP Publish trunk on Presence Server.

Have also performed the following:

Configure CTI gateway settings

Create Users on CUCM and passwords/digest credentials---> they replicate onto Presence server successfully.

Each device created(Phone) on CUCM has been associated with Users and has been CTI controlled enabled.

Created UPC devices for CUPC in CUCM using UPCXXX (Where XXX is username as it is in CUCM) and unchecked   allow  control of device from.

Like i mentioned all users from CUCM and in sync with CUPS . Users can log in user options on CUPS using https://server/ccmuser

But the great issue is that they cannot login using CUPC client.

I have done a bit of troubleshooting from the logs and it seems that there is an issue with SOAP.

I have the following error from the log:

(MWMSG_EIM_SOAPLOGINFAILED) Failed to log in to SOAP server https://10.1.1.46/EPASSoap/service, Host unreachable

When i try to reach that url over internet explorer, i get page not found (404) from Tomact.

I have attached the log as well.
Please help

Regards

10 REPLIES

Re: CUPC cannot login

On the CUPS server did you create an incoming/outgoing ACL of 'ALL'?

New Member

Re: CUPC cannot login

Hi cileikis,

Yes i did create, but no luck!

Re: CUPC cannot login

Have you tried rebooting the CUPS server?  I've had some login issues before and rebooting the server cleared up my problem when my config looked good.

Re: CUPC cannot login

Also, make sure you allow CUPC through your firewall.

New Member

Re: CUPC cannot login

Hi,

I am not going through a firewall, it is in  a lab environment in my company. And on my pc windows firewall  is disabled. Anything about the Failed to log in to SOAP server https://10.1.1.46/EPASSoap/service, Host unreachable ?
Have you seen this error before? I have rebooted a number of times but still doesn't work

Re: CUPC cannot login

Here are a couple of suggestions

From the client PC try to access the following page

https://10.1.1.46/EPASSoap/service

Do you get anything ?

Can you check out the exact version of your client ?

CUPC 7.1.1  and 7.0.2C are not compatible with CUPS earlier than 7.0(5)

Regards,

Christos

New Member

Re: CUPC cannot login

Hi Christos,

The version of my client is 7.0(1.13056).

Like i mentioned in my original post i get an error message when i try to access http://10.1.1.46/EPASSoap/Service --> Error 404 From Tomcat

Is it an issue, i am suppose to see something from that page?

Regards

Nawaz

Re: CUPC cannot login

What you normally should be getting is the following

'This is a SOAP service. Send a POST request!'

Maybe you can restart the 'SOAP -Real-Time Service APIs' or the whole server for that matter ?

Can you try from different PC's ? Is it working from some of them ?

Regards,

Christos

FYI: CUPC is using SOAP to download it's config so it fails in the initial stage. I the report you provided I also see lots of crashes in past login attempts.

Do you still have issues with crashes?

New Member

Re: CUPC cannot login

Hi christos

I have re started the server serveral times, have re-started the service as well, but it doesn't work. I have tried from Different PCs but it doesn't work. My idea about it, if i get the error 404, page not found from Tomcat then i think the page itself doesn't exist, What do you think, do you think it is an installation issue?
Yes i still have the crashes.

Regards

Nawaz

Re: CUPC cannot login

What kind of PC's you have ? Is it Dell PC's ?

Are all the PC's the same brand and they use the same image ? Do they have the same OS and applications installed ?

The crashes are most likely caused because of a conflict with an application.

Maybe you can test this one a 'clean' PC ?

Not sure if you could send me the crash dump file (it is included in the troublereport). I may be able to find out which app is the culprit.

Regards,

Christos

1128
Views
0
Helpful
10
Replies
CreatePlease to create content