Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUPC CTI: phone control does not always work

Hi everybody,

I have a CTI problem with my Personal Communicator/Presence Server installation.

I use CUPC to control my IP Phone (7942) but sometimes the CTI feature suddenly doesn't work anymore and the icon in the upper right corner (where you can switch between no phone, softphone, ip phone) greys out. If I restart the CUPC client the icon reverts to softphone mode and the ip phone icon is still greyed out. This happens for all users simultaneously. Everything apart from CTI works perfectly.

The funny thing is that CUPC goes back to normal mode after some time (after 5 minutes or so) and CTI with ip phone works again.

There is a transparent L2 firewall (Cisco Firewall Service Module) between the presence server and the client running personal communicator. The firewall is configured as follows:

- permit ip any any in both directions

- sip inspection disabled

My next action would be to remove the firewall between server and client, but this is not so easy (since it is a live system with other traffice going through the firewall).

So I was wondering if anybody out there is/was experiencing the same issues.

Could this whole thing be related to some firewall session timers? Any other ideas?

Software versions

--------------------

FWSM Firewall 4.0(4)

CUCM 7.1.2.21900-5

CUPS 7.0.4.10000-18

CUPC 7.0(2)

Any help greatly appreciated. Thanks.

lukas.

4 REPLIES
Red

Re: CUPC CTI: phone control does not always work

On CUCM > System > LDAP > LDAP Authentication, what port is being used? (if you're using LDAP authentication).

Michael

http://htluo.blogspot.com

New Member

Re: CUPC CTI: phone control does not always work

I do use LDAP authentication and it uses the standard port 389.

I have two LDAP server entries in case that matters.

Red

Re: CUPC CTI: phone control does not always work

This problem is usually caused by LDAP referral. Please change the port to 3268 (default Global Catalog port). Then restart CTIManager (on all CUCM servers).

This should fix the problem.

Michael

New Member

Re: CUPC CTI: phone control does not always work

Hi Michael,

thank you very much for your super fast reply.

I did change the LDAP authentication port to 3268 in my lab environment and everything worked fine (like you said). I could get back to this problem in my productive environment only today. And believe it or not, no user reported any further problems with CUPC CTI since last week.

So, for now, I decided to leave the port as it is (389). But I will definitely keep your solution in mind! Thanks again. I hope your post also helps others.

lukas.

524
Views
4
Helpful
4
Replies