Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CUPC & Meeting Place

Question regarding Cisco Unified Personal Communicator and Meeting Place.

Setting up a Meet-me conference works just fine from within CUPC. However, once the host sets up the meeting should it not automatically prompt the other receipiants active on the call for internal users. I have to Invite Participants and either email the meeting place link or to IM the link.

6 REPLIES
Community Member

Re: CUPC & Meeting Place

Hi,

I'd like to reactivate this thread even though it's quite old by now.

I have the exact same problem with my new CUPS/CUPC/MPX installation:

If I try to escalate an ongoing call to a web conference (by clicking the conference icon in CUPC window), nothing happens.

I would expect a conference window to pop open on my partner's screen.

If I say invite participant and then send him the link via IM or e-mail, he can click it and a conference window opens up just fine.

Does anybody out there have an idea what could be wrong?

@mz4kmg: were you able to solve this problem in your environment?

thanks,

lukas

Red

Re: CUPC & Meeting Place

This is because CUPC was not able to derived the correct user ID by the telephone number.

There are couple scenarios of this:

#1 You're on call with extension number 2001. CUPC was not able to find any user ID associated with DN 2001 because in LDAP his phone number is no exactly 2001. (e.g. it was 408-555-2001 in LDAP).

#2 You're on call with extension number 2001. CUPC was able to find a user in LDAP with phone number 2001. However the LDAP user ID was not found in CUPS user ID database. (e.g. the LDAP user ID was 'jdoe' while the CUPS user ID is 'JohnDoe'.

In a nutshell, it's all about phone_number-to-user resolution.

Michael

http://htluo.blogspot.com

Community Member

Re: CUPC & Meeting Place

Hi Michael,

thanks a lot for you super fast reply.

It all looks like I'm hitting scenario #1. I call a 4-digit internal extension but all users have their full E.164 number entered in active directory user properties.

Though when I showed this thread to a friend of mine, he said that he had this working with different numbers once before.

What I'm gonna do next week is I will change the phone number in LDAP to the 4-digit internal extension so that it matches the called number.

We'll see what happens.

I'll keep this thread updated.

lukas

Red

Re: CUPC & Meeting Place

If you have E.164 number in active directory, you may configure "directory lookup rules" in CUCM to translate that.

Go to CUCM Admin > Call Routing > Dial Rules > Directory Lookup Rules.

Michael

Community Member

Re: CUPC & Meeting Place

Hi Michael,

thanks for your second hint.

What I tried first is:

I changed the phone number in Active Directory user properties to the internal 4digit extension, synchronized LDAP with CUCM and it works!

So my problem is definitely #1 and I'm glad that I/you found the problem.

What I tried next is:

I changed the number back to E.164 format. Actually it's not E.164, it includes some special characters and looks like this:

+41 (xx) xxx xx xx

Then I tried to add a new Directory Lookup Dial Rule to map the 4digit extension to this full E.164 number.

This ain't working yet. I tried with several rules but they don't seem to match/work.

I also tried with plain E.164 numbers in AD (+41xxxxxxxxx), no success either.

I'll keep working on it, just wanted to let you guys out there know how it is going, in case somebody else faces the same problem.

Lukas.

Community Member

Re: CUPC & Meeting Place

All good now!

I configured a Directory Lookup Dial Rule as follows:

Number Begins With:

Number of Digits: 4

Total Digits to be Removed: 0

Prefix With Pattern: +41xxxxx

Not sure why it didn't work the first time. Maybe I was just too tired.

Michael, thanks again for your excellent support/advice.

Lukas

P.S.: how do I mark a post with a red tick "includes response(s) that solved Author's issue"?

750
Views
25
Helpful
6
Replies
CreatePlease to create content