Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUPC Presence Newbee

I have Presence 6.0 with CUCMBE 6.1. This is the first time I'm setting this up and am not sure if everything's been configured properly. Troubleshooter shows all green. Running into few issues so I was hoping someone mgiht be able to answer these below:

1. Based on docs, it says CUPC pulls user credentials from CUCM. I am having some problems with users not being able to login (some are okay). Error states "Login failed. Make sure your username and password are correct." However, when I try logging in to Presence User options browser with the same credentials, it works.

2. I noticed when you update user credentials in CUCM, it doesn't get updated in Presence right away. Is there a refresh interval for this or do you have to always restart the sync agent?

3. For contact info, I know you need to integrate with an LDAP server. Where do you set the proper OUs and CNs? Not an Exchange/AD guy so this might be simple.

Any help would be greatly appreciated. Thx.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: CUPC Presence Newbee

you cant unless you have access to your AD domain controllers to figure it out.

I googled a quick answer

http://www.computing.net/answers/windows-2000/how-do-i-id-my-global-catalog-serv/62266.html

6 REPLIES

Re: CUPC Presence Newbee

For the Client, you really need to close the client completely, then open it back up again. For CUCM authentication, try setting the digest credentials also for the login. Something like 12345, doesnt really matter what the digest credentials are on the subscriber as long as they are the same. The CUPC client will not use them to type in the password, only their actual password.

For Contact info? What do you mean? You mean once you are logged into the CUPC and you search for someone in the directory? If so, you need to configure the LDAP profile for the subscriber on the CUPS server. Close the client, open the client. You should get the LDAP connection then.

Remember, you have to connect to an LDAP source such as AD and it must the Global Catalog server on the correct LDAP secure port. 38xx something i think. Search the forums and you will find the correct port for this.

Hope this helps.

And since you are using CUCMBE, there are no LDAP configs on this server, its only on the CUPS server. So it should be easy.

New Member

Re: CUPC Presence Newbee

Many thanks for the info tcatlinins.

For the personal communicator, I have tried closing the client app as well as reboot the presence server but am still having issues with some users not being able to login. Also tried what you suggested about putting in digest credentials for the user. not sure if doing this via vpn is part of the issue but as mentioned it works when used again with the presence user options page. Technically, should you be able to login to CUPC if you are abel to login to presence user options using the same credentials or is there something else needed?

For LDAP, I do show the connections established and green light on client side but no contacts. My guess is I'm connecting to an AD that is not a Global Catalog. Is there a simple way to determine if it is a Global Catalog or not?

Again, thanks for the help.

Re: CUPC Presence Newbee

What port is configured for LDAP connection profile on the CUPS?

For logins, you can enable logging on the client, then check the logs to see what the issue is.

Are you sure you can ping the CUPC and CUCM server from the client PC and you have communication?

The other trick is that if you have a client PC, and it logs in OK with their credentials. You log out, then log in with a different account you know is NOT working, you now know it's a problem with the credentials or CUP profile. (possibly not enabled, configured, password, etc)

hope this helps

New Member

Re: CUPC Presence Newbee

figured out what the problem was. looks like if you have the credentials "user must change pwd at next login", it will not let you login to CUPC. I unchecked it for two users having login issues and it works after resetting the sync agent.

LDAP is set to use port 3268. On the client server health it shows green although I don't see any contacts. How do i determine if the AD is a Global Catalog? Sorry, this is completely out of my realm.

Re: CUPC Presence Newbee

you cant unless you have access to your AD domain controllers to figure it out.

I googled a quick answer

http://www.computing.net/answers/windows-2000/how-do-i-id-my-global-catalog-serv/62266.html

New Member

Re: CUPC Presence Newbee

Thanks. Looks like that's the right box. i did some playing around with the credentials and search context and got it working. Thanks for the help again...

301
Views
0
Helpful
6
Replies
CreatePlease to create content