Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

CUPC unable to do desk phone control

We run CUPS 7.0 and CUPC 7.0 with CUCM 6.1.3.

I have set up an number of users with CUPC and they are abel to choose desk phone from CUPC.

Some users that I have added can only use the softphone, although I have:

-assigned the users as CUP users

-assigned desk phone control

-assigned a CTI gateway profile.

-associated the line on the deskphone with the appropriate user ID (CUCM)

-associated both the desk phone device and CUPC device to the end user configuration in CUCM

-added the end user to CCM end user and CTI enable group

-checked Allow CTI control of device settings at the end user and extension config, both boxes ticked

-checked the presence viewer for the failing user, and see all the settings correct.

I suspect there is something wrong with CTI control of the desk phone from CUPC, but cannot seem to find any configuration differences between the users that fail and those that have desk phone control.

I

I have compared

Please remember to rate useful posts, by clicking on the stars below.

8 REPLIES
Red

Re: CUPC unable to do desk phone control

Can you go to CUPC > Help > enable detailed logging?

Recreate the problem and attach CUPC problem report.

Is the CUCM using LDAP authentication? What port it is using? 389 or 3268?

You may also take a look at this article: http://htluo.blogspot.com/2009/01/myterious-invalid-crdential-on-cupc.html

Thanks!

Michael

Re: CUPC unable to do desk phone control

Yes CUPS is using LDAP for authentication,

using the defualt port, 389 (off the top of my head)

Please remember to rate useful posts, by clicking on the stars below.

Red

Re: CUPC unable to do desk phone control

change the port to 3268 and restart CTIManager.

Michael

Re: CUPC unable to do desk phone control

are you sure your CUPC client can "talk" to the callmanager server? Basically, if you look at the Server Health on the CUPC client, and see the Deskphone retrying, take a look at the server name. If the server name can not be resolved from the client to the servers, you need to resolve this first. On the CUPS server, ping the callmanager hostname.

on the CUPC client computer, ping the cucm hostname. If needed, put a host file on teh CUPC file for testing. It is possible, even though you setup IP address for CUCM, it's still using the hostname.

(and whatever Michael says!)

New Member

Re: CUPC unable to do desk phone control

Just install 500 cupc clients and in the process I ran into a few issues that resulted in what you are experiancing:

here goes:

in call manager

1. make sure user has licensing enaabled under capabilities assignment"no brainer but just in case"

2. build the cup phone and make sure the device name after upc does not exceed 12 charecters and all capitals letters

3. set device pool of cupc to be the same as hard phone

4.associate the owner user id to the user

5.associate the primary phone of the user

note, allow control of cti should not be checked here

6.associate digest user

save and click ok on pop-up

click add a new extension

enter directory number and route partiton

note, allow control of device from cti must be checked here

7. click associate end userbutton and chose user.

save

under user management

1. find or add the user under end user

click the device association button

find desk and cupc phone and associate.

save

click go to go back to users page

select the subscribe calling search space " recommended setting would be internal css

check the allow control of device from cti

select the correct "primary extension from the dropdown"

click the add to users button

find and check the standard cti enabled

click the add selected button

save

on the presence server under user settings

use drop down to select the following

prefeerred cti device

unity profile

meetingplace profile

device pool

ldap profile

sip proxy profile

save

couple of things

1. name for user must be the same as ldap

2. mac address of cti device in cupc must match the users

3. the 12 char name thing very important.

hope this helps.

New Member

Re: CUPC unable to do desk phone control

Thanks Stuart and Michael. Perhaps you guys should write Cisco Documentation!

I'm still having the problem though. I am Using GC (port 3268) and have checked everthing else here I can find. Using CUCM 6.1.3.2000-1 (Pub and one Sub) and Single CUP 6.0.5.100.13. Integrated with AD and using AD authentication, Again using 3268. AD authentication works fine for CUCM. CUPC log shows :

WARN LCCallControl - (CCMSG_QBE_PROVIDEROPENFAILED) ProviderOpen failed: Directory login failed - timeout

Getting a bit desperate now! Any other things you can suggest?

Thanks.

[Michael your book is on it's way!]

Red

Re: CUPC unable to do desk phone control

"ProviderOpen failed: Directory login failed - timeout" means CTIManager authentication with LDAP was timed out.

Could you go to "Cisco Unified Serviceability > Tools > Control Center - feature services" and see how long the "Cisco CTIManager" has being running? If it doesn't seem to be restarted lately, please restart it.

Usually, restart CTIManager (on all CUCM servers) would fix this problem.

If that didn't fix the problem, you may go to CUCM Admin > System > Service Parameters > Cisco CTI Manager > Advanced. Change "CTI Request Timer" from 5 to 300.

Please note:

1) You need to restart CTIManager after the change.

2) You have to do it for each CUCM server.

Michael

New Member

Re: CUPC unable to do desk phone control

You are a Champion! Increasing the timer worked.

Thanks Heaps.

1151
Views
10
Helpful
8
Replies