Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUPS 7.0 - Can't add contacts

Hello,

     I've configured CUPS 7.0 in a lab for testing, integrated with AD and working with desk phones and softphones.  Am able to log in with AD credentials with no problems, make calls, everything looks fine except that I can't add contacts.  I've read through some posts where people have suggested that the most likely cause is an issue in the LDAP configuration, but LDAP seems to be working properly to be able to import users and authenticate them.  I also suspected that the Windows firewall may be causing the problem, but it's disabled and still no dice.  Does anyone know where else the issue may be for me?

5 ACCEPTED SOLUTIONS

Accepted Solutions
Super Bronze

CUPS 7.0 - Can't add contacts

Hi

Do you get an error when importing? Have you expanded the view of the group you are adding to (I seem to recall them being minimized/rolled up by default)?

Have you used a custom field (i.e. not sAMACcountName) as user ID for the AD integration?

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Bronze

CUPS 7.0 - Can't add contacts

Can you see all the users in CUPS? Do all the users have CUPC and CUPC license capabilities?

Bronze

CUPS 7.0 - Can't add contacts

On the client, go to help > Server health and check the status of LDAP.

Bronze

CUPS 7.0 - Can't add contacts

Yes, the LDAP server IP should be the same as your AD server.

Just want to make sure that you've assigned the correct LDAP profile to your users, and I'm not sure with v7.0, but if you have a Search context filter set up in your LDAP profile, make sure it's correct.

Bronze

CUPS 7.0 - Can't add contacts

Try putting in a Search Context filter. (cn=users,DC=myco,DC=com) and then restarting the directory service.

11 REPLIES
Super Bronze

CUPS 7.0 - Can't add contacts

Hi

Do you get an error when importing? Have you expanded the view of the group you are adding to (I seem to recall them being minimized/rolled up by default)?

Have you used a custom field (i.e. not sAMACcountName) as user ID for the AD integration?

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

CUPS 7.0 - Can't add contacts

Hey Aaron,

     I'm not using a custom field, just sAMACcountName.  No error importing.  Also, yes I've expanded the contact list - nothing.  How are the contact lists generated?  Are these groups I'm supposed to be setting up in CUPS or CUCM?  In any case, when I do a search with Personal Communicator, nothing shows up. 

Bronze

CUPS 7.0 - Can't add contacts

Can you see all the users in CUPS? Do all the users have CUPC and CUPC license capabilities?

New Member

CUPS 7.0 - Can't add contacts

Hi Gareth,

     I see all AD users in CUPS and they all have the CUPS capability added (CUP enabled and CUPC enabled).

Bronze

CUPS 7.0 - Can't add contacts

On the client, go to help > Server health and check the status of LDAP.

New Member

CUPS 7.0 - Can't add contacts

It shows a green check mark and Last Connection: Successful (Primary).  The ones that show X are Web Conferencing (not configured) and Secure Messaging (which sounds like a problem since I think this refers to Instant Messaging service?)

New Member

CUPS 7.0 - Can't add contacts

Gareth,

     The LDAP server should be the IP of the AD server, correct? 

Bronze

CUPS 7.0 - Can't add contacts

Yes, the LDAP server IP should be the same as your AD server.

Just want to make sure that you've assigned the correct LDAP profile to your users, and I'm not sure with v7.0, but if you have a Search context filter set up in your LDAP profile, make sure it's correct.

New Member

CUPS 7.0 - Can't add contacts

Hi Gareth,

     There's no Search Context configured on the LDAP profile (and I've verified that all of the users have been added to the profile).  It sounds to me that this profile is used to define how a user is able to search the corporate directory for other users.  In any case, any time I make a change to the LDAP settings those changes are reflected in Personal Communicator under server health.  What can it mean when a user tries to search LDAP but it's not returning results then?  LDAP seems to be working fine in any other sense.

Bronze

CUPS 7.0 - Can't add contacts

Try putting in a Search Context filter. (cn=users,DC=myco,DC=com) and then restarting the directory service.

New Member

CUPS 7.0 - Can't add contacts

Gareth,

     Thank you so much.  That did the trick.  Works great now.  I really appreciate the help.

560
Views
0
Helpful
11
Replies
CreatePlease to create content