Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

CUPS 8.6 -- VMTools Install

I've got a CUPS 8.6 install (upgraded from 8.0.x to 8.5.x to 8.6.1 currently) in a virtualized ESXi 4.1 environment.

I'd like to get VMtools installed to ensure that I'm running it at the best performance possible, but it won't seem to install properly.

Here's my process:

1. Logon to CLI in the vSphere console view.

2. Right click the VM and choose Guest > Install/Upgrade VMTools... Click OK.

3. Nothing happens on the client side.

4. I attempt to use utils vmtools upgrade but it tells me a previous install isn't finished.

5. I attempt to use utils vmtools status but it tells me no version is installed.

6. I attempt to use utils system restart but get no indication on reboot that installation is occurring.

How can I successfully get VMtools installed?

9 REPLIES
New Member

Re: CUPS 8.6 -- VMTools Install

Ok, when you do a

Utils vmtools upgrade

Type

Yes instead of just 'y'

I found this worked on cuc and cucm

Sent from Cisco Technical Support iPad App

New Member

Re: CUPS 8.6 -- VMTools Install

Thanks for the response, but I already tried that.

New Member

Re: CUPS 8.6 -- VMTools Install

Are you selecting an interactive or automatic tool upgrade from the vSphere  console?

I believe automatic tools upgrade is supported, but I have personally seen situations where the automatic tool upgrade does nothing. Select to do an interactive tools upgrade, then run utils vmtools upgrade.

New Member

Re: CUPS 8.6 -- VMTools Install

I don't get this prompt when selecting to Install/Upgrade Tools... I receive the following prompt instead...

Which would be fine, except, the OS *is* running.

New Member

Re: CUPS 8.6 -- VMTools Install

What is the guest OS set to within vSphere? Should be RHEL 4 (32-bit).

New Member

Re: CUPS 8.6 -- VMTools Install

Ah! Somehow mine was set for Linux (Other). I've changed it to RHEL4 (32-bit) but still get the same OS not running prompt.

New Member

Re: CUPS 8.6 -- VMTools Install

That's me pretty much out of ideas unfortunately! All I've got left is...

  • What virtual machine hardware is it set to, 4 or 7?

  • Have you restarted it since changing the guest OS type? Perhaps it needs a kick up the bum to realise it's not powered on after the change.
  • Perhaps since you've upgraded through versions, there is a setting not set that would be in the CUPS 8.6 OVA template. Create a new guest using the 8.6 OVA template and compare to the settings of your current CUPS guest.
New Member

Re: CUPS 8.6 -- VMTools Install

Yeah, VM7... everything matches except that my SCSI controller is SAS instead of Parallel and my NIC is Intel instead of Flexible.

Cisco Employee

Re: CUPS 8.6 -- VMTools Install

Cisco TAC resolved the issue via root access.

Root-level procedure to perform VMTools upgrade on the VM instances:

1. Open up a console for the VM and login as root. (Please do NOT use SSH to do this, as uninstalling tools in Step 3 will knock out eth0's connectivity - console access is preferred)

2. From the console menu, select VM -> Guest -> Install / Upgrade VMware Tools, followed by "Interactive Tools Upgrade" at the next screen.

3. As root, run the following:

   mount /dev/cdrom /mnt

   cd /mnt

   cp VMwareTools-8.3.2-257589.tar.gz /tmp (copy the tarball that you find in /mnt to a temp dir)

   cd /tmp

   tar -xvzf /tmp/VMwareTools-8.3.2-257589.tar.gz

   cd /tmp/vmware-tools-distrib/bin

   ./vmware-uninstall-tools.pl    (this wasn't actually necessary because the VMWare tools wasn't yet installed)

   rm -rf /etc/vmware-tools

   rm -rf /usr/lib/vmware-tools

   cd /tmp/vmware-tools-distrib

   ./vmware-install.pl -d

   init 6 (this will reboot the system)

808
Views
10
Helpful
9
Replies
CreatePlease to create content