Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Silver

CXN 8.5 MWI sync issue on single phone

Like the subject says -- single user MWI issue.  It's as if the phone isn't receiving the MWI off notification after the last unread message is marked read, but a manual sync fixes it.  Any ideas?

thanks,

will

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: CXN 8.5 MWI sync issue on single phone

Hello Will,

So far the phone has been replaced and the user which is not AD (Active Directory) integrated has been recreated. Resync through the Telephony Integration in CUC addresses the issue temporarily and dialing the ON/OFF extension works which leaves the CSS/PT away as a possible issue.

To have a deeper understanding please advise of the suggestions below even though they might seem unprobable:

1-Run a route plan report on CUCM for the DN of the user and the MWI ON/OFF to check for any overlappings.

2-Check replication on CUC and CUCM as well. This might seem a little bit too far but we got to rule out all posibilities.

3- Is the user SIB (Unified Messaging) integrated? Might be a problem synching to Exchange.

4- Is this a SCCP (Skinny) or SIP integration?

5- Do the application logs in RTMT (Real Time Monitoring Tool) report any information regarding that user/extension on CUCM or CUC?

6- On CUC enable all levels for the Notifier traces an gather them via RTMT (Real Time Monitoring Tool) for Connection Notifier, below is an example of how it should look in a working scenario:

User= Katresnan  Extension=4444

UNITY CONNECTION TRACES

10:57:32.838 |14670,,,Notifier,21,ResultMonitor NOTIFYQ_ACTION_MWIOFF_COMPLETE Katresnan MailboxObjectId=d7d2ea1c-1854-411b-8187-7a096418fbf5

d38d9c41-8328-4fb3-acb8-186559255d6d

10:57:32.838 |14670,,,Notifier,12,Katresnan: MWI  (OFF) completed successfully for mwi

extension =4444

10:57:32.838 |14670,,,Notifier,11,writeMWIStatus for Katresnan mwi=MWI-1 ext=4444

isOn=false port=

10:57:33.280 |14672,,,Notifier,21,Read from NotifyQ: NOTIFYQ_ACTION_SEEN_MSG_DELETEDKatresnan MailboxObjectId=d7d2ea1c-1854-411b-8187-7a096418fbf5

VoiceNormal-Priority2f26d822-9cd1-43db-97e8-ab2022b956d9

10:57:33.281 |14669,,,Notifier,21,MessageStoreMonitor NOTIFYQ_ACTION_SEEN_MSG_DELETEDKatresnan MailboxObjectId=d7d2ea1c-1854-411b-8187-7a096418fbf5

VoiceNormal-Priority2f26d822-9cd1-43db-97e8-ab2022b956d9

10:57:33.281 |14669,,,Notifier,21,Katresnan: Processing DeletedSeenMsgEvent

MsgId=2f26d822-9cd1-43db-97e8-ab2022b956d9

10:57:33.281 |14669,,,Notifier,24,Katresnan: Adjust saved message counts by -1 for

media=Voice priority=Normal-Priority starting 0,0,0,0,0,0,0,0,0,0,0,1,0,0,0,0,0

10:57:33.281 |14669,,,Notifier,24,Katresnan: Adjusted saved message counts for

media=Voice priority=Normal-Priority now 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

10:57:33.281 |14669,,,Notifier,1,Katresnan: resyncMsgCountsCheck for Katresnan

seq#=444 counts=0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

10:57:33.281 |14669,,,Notifier,1,Katresnan: resyncCheck found expected msgcounts

0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 seq#=444 already have seq#=444

10:57:33.281 |14669,,,Notifier,12,Katresnan, mwi extension=4444: needs MWI update due

to always-update flag.

10:57:33.281 |14669,,,Notifier,12,Katresnan: evaluate MWI -  lamp update to OFF  mwi

extension=4444

10:57:33.294 |14670,,,Notifier,21,ResultMonitor NOTIFYQ_ACTION_MWIOFF_COMPLETE Katresnan MailboxObjectId=d7d2ea1c-1854-411b-8187-7a096418fbf5

d38d9c41-8328-4fb3-acb8-186559255d6d

10:57:33.294 |14670,,,Notifier,12,Katresnan: MWI  (OFF) completed successfully for mwi

extension =4444

10:57:33.294 |14670,,,Notifier,11,writeMWIStatus for Katresnan mwi=MWI-1 ext=4444

isOn=false port=

Regards,

D0|V1D

Cisco Employee

Re: CXN 8.5 MWI sync issue on single phone

The traces have to be enabled under Unity Connection Serviceability>Trace>Micro Traces>Notifier, enable all of them, wait for the issue to occur then pull them from RTMT.

15 REPLIES
Silver

CXN 8.5 MWI sync issue on single phone

Forgot to mention that the phone has been replaced, so the liklihood that it's a hardware issue is pretty slim.

Re: CXN 8.5 MWI sync issue on single phone

Hi Will.
If you call Wmi On number from that phone, does the ligth come on?
Let me know

Regards

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
Silver

Re: CXN 8.5 MWI sync issue on single phone

Yes sir.  To recap...

Only one user with the issue.  Each day (presumably after the mwi resync), his light gets turned on.  CXN shows no messages and that the mwi is off.  I can then resync the mwi via either CXN or by manually dialing the mwi off number to correct the issue.

...then the next day it happens again.  I'm out of ideas.

thanks,

will

Re: CXN 8.5 MWI sync issue on single phone

Hi Will.

Have you try to delete and resynchronize that user on Unity Connection?

Let me know

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
Silver

Re: CXN 8.5 MWI sync issue on single phone

Yes sir.  There's no AD integration, but the account was deleted and  added back in.  I also used user data dump to check for alt extensions.

Really out of ideas.  +5 for trying though. 

thanks,

will

Re: CXN 8.5 MWI sync issue on single phone

Will,
please do a test for me.
Configure that user line on another ip phone and see if both phone have the same behaviour ( it can also be a CIPC)

Let me know


Thanks

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
Silver

Re: CXN 8.5 MWI sync issue on single phone

Same behavior, but easier to view then webbing into the phone and looking at the mwi status or pulling a screenshot.  I can't fathom why a manual resync in CXN works every time, but still having this issue.

Silver

Re: CXN 8.5 MWI sync issue on single phone

Hello Will,

So far the phone has been replaced and the user which is not AD (Active Directory) integrated has been recreated. Resync through the Telephony Integration in CUC addresses the issue temporarily and dialing the ON/OFF extension works which leaves the CSS/PT away as a possible issue.

To have a deeper understanding please advise of the suggestions below even though they might seem unprobable:

1-Run a route plan report on CUCM for the DN of the user and the MWI ON/OFF to check for any overlappings.

2-Check replication on CUC and CUCM as well. This might seem a little bit too far but we got to rule out all posibilities.

3- Is the user SIB (Unified Messaging) integrated? Might be a problem synching to Exchange.

4- Is this a SCCP (Skinny) or SIP integration?

5- Do the application logs in RTMT (Real Time Monitoring Tool) report any information regarding that user/extension on CUCM or CUC?

6- On CUC enable all levels for the Notifier traces an gather them via RTMT (Real Time Monitoring Tool) for Connection Notifier, below is an example of how it should look in a working scenario:

User= Katresnan  Extension=4444

UNITY CONNECTION TRACES

10:57:32.838 |14670,,,Notifier,21,ResultMonitor NOTIFYQ_ACTION_MWIOFF_COMPLETE Katresnan MailboxObjectId=d7d2ea1c-1854-411b-8187-7a096418fbf5

d38d9c41-8328-4fb3-acb8-186559255d6d

10:57:32.838 |14670,,,Notifier,12,Katresnan: MWI  (OFF) completed successfully for mwi

extension =4444

10:57:32.838 |14670,,,Notifier,11,writeMWIStatus for Katresnan mwi=MWI-1 ext=4444

isOn=false port=

10:57:33.280 |14672,,,Notifier,21,Read from NotifyQ: NOTIFYQ_ACTION_SEEN_MSG_DELETEDKatresnan MailboxObjectId=d7d2ea1c-1854-411b-8187-7a096418fbf5

VoiceNormal-Priority2f26d822-9cd1-43db-97e8-ab2022b956d9

10:57:33.281 |14669,,,Notifier,21,MessageStoreMonitor NOTIFYQ_ACTION_SEEN_MSG_DELETEDKatresnan MailboxObjectId=d7d2ea1c-1854-411b-8187-7a096418fbf5

VoiceNormal-Priority2f26d822-9cd1-43db-97e8-ab2022b956d9

10:57:33.281 |14669,,,Notifier,21,Katresnan: Processing DeletedSeenMsgEvent

MsgId=2f26d822-9cd1-43db-97e8-ab2022b956d9

10:57:33.281 |14669,,,Notifier,24,Katresnan: Adjust saved message counts by -1 for

media=Voice priority=Normal-Priority starting 0,0,0,0,0,0,0,0,0,0,0,1,0,0,0,0,0

10:57:33.281 |14669,,,Notifier,24,Katresnan: Adjusted saved message counts for

media=Voice priority=Normal-Priority now 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

10:57:33.281 |14669,,,Notifier,1,Katresnan: resyncMsgCountsCheck for Katresnan

seq#=444 counts=0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

10:57:33.281 |14669,,,Notifier,1,Katresnan: resyncCheck found expected msgcounts

0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 seq#=444 already have seq#=444

10:57:33.281 |14669,,,Notifier,12,Katresnan, mwi extension=4444: needs MWI update due

to always-update flag.

10:57:33.281 |14669,,,Notifier,12,Katresnan: evaluate MWI -  lamp update to OFF  mwi

extension=4444

10:57:33.294 |14670,,,Notifier,21,ResultMonitor NOTIFYQ_ACTION_MWIOFF_COMPLETE Katresnan MailboxObjectId=d7d2ea1c-1854-411b-8187-7a096418fbf5

d38d9c41-8328-4fb3-acb8-186559255d6d

10:57:33.294 |14670,,,Notifier,12,Katresnan: MWI  (OFF) completed successfully for mwi

extension =4444

10:57:33.294 |14670,,,Notifier,11,writeMWIStatus for Katresnan mwi=MWI-1 ext=4444

isOn=false port=

Regards,

D0|V1D

Silver

Re: CXN 8.5 MWI sync issue on single phone

1-Run a route plan report on CUCM for the DN of the user and the MWI ON/OFF to check for any overlappings.

Nope

2-Check replication on CUC and CUCM as well. This might seem a little bit too far but we got to rule out all posibilities.

Nope

3- Is the user SIB (Unified Messaging) integrated? Might be a problem synching to Exchange.

Nope

4- Is this a SCCP (Skinny) or SIP integration?

SCCP

5- Do the application logs in RTMT (Real Time Monitoring Tool) report any information regarding that user/extension on CUCM or CUC?

Nope

6- On CUC enable all levels for the Notifier traces an gather them via RTMT (Real Time Monitoring Tool) for Connection Notifier, below is an example of how it should look in a working scenario:

Weird.  Running 8.5.1 and there are no verbosity level settings and the logs don't look like yours.  No occurances of the "NOTIFYQ_ACTION_MWI" string at all.  Is there a setting I'm missing somewhere to enable the notifier traces?  All I'm seeing is number/size of files.

Cisco Employee

Re: CXN 8.5 MWI sync issue on single phone

I don't see it mentioned here but if this was a migration from an old Unity or UC system and that old system is still running doing MWI resyncs, this can cause this hair-pulling scenario   It's also possible that a user may have this particular person's extension as another MWI extension configured.  Otherwise, like David said, set and collect Notifier traces to see if UC is dialing it out over night or whenever it's occurring.  You can download and configure the CUDLI tool and do a DB search in the tbl_notificationmwi, vw_notificationmwi, and vw_notificationallactivedevices tables focusing on the mwiextension column to see where that user's extension may be configured. 

CUDLI: http://www.ciscounitytools.com/Applications/CxN/CUDLI/CUDLI.html

Hope that helps,

Brad

Silver

Re: CXN 8.5 MWI sync issue on single phone

Thanks for the ideas Brad.  I hadn't checked with CUDLI, but did check with the user data dump tool for alt extensions.  Didn't find anything.  Not sure if there's a step I missed to enabled Notifier traces, but not seeing any configuration options other than max number of files and size per file.  These Notifier logs don't have the details which David posted -- at all, not just for this user/mailbox number.

thanks,

will

Cisco Employee

Re: CXN 8.5 MWI sync issue on single phone

The traces have to be enabled under Unity Connection Serviceability>Trace>Micro Traces>Notifier, enable all of them, wait for the issue to occur then pull them from RTMT.

Silver

Re: CXN 8.5 MWI sync issue on single phone

Awesome!  Love picking up new things.

Silver

Re: CXN 8.5 MWI sync issue on single phone

Thanks guys!  Somehow there was an extra MWI for this user's extension on another mailbox.  The notifier traces pointed me there inside of a couple of minutes -- so that was a great tip.

Is it safe/best practice to leave those notifier trace settings in place?  Also, did I miss something with the CUDLI search or rather which table and column would have shown me this?

thanks,

will

Cisco Employee

Re: CXN 8.5 MWI sync issue on single phone

Glad you found it - I'd suggest turning the debugs back to defaults on the Macro Traces page, there's a button to reset to defaults, it'll put all macro/micro back for you.  If you searched the entire DB for the extension in question, it would have shown up.  I'm not sure how you may have done your search but here's where it shows how to in case: http://www.ciscounitytools.com/Applications/CxN/CUDLI/Help/CUDLI.htm#_Toc346289230

You can always add a bogus MWI extension on your user account, something obvious (ie; 987654321) and save it, then go into CUDLI and do a DB search for that #, and you'll see where in the DB it's located.

Hope that helps,

Brad

380
Views
0
Helpful
15
Replies
CreatePlease to create content