Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Delay between Unity Connection and Exchange 2010

All,

We are experiencing a weird issue in our Unity/Exchange environment. We have Unity Connection 8.6 and Exchange 2010 SP2 RU6. We had been working fine up until a month ago, and now when users get a voice mail, their MWI lights up, they can access their voicemail, but they don't get the message in Outlook until several hours later, and sometimes not at all. We aren't sure what changed that caused this, and TAC has not been helpful.

tl;dr:

EVERYTHING WORKING until 8/4/2013

After 8/4/2013: Voicemails work but not delivered to Exchange in a timely manner (sometimes delays of hours)

Any ideas?

7 REPLIES
Cisco Employee

Delay between Unity Connection and Exchange 2010

Hi,

Thanks for the question.

Under a user account, perform a test of the UM service. What happens there?

Do you have a CUC cluster? Do you see any behavior changes if you failover to the other node? When you fail over, the MBX sync service will stop on one node and start on another. It could be that the MBX sync serivce was in a bad state. When was the last time the CUC cluster was restarted?

On the Exchange side, do you see any errors under the event viewer application logs? Have you looked at restarting any CAS servers or changing the UM service to use a different CAS server? Depending on how you have it setup, you could be using autodiscover to find the CAS servers however you may want to find out if you see a delay when trying to connect to a specific CAS or not.

Good Luck,

Brad

New Member

Delay between Unity Connection and Exchange 2010

Thanks for the reply, Brad.

When I click "test" it succeeds without error.

We have a 2 CUC servers. No behavior change when the mailbox sync service is activated on another node. We rebooted both servers (as well as the Exchange servers) and there was no change in behavior.

I don't see any errors on the Exchange side (I am more of an Exchange admin than a telecom admin). I've restarted the CAS servers. I've pointed the UM service at individual CAS servers rather than having the service search for servers, and again, no change in behavior.

Cisco Employee

Delay between Unity Connection and Exchange 2010

Hi,

It will help you to be more of an Exchange admin for this type of an issue since most of the troubleshooting can be on the Exchange side.

Let's clarify a few details first.

Can any users see any voicemails show up in their email mailboxes? Based on your original statement, I would expect to see CUC trying to deliver the messages and fail for a period of time. Eventually the CUC server will get the message delievered however you should see multiple attempts of trying to deliever that message before it actually completes.

I would test the following to see exactly what exactly is breaking down.

1. Create a clean mailbox or if you already have a test mailbox make sure to delete any old voicemail messages on both CUC and Exchange sides.

2. Specify the CAS server under the UM service config page. I would even go so far as to have Wireshark running on the CAS server as well to verify that traffic is going in between the two servers. filter that traffic on the IP address of the CUC server. If necessary, you can create a new UM service pointing it to the CAS server and only assiging the test user to it for simplicity reasons.

3. Leave a new VM for that test user and see what happens. Do you see the EWS traffic and how frequently do you see it come in? Make sure to see CUC trying to make those connections.

Depending on what happens next I would also try the following:

4. Use EWSEditor to verify that you can gain access to the mailboxes via the CAS server with the correct permissions.

http://archive.msdn.microsoft.com/ewseditor

EWSEditor is an MS tool that you can simulate the same type of connect being made from the CUC server.

5. Check my DNS, under the UM service are you using DNS names or IP addresses? What happens if you use only IP addresses (to take DNS out of the mix)?

Based on the behavior that you're describing we should see some change. If CUC's MBX sync has been started verify that EWS requests are getting sent. If the CAS server gets the request what happens next on the Exch side? You may have to turn up some EWS traces on the Exchange side to help verify that everything is working within a reasonable fashion on the Exch side.

Thanks,

Brad

New Member

Delay between Unity Connection and Exchange 2010

I've used EWSEditor to verify access with the UM Service account pointed at both CAS servers, but what permissions do I need to check?

New Member

Delay between Unity Connection and Exchange 2010

Something I noticed - in the EWS Editor, the folder UCxNData - I see a TotalCount and UnreadCount. They are both 1. I did have 1 unread voicemail in my VM box so I deleted it.

I logged out of EWSEditor and went back in, and it still says 1 TotalCount and 1 UnreadCount.

New Member

Delay between Unity Connection and Exchange 2010

In EWSEditor - I also see my "All Items" (normal mail items) updating normally in EWSEditor. For instance, I had 40 unread items, I marked all as read, now I have 0 unread items.

New Member

Delay between Unity Connection and Exchange 2010

And to answer your original question - yes, eventually the voice  messages get delivered for all users, but it is 4-8 hours late. The only  time they DON'T see get the voice messages delivered is if they delete  the voicemail from their phone.

I will also add, there are times that I notice all my  voice messages get delivered at night, but then I will call and leave  myself a test message, and it instantly arrives!

651
Views
0
Helpful
7
Replies