Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DiRT Restore, SQL exclusive access issues

I built a new Unity box (4.0(4), no SR1), and I am trying to do a DiRT Restore. When I run DiRT Restore, I get the error that DiRT could not get exclusive access to the SQL databases. Per the DiRT docuemnt, I have tried stopping and starting the SQL services, then pressing OK to continue. This doesnt work, and I keep getting the error. This is a brand new box with nothing else on it. I reboot the box and try a DiRT restore, and it still happens. My versions are the same, except for Exchange. The new box has Exchange SP3 on it, any chance that is causing the error?

3 REPLIES
Cisco Employee

Re: DiRT Restore, SQL exclusive access issues

Kind of doubt SP3 is related, but you never know about such things...

Gotta find out what process is holding on to the SQL handle for UnityDB - some backup application maybe? virus protection?

you can pop open a command window and type the following:

OSQL -E

sp_who

go

this runs the stored proc that will show all the processes with handles on all the DB - scan the output for references to UnityDb and see if you can find out what app is holding the DB open. SQL simply will not allow a restore of the DB until all parties let go.

Also, make sure you're running the latest version of DiRT restore - there was a bogus error kicking out from SQL at one point that it lumped in with the "someone has a handle on the DB" error - make sure you're not getting bit by that - you can get the latest version on its home page here:

http://www.ciscounitytools.com/App_DisasterRecoveryTools.htm

New Member

Re: DiRT Restore, SQL exclusive access issues

I updated the version of DiRT I was using, and it still gives me the error. When I run the OSQL -E command, it shows all '0's on the right side. There is nothing else installed on the server, just a new Win2K install, SP4, and then SQL, Exchange, and Unity, all installed from the Unity CDs. Exchange and SQL are SP3, no ES or SR1 on Unity yet.

I'm going to open a TAC case and see what they say.

Cisco Employee

Re: DiRT Restore, SQL exclusive access issues

The 0s you see don't mean anything - if you see references to UnityDB in the list, then a procress running under the account listed has a handle open to that DB regardless of the numbers listed in the block. You should see an number of processes that have master open, for instance, but none with UnityDb.

I've never seen a system where you bounce SQL and it still reports a handle open - something aggressive is holding on to the Db on your system.

110
Views
0
Helpful
3
Replies