Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DTMF troubles %SIP-3-DIGITEND: Missing digit end event for '0'

Hi:

When i tried to call to my central says:

%SIP-3-DIGITEND: Missing digit end event for '0' for call ID 3E09FC11-D75511DF-80BAC87B-DB0D84FB@10.10.14.240

I tried to change the configuration of the dtmf but nothing happens this is my configuration.

no aaa new-model
memory-size iomem 5
clock timezone GMT -4
network-clock-participate wic 3
network-clock-select 1 T1 0/3/0
!
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.14.201 10.10.14.254
ip dhcp excluded-address 172.18.1.201 172.18.1.254
!
ip dhcp pool IPTelephony
   network 10.10.14.0 255.255.255.0
   option 150 ip 10.10.14.240
   default-router 10.10.14.240
   lease 8
!
ip dhcp pool DATA
   network 172.18.1.0 255.255.255.0
   default-router 172.18.1.240
   dns-server 172.17.0.2 172.17.0.3
      lease 8
!
!
multilink bundle-name authenticated
!
!
password encryption aes
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323
  h225 h245-address on-connect
sip
!
!
voice class codec 1
codec preference 1 g711ulaw
!
voice class codec 2
codec preference 2 g729r8
!
voice translation-rule 1
rule 1 /^98/ /8/
rule 2 /^918/ /18/
rule 3 /^90/ /0/
!
voice translation-profile cisco
translate called 1
!
!
voice-card 0
no dspfarm
dsp services dspfarm
!
archive
log config
  hidekeys
!
!
controller T1 0/3/0
shutdown
framing sf
linecode ami
cablelength short 110
ds0-group 0 timeslots 1-24 type e&m-wink-start
!
!
class-map match-all voice-signaling
match access-group 103
class-map match-all voice-traffic
match access-group 102
!
!
policy-map VoIP
class voice-signaling
    bandwidth 80
class voice-traffic
    priority 900
class class-default
    fair-queue
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.28
description DATA VLAN
encapsulation dot1Q 28 native
ip address 172.18.1.240 255.255.255.0
!
interface GigabitEthernet0/0.101
description VOICE VLAN
encapsulation dot1Q 101
ip address 10.10.14.240 255.255.255.0
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.10.14.240
!
interface GigabitEthernet0/1
ip address 172.22.1.2 255.255.255.252
duplex auto
speed auto
service-policy output VoIP
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Service-Engine1/0
ip unnumbered GigabitEthernet0/0.101
service-module ip address 10.10.14.241 255.255.255.0
service-module ip default-gateway 10.10.14.241
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip route 10.10.14.241 255.255.255.255 Service-Engine1/0
ip route 172.19.11.10 255.255.255.255 10.10.14.247
ip route 172.19.100.132 255.255.255.252 10.10.14.247
!
!
ip http server
no ip http secure-server
ip http path flash:
!
access-list 102 permit udp any any range 16384 32767
access-list 102 permit ip any any precedence critical
access-list 102 permit ip any any dscp ef
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
access-list 103 permit tcp any eq 2000 any
access-list 103 permit tcp any any eq 2000
!
!
tftp-server flash:P00405000700.bin
tftp-server flash:P00405000700.sbn
tftp-server flash:P00308000500.bin
tftp-server flash:P00308000500.loads
tftp-server flash:P00308000500.sb2
tftp-server flash:P00308000500.sbn
tftp-server flash:Analog1.raw
tftp-server flash:Analog2.raw
tftp-server flash:AreYouThere.raw
tftp-server flash:AreYouTheref.raw
tftp-server flash:Bass.raw
tftp-server flash:CallBack.raw
tftp-server flash:Classic1.raw
tftp-server flash:Classic2.raw
tftp-server flash:ClockShop.raw
tftp-server flash:Drums1.raw
tftp-server flash:Drums2.raw
tftp-server flash:FilmScore.raw
tftp-server flash:HarpSynth.raw
tftp-server flash:Jamaica.raw
tftp-server flash:KotoEffect.raw
tftp-server flash:MusicBox.raw
tftp-server flash:RingList.xml
tftp-server flash:DistinctiveRingList.xml
tftp-server flash:Piano1.raw
tftp-server flash:Piano2.raw
tftp-server flash:Pop.raw
tftp-server flash:Pulse1.raw
tftp-server flash:Ring1.raw
tftp-server flash:Ring2.raw
tftp-server flash:Ring3.raw
tftp-server flash:Ring4.raw
tftp-server flash:Ring5.raw
tftp-server flash:Ring6.raw
tftp-server flash:Ring7.raw
tftp-server flash:Sax1.raw
tftp-server flash:Sax2.raw
tftp-server flash:Chime.raw
tftp-server flash:Vibe.raw
tftp-server flash:CP7912080003SCCP070409A.bin
tftp-server flash:SCCP11.8-3-3S.loads
tftp-server flash:term06.default.loads
tftp-server flash:term11.default.loads
tftp-server flash:apps11.8-3-2-27.sbn
tftp-server flash:cvm11sccp.8-3-2-27.sbn
tftp-server flash:cnu11.8-3-2-27.sbn
tftp-server flash:dsp11.8-3-2-27.sbn
tftp-server flash:jar11sccp.8-3-2-27.sbn
tftp-server flash:CP7902080002SCCP060817A.sbin
tftp-server flash:S00105000300.sbn
tftp-server flash:ATA030203SCCP051201A.zup
!
control-plane
!
voice-port 0/0/0
shutdown
!
voice-port 0/0/1
shutdown
!
voice-port 0/3/0:0
!
voice-port 0/1/0
connection plar 6301
!
voice-port 0/1/1
connection plar 6301
!
voice-port 0/1/2
shutdown
!
voice-port 0/1/3
shutdown
!
sccp local GigabitEthernet0/0.101
sccp ccm 10.10.14.240 identifier 1 version 5.0.1
sccp ccm 10.10.10.18 identifier 3 version 6.0
sccp ccm 10.10.10.1 identifier 2 version 6.0
!
sccp ccm group 1
bind interface GigabitEthernet0/0.101
associate profile 1 register mtp001c58388810
keepalive retries 5
switchover method immediate
switchback interval 15
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 12
associate application SCCP
shutdown
!
dial-peer cor custom
name internal
name locals
name nationals
name internaltionals
!
!
dial-peer cor list locals
member internal
member locals
!
dial-peer cor list nationals
member internal
member locals
member nationals
!
dial-peer cor list internaltionals
member internal
member locals
member nationals
member internaltionals
!
dial-peer cor list internal
member internal
!
!
dial-peer voice 6300 voip
destination-pattern 630.
session protocol sipv2
session target ipv4:10.10.14.241
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 3000 voip
preference 1
destination-pattern 3[0-5]..
voice-class codec 1
session target ipv4:10.10.10.1
incoming called-number .
dtmf-relay rtp-nte h245-signal
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 3001 voip
preference 2
destination-pattern 3[0-5]..
voice-class codec 1
session target ipv4:10.10.10.18
incoming called-number .
dtmf-relay rtp-nte h245-signal
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 4098 voip
preference 1
destination-pattern 40..
voice-class codec 1
session target ipv4:10.10.10.1
incoming called-number .
dtmf-relay h245-signal h245-alphanumeric
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 4099 voip
preference 2
destination-pattern 40..
voice-class codec 1
session target ipv4:10.10.10.18
incoming called-number .
dtmf-relay h245-signal h245-alphanumeric
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 5198 voip
preference 1
destination-pattern 51..
voice-class codec 1
session target ipv4:10.10.10.1
incoming called-number .
dtmf-relay h245-signal h245-alphanumeric
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 5199 voip
preference 2
destination-pattern 51..
voice-class codec 1
session target ipv4:10.10.10.18
incoming called-number .
dtmf-relay h245-signal h245-alphanumeric
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 809 voip
corlist outgoing locals
translation-profile outgoing cisco
destination-pattern 9809[2-9]......
session target ipv4:172.19.11.10
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 829 voip
corlist outgoing locals
translation-profile outgoing cisco
destination-pattern 9829[2-9]......
session target ipv4:172.19.11.10
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 311 voip
corlist outgoing locals
translation-profile outgoing cisco
destination-pattern 9[2-9]11
session target ipv4:172.19.11.10
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 9 voip
corlist outgoing internaltionals
translation-profile outgoing cisco
destination-pattern 9T
session target ipv4:172.19.11.10
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 1809 voip
corlist outgoing nationals
translation-profile outgoing cisco
destination-pattern 91809[2-9]......
session target ipv4:172.19.11.10
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 1829 voip
corlist outgoing nationals
translation-profile outgoing cisco
destination-pattern 91829[2-9]......
session target ipv4:172.19.11.10
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 462 voip
corlist outgoing locals
translation-profile outgoing cisco
destination-pattern 9*...
session target ipv4:172.19.11.10
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 312 voip
corlist outgoing locals
translation-profile outgoing cisco
destination-pattern 911..
session target ipv4:172.19.11.10
dtmf-relay h245-alphanumeric
codec g711ulaw
!
!
num-exp 9999 6301
num-exp 9999 6301
num-exp 9999 6301
!
telephony-service
load 7914 S00105000300
load 7902 CP7902080002SCCP060817A
load 7906 SCCP11.8-3-3S
load 7910 P00405000700
load 7911 SCCP11.8-3-3S
load 7912 CP7912080003SCCP070409A
load 7960-7940 P00308000500
load ata ATA030203SCCP051201A
max-ephones 100
max-dn 280
ip source-address 10.10.14.240 port 2000
auto assign 1 to 100
  url services http://10.10.14.241/voiceview/common/login.do
url authentication http://10.10.14.241/voiceview/authentication/authenticate.do
time-zone 15
date-format dd-mm-yy
voicemail 6300
max-conferences 8 gain -6
moh hold.au
  dn-webedit
time-webedit
transfer-system full-consult
secondary-dialtone 9
login timeout 5
after-hours block pattern 1 90
after-hours block pattern 2 912
after-hours block pattern 3 913
after-hours block pattern 4 914
after-hours block pattern 5 915
after-hours block pattern 6 916
after-hours block pattern 7 917
after-hours block pattern 8 918
after-hours block pattern 9 919
after-hours block pattern 10 910
after-hours day Sun 00:00 23:59
after-hours day Mon 00:00 23:59
after-hours day Tue 00:00 23:59
after-hours day Wed 00:00 23:59
after-hours day Thu 00:00 23:59
after-hours day Fri 00:00 23:59
after-hours day Sat 00:00 23:59
create cnf-files version-stamp 7960 Oct 13 2010 19:31:04
!
!
ephone-dn  1  dual-line
number 6500
call-forward busy 6300
call-forward noan 6300 timeout 21
!

1 REPLY
Cisco Employee

Re: DTMF troubles %SIP-3-DIGITEND: Missing digit end event for '

Possible that it's the same problem described in the following TACCC

http://www.ciscotaccc.com/kaidara-advisor/voice/showcase?case=K40400435

If those changes don't resolve the issue then provide additional information on the call flow and when the error is seen. Please include the devices involved.

-Felipe

531
Views
0
Helpful
1
Replies
CreatePlease to create content