Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Error while MSCW in the Unity 4.0(3)

- Unity 4.0(3)

- Exchange 2K sp3, off box

I have an error message as following whenever I run the MSCW(Msg Store Cfg Wizard) from Add/Remove program menu.

---

Cisco Unity has NOT been properly installed.

- Failure encountered while synchronizing the SQL database with the mail stire.

hr=0x80004005.

---

The wired symptom is the "Log On As" accounts are change to "UnityInstall" from "UnityDirSvc" for AVDSAD and AVDSGlobalCatalog if I run the MSCW. the event log at this time,

---

Event ID=1048

Source=CiscoUnity_DSAD

The AvDSAD service failed to create object.

Type: AVOBJECTTYPE_RECIPIENT

Name: TGarner

Reason: ERROR_DS_NO_SUCH_OBJECT: There is no such object on the server.

Domain Controller: TORUDC01.deunitycorp.com

Possible causes include: 1) Network connectivity to the Domain Controller. 2) Insufficient rights for the AvDSAD service account.

Ensure that the AvDSAD service can contact the Domain Controller and has sufficient rights to create objects. If the problem persists, enable all the micro traces for the AvDSAD service in the Unity Diagnostic Tool. Report the problem to Cisco TAC and include the diagnostic log.

For more information, click: http://www.CiscoUnitySupport.com/find.php

---

- If I issue the "setup" command in the \commserver\configurationsetup directory, not change the Log On as account. remains as UnityDirSvc but not asking the Exchange Partner.

- DSAD micro trace shows exactly same as the event log.

Advise please.

Thanks,

1 REPLY
Cisco Employee

Re: Error while MSCW in the Unity 4.0(3)

I think your problem may be due to CSCeb07397 GC sync fails with E_ADS_BAD_PATHNAME when DL contains forward slash if you do not have SR1 installed. http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_release_note09186a0080205a1e.html

HRESULT code 0x80004005 means that either the object does not exists or not enough permission.

If the problem is due to TGarner account, check to see if the account used to start AvDsAd and AvDsGlobalCatalog has rights to make changes to TGarner account.

I presume that the Domain Controller: TORUDC01.deunitycorp.com is correct.

What about the GC server. Check in the registry

HKEY_LOCAL_MACHINE\SOFTWARE\Active Voice\Directory Connectors\

DirSynchGlobalCatalog\1.00\Directory\DefaultGlobalCatalogServer.

and make sure you can telnet to port 3268 which is the GC port.

139
Views
0
Helpful
1
Replies
CreatePlease to create content