Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Exchange 2003 Schema Updated - still at Unity 3.1(5)

Hi Jeff, Keith, et all:

This past weekend, Exchange 2003 schema updates were added to our forest. I have already logged a TAC case, #F081720 and spoken with Mike about needing to upgrade our Unity server to 4.0(3). I will be performing the upgrade this evening. Unity is still operational for some subscribers via the TUI, most are getting the failsafe message. Here's what I wanted to check with you. I want to break my mirror set, which will require a Unity shutdown. However, since Unity cannot communicate with AD or Exchange as a result of the schema updates, how should I proceed? I can put Unity into UMR mode, but I will need to contact my peer Exchange 2000 server for the configuration part of the upgrade. Do you have any recommendations or considerations I should make? I will update my TAC case with same information, so Mike can know I made this post.

Thanks in advance. Ginger

6 REPLIES
Gold

Re: Exchange 2003 Schema Updated - still at Unity 3.1(5)

Actually all of the schema extensions are backwards compatible so this shouldn't be causing the problem. Are you sure nobody upgraded one of the servers to Exchange 2003? That would cause this to happen for sure.

Send me over your application log and I can take a quick peak. kechambe@cisco.com.

Thanks,

Keith

Gold

Re: Exchange 2003 Schema Updated - still at Unity 3.1(5)

Just an update on this issue...

Ginger and I worked offline and determined that 'receive as' permission had been set to deny for the Exchange Domain Servers group. Since Unity needs that permission to logon to the user mailboxes logons were failing. We changed their Unity system over to the 4.0(3) permissions model and things are back normal.

The root of the cause was running Exchange 2003 ForestPrep after all. Running Exchange 2003 ForestPrep causes a DENY ACE to be placed on the 'Servers' containers in every Administrative Group for the Exchange Domain Servers group.

Thanks,

Keith

Re: Exchange 2003 Schema Updated - still at Unity 3.1(5)

Hi Keith -

We are getting error messages this morning attempting to import Unity subscribers from our domain. Error: illegal configuration: MailStore list cannot be empty (for server COSP-M-PF01) in Active Directory configuration. See Unity Troubleshooting Guide. The server COSP-M-PF01 is not in our domain. I checked the registry and did not find this server listed anywhere. It shows up in the Exchange Server field of the Add Subscriber screen in SA (note the field is greyed out). At the same time, we are seeing this error in the app event log: AvDirSynch_MC LDAP Insufficient Rights and the following objects are shown (ciscoEscbuListinUMDirectory and ciscoEscbuUMLocationObjectId). The user is then partially defined in Unity in that the import fails, but I am able to see the user if I do a find Unity subscriber. No Subscriber Properties are visible by using the "Remove Subscriber Properties" tool. I suspect once we get the errors resolved, I will need to do userid cleanup in Unity db.

Ginger

Gold

Re: Exchange 2003 Schema Updated - still at Unity 3.1(5)

This last post turned out to be permissions related. Rights were set that the domain/users level where they actually needed to be set at the domain/ level. Once this was corrected by rerunning the permissions wizard imports went as normal.

Thanks,

Keith

New Member

Re: Exchange 2003 Schema Updated - still at Unity 3.1(5)

Will re-running the latest Permissions Wizard resolve this? Or do I need to manually check and reset the proper permissions?

I have Unity 4.0(3) SR1, Exchange 2k. Someone ran Exchange 2k3 AD extensions a couple of weeks ago, now today, Unity think Exchange is offline.

I re-ran the latest Permissions Wizard, and it says it completed successfully, but it's still not working.

Thx!

Re: Exchange 2003 Schema Updated - still at Unity 3.1(5)

Had a client update their exchange servers to 2003 and do forestprep, and unity 3.15 no longer works as expected.

Can unity be upgraded to 4.0x fine after exchange is on 2003 and such without problems or any tricks to get upgrade to go?

111
Views
0
Helpful
6
Replies
CreatePlease login to create content