Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

External messages not getting delivered in Unity 4.0(2)

I have a problem with my Unity 4.0(2) system that started when I applied updates using the Cisco Unity Server Update Wizard. The system is a Windows 2000 server with Exchange 2000 on box, running Unity 4.0(2). Since applying the updates my Unity system no longer delivers messages from external callers to my subscribers. However, internal messages are delivered just fine. Every time the sustem tries to deliver an external message I receive the following error in my Windows Application Event Log: A message was moved to failed directory on line 572 of e:\views\Unity4.0.1.55\un_Conv3\UnityUMR\AvUMRSyncSvr\UMRThread.cpp 0x00001624

I have used the latest dbWalker, and it found no errors. I have re-ran the latest Permissions wizard, and I have re-ran the Message Store Configuration Wizard all to no avail. I opened a TAC case, but they didn't feel that this issue could have been created by the update wizard, so they had me re-run the Permissions Wizard. Now that I have done that, I cannot get back in touch with my engineer.

Does anyone have any idea what would cause external messages to fail to be delivered while internal messages work fine?

Any help would be greatly appreciated.

Thank you,

Aaron

  • Unified Communications Applications
8 REPLIES
Cisco Employee

Re: External messages not getting delivered in Unity 4.0(2)

Aaron,

All external messages go through a different process for delivery. They are sent through the Unity_ mailbox. Check to see if that mailbox still exists and that there are no problems there. You may want to also try giving AvUMRSyncSvr service a restart.

Brad

New Member

Re: External messages not getting delivered in Unity 4.0(2)

Brad,

Thank you for your quick reply. I don't think that I am seeing that mailbox in Exchange System Manager. I do see a mailbox called "Unity Messaging System - ", but I don't think that that is the one that you are referring to. I checked the Unity_ account in AD Users and Computers, and the SMTP address shown there is Unity_ as you suggested. I assume that this is a problem. Is that a safe assumption? If so, how do I go about creating that mailbox so that external messages will be delivered properly?

Thank you for your tiem and assistance,

Aaron

Cisco Employee

Re: External messages not getting delivered in Unity 4.0(2)

Aaron,

You're seeing the correct information. The mailbox is Unity Messaging System, the AD account its tied to is the Unity_. UMR traces will probably need to be set for TAC to take a look at.

Brad

Cisco Employee

Re: External messages not getting delivered in Unity 4.0(2)

you can find the instructions here:

Cisco Unity 3.1(x) and 4.x: AvCsMgr Service Fails to Start

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_tech_note09186a00800949dc.shtml

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: External messages not getting delivered in Unity 4.0(2)

I took a look at that documentation, but I don't think that it applies to my situation. I seem to have everything in place as it should be, and my AvUMRSyncSvr service is started.

Is there anything else that would cause a failure in delivering messages from external callers, but not internal callers?

Thank you for all of your time and assistance,

Aaron

Cisco Employee

Re: External messages not getting delivered in Unity 4.0(2)

as already noted the issue is with unity_, try running the PW and the MSCW -sync

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: External messages not getting delivered in Unity 4.0(2)

Thank you to everyone that provided me with assistance on this issue. I have resolved the issue at this point, however, I am not sure exactly what did it. To be honest, I went through several restarts of the server, several run throughs of the Permissions Wizard and the Message Store Config Wizard all with no positive outcome. However, just as a last resort, I repeatedly stopped and started the AvUMRSyncSvr service, and for some reason on restart number 7 of that service things started working again. By the way, my AvUMRSyncSvr never failed to start, it just failed to deliver the messages correctly.

So again, thank you for all of your assistance. I really appreciate your time and expertise.

Aaron

Cisco Employee

Re: External messages not getting delivered in Unity 4.0(2)

Glad we could help :)

184
Views
0
Helpful
8
Replies