Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

HTTP 500 error message

Hello There,

After upgrading our CER 8.5 to 9.0.2, we are receiving an HTTP 500 erreur message when we try to access the CER admin page. We intalled the COP file before upgrading to 9.0.2. When we switch version to 8.5, we can access the admin page with no issue.

Can we switch back to 8.5 and run the refresh upgrade and then upgrade to 9.0.2 again? Or we need first to delete the inactive partition and then start it over?

 

admin:show version active
Active Master Version: 9.0.2.10000-1
Active Version Installed Software Options:
ciscocm.cer_refresh_upgrade_v1.1.cop

 

admin:show version inactive
Inactive Master Version: 8.5.1.10000-7
Inactive Version Installed Software Options:
ciscocm.cer_refresh_upgrade_v1.1.cop

 

 

HTTP Status 500 -

type: Exception report

message:

description: The server encountered an internal error () that prevented it from fulfilling this request.

exception:

javax.servlet.ServletException: Servlet.init() for servlet CERAdminServlet threw exception
	org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:563)
	org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:555)
	org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:421)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857)
	org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
	org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
	java.lang.Thread.run(Thread.java:662)
                

 

root cause:

java.lang.IllegalThreadStateException
	java.lang.Thread.start(Thread.java:638)
	com.cisco.e911.db.CERPollActiveDBThread.startThread(CERPollActiveDBThread.java:42)
	com.cisco.e911.systemadmin.E911AdminModel.initialiseLdap(E911AdminModel.java:958)
	com.cisco.e911.systemadmin.E911AdminModel.init(E911AdminModel.java:173)
	com.cisco.e911.systemadmin.E911AdminServlet.start(E911AdminServlet.java:78)
	org.webmacro.servlet.WMServlet.init(WMServlet.java:137)
	javax.servlet.GenericServlet.init(GenericServlet.java:212)
	org.webmacro.servlet.WMServlet.init(WMServlet.java:89)
	sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	java.lang.reflect.Method.invoke(Method.java:597)
	org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:269)
	java.security.AccessController.doPrivileged(Native Method)
	javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
	org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:301)
	org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:162)
	org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:115)
	org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:563)
	org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:555)
	org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:421)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857)
	org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
	org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
	java.lang.Thread.run(Thread.java:662)
4 REPLIES
Bronze

Anybody with any idea? MK

Anybody with any idea?

 

MK

Bronze

Would that be possible to

We started from scratch, rebuilt a 8.5 version of CER and then upgraded to 9.0.2 using the COP file. Now, the switch version using CLI fails but it works from GUI.  This is a lab environment with a single Pub server. Would you guys happen to know where the issue is?

Here's the error message:

Switching Version and Restarting the Appliance ...
Failed to Switch Version and Restart the Appliance

 

Thanks,

 

MK

Bronze

Last call before opening a

Last call before opening a TAC case?

Thanks,

 

MK

Bronze

Just wanted to update this

Just wanted to update this for those having the same issue.

I opened a TAC case and the engineer came up with the following answer:

CSCup98189    Unable to Switch Versions from CLI after Upgrade

https://tools.cisco.com/bugsearch/bug/CSCup98189

 

Symptom:

unable to switch versions from cer 8.6(1) to 9.0(2) after upgrade on pub and sub

 

Workaround:

switch version from GUI through OS Admin page

 

possible you may need to login to CER Admin first and then OS Admin

 

Thanks,

 

MK

152
Views
0
Helpful
4
Replies