Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IM&P 10.5.1 node not syncing NTP with CUCM 10.5.1 Publisher

Hi,

I've got a weird problem where the 10.5.1 UC cluster appears to be healthy and all working 100%, however the IM&P server is using it's own internal clock as it's time source and is not syncing NTP to the CUCM Publisher.

I had an issue earlier where the CUCM Publisher was unable to control the IM&P server's 'serviceability'. I followed the tasks outlined in this post: https://supportforums.cisco.com/discussion/11074916/connection-server-cannot-be-established-unable-access-remote-node to re-generate the tomcat.pem, ipsec.pem, tvs.pem and capf.pem certificates and then reboot the cluster.

I'm not sure if that's related to the problem that I have with NTP sync on the IM&P node, but I thought it's worth mentioning.

Here's the NTP output from the CUCM Publisher:

admin:utils ntp status
ntpd (pid 8416) is running...

     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*172.16.20.20    192.189.54.33    3 u   80  128  377    0.417   19.946   9.433
+172.31.1.254    203.12.160.2     4 u   78  128  377    0.598   12.635   4.292


synchronised to NTP server (172.16.20.20) at stratum 4
   time correct to within 123 ms
   polling server every 128 s

Current time in UTC is : Mon Aug 18 06:12:25 UTC 2014
Current time in Australia/Melbourne is : Mon Aug 18 16:12:25 EST 2014

 

Here's the output from the IM&P Node:

admin:utils ntp status
ntpd (pid 5988) is running...

     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
+27.54.95.12     233.171.100.138  3 u   55  128  377   67.903    1.117   4.620
*129.250.35.251  204.123.2.72     2 u  123  128  377  169.505    2.260   2.991
+27.106.200.44   192.231.203.132  3 u   17  128  377   17.611  -26.154   1.959


synchronised to NTP server (129.250.35.251) at stratum 3
   time correct to within 64 ms
   polling server every 128 s

Current time in UTC is : Mon Aug 18 06:13:17 UTC 2014
Current time in Australia/Melbourne is : Mon Aug 18 16:13:17 EST 2014
 

admin:utils ntp config
This node is configured to synchronize with its hardware clock.
 

admin:utils ntp server add 172.16.20.31
172.16.20.31 : [The requested action is not permitted on a subsequent node (Subscriber).]

 

Any suggestions on how to validate, troubleshoot or fix this issue?

Dave

2 REPLIES
VIP Super Bronze

It's not using the CUCM-Pub

It's not using the CUCM-Pub as 129.250.35.251 is in a higher stratum and thus more preferred. You can try 'utils ntp server delete' to see if it'll let you pull the other addresses out. If not, you may need TAC to clean this up via root access.

Please remember to rate helpful responses and identify helpful or
New Member

Thanks for your reply

Thanks for your reply Jonathan.

I suspect you might be right regarding the stratum, however these 'internal' NTP servers cannot be deleted.

We bought the UC 10.x NFR kit from Cisco as we're an integration company and it's for our internal use only. As such, I don't think we're able to log TAC cases against it.

It's not causing us any grief.  The time on the IM&P server matches the time on our CUCM anyway, so I think we'll just leave it.

 

1348
Views
4
Helpful
2
Replies