Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Integration CUCM with ERICSSON MX1

                  Hi All ,

                             I am facing a problem , i did the integration b/w CUCM and ericsson MX1 through E1 connection .. i am using gateway protocol

MGCP...now the problem is that from i cant call CISCO phone to ERICSSON  phonegive busy ..but from ERICSSON ph to CISCO ph calls ok

Apprecite if some one help.

below are the details,,,

nwafh_vg#

nwafh_vg#

May 28 14:52:10.914: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x000D

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9839F

                Exclusive, Channel 31

        Facility i = 0x9FAA06800100820100A1080201000201008400

        Calling Party Number i = 0x0081, '87010'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0xC1, '85011'

                Plan:ISDN, Type:Subscriber(local)

May 28 14:52:10.950: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x800D

        Cause i = 0x81D2 - Identified channel does not exist

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

May 28 14:52:57.646: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0018

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA18398

                Preferred, Channel 24

        Facility i = 0x9FAA068001008201008B0100A1100201010201553008820301B850860101

        Progress Ind i = 0x8183 - Origination address is non-ISDN 

        Called Party Number i = 0xC9, '87010'

                Plan:Private, Type:Subscriber(local)

        User-User i = 0x00FE, 'U', 0x0100, 'Y', 0x0100B10C07, 'I', 0x81, '85011'

        Shift to Codeset 4

        Codeset 4 IE 0x31  i = 0x80

May 28 14:52:57.650: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8018

        Channel ID i = 0xA98398

                Exclusive, Channel 24

May 28 14:52:57.654: ISDN Se0/0/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x8018

        Facility i = 0x9FAA06800100820100A1080201010201018400

        Progress Ind i = 0x8088 - In-band info or appropriate now available

May 28 14:53:07.134: ISDN Se0/0/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x8018

        Facility i = 0x9FAA06800100820100A1080201020201028400

        Connected Number i = 0x0081, '87010'

May 28 14:53:07.294: ISDN Se0/0/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x0018

nwafh_vg#

nwafh_vg#

May 28 14:53:57.761: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x0018

        Cause i = 0x8190 - Normal call clearing

        User-User i = 0x00FE

May 28 14:53:57.785: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8018

May 28 14:53:57.813: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x0018

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

May 28 14:52:10.914: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x000D

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9839F

                Exclusive, Channel 31

        Facility i = 0x9FAA06800100820100A1080201000201008400

        Calling Party Number i = 0x0081, '87010'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0xC1, '85011'

                Plan:ISDN, Type:Subscriber(local)

May 28 14:52:10.950: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x800D

        Cause i = 0x81D2 - Identified channel does not exist

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

nwafh_vg#

May 28 14:52:57.646: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0018

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA18398

                Preferred, Channel 24

        Facility i = 0x9FAA068001008201008B0100A1100201010201553008820301B850860101

        Progress Ind i = 0x8183 - Origination address is non-ISDN 

        Called Party Number i = 0xC9, '87010'

                Plan:Private, Type:Subscriber(local)

        User-User i = 0x00FE, 'U', 0x0100, 'Y', 0x0100B10C07, 'I', 0x81, '85011'

        Shift to Codeset 4

        Codeset 4 IE 0x31  i = 0x80

May 28 14:52:57.650: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8018

        Channel ID i = 0xA98398

                Exclusive, Channel 24

May 28 14:52:57.654: ISDN Se0/0/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x8018

        Facility i = 0x9FAA06800100820100A1080201010201018400

        Progress Ind i = 0x8088 - In-band info or appropriate now available

May 28 14:53:07.134: ISDN Se0/0/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x8018

        Facility i = 0x9FAA06800100820100A1080201020201028400

        Connected Number i = 0x0081, '87010'

May 28 14:53:07.294: ISDN Se0/0/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x0018

nwafh_vg#

nwafh_vg#

May 28 14:53:57.761: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x0018

        Cause i = 0x8190 - Normal call clearing

        User-User i = 0x00FE

May 28 14:53:57.785: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8018

May 28 14:53:57.813: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x0018

nwafh_vg#

nwafh_vg#

Everyone's tags (3)
5 REPLIES

Re: Integration CUCM with ERICSSON MX1

Hi Shaikh,

The failed call deug shows that the call is using channel 31 and the remote device is returning an error indicating that channel 31 does not exist. Make sure your timeslots that's configured on your controller match what is being used on the other end of the E1.

May 28 14:52:10.914: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x000D

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9839F

                Exclusive, Channel 31

        Facility i = 0x9FAA06800100820100A1080201000201008400

        Calling Party Number i = 0x0081, '87010'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0xC1, '85011'

                Plan:ISDN, Type:Subscriber(local)

May 28 14:52:10.950: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x800D

        Cause i = 0x81D2 - Identified channel does not exist

Request to share the configuration of the voice gateway for better understanding.

Thanks,

Gagarin

Regards, Gagarin Please rate all helpful posts.
New Member

Re: Integration CUCM with ERICSSON MX1

Current configuration : 7797 bytes

!

! Last configuration change at 10:24:12 UTC Mon May 28 2012 by admin

! NVRAM config last updated at 10:21:04 UTC Mon May 28 2012 by admin

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname nwafh_vg

!

boot-start-marker

boot-end-marker

!

!

card type e1 0 0

logging buffered 51200 warnings

enable password nwafh!@#$

!

no aaa new-model

network-clock-participate wic 0

network-clock-select 1 E1 0/0/0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

no ip domain lookup

ip domain name yourdomain.com

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-qsig

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1380030298

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1380030298

revocation-check none

!

!

crypto pki certificate chain TP-self-signed-1380030298

certificate self-signed 01

  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31333830 30333032 3938301E 170D3131 31313236 30333335

  32335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 33383030

  33303239 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100CE0A BE929B99 E5E452A1 C1DBD1B2 02C35FD2 940DDEAD E6A94BAF 9F45EA56

  A166FA91 A9403590 BFA17A87 A9E216C7 4B63C55D 8A3BB7DF 1B689B88 EAFF9C91

  13011965 5B4163E7 D988A226 E5B892ED 1105E8A8 1F851238 3AC833B8 CE76FA01

  3909D632 7A8A34C6 EC0E340A D860F390 D3FA90F6 4BEE2FE7 EF75ED1F 7006A241

  5C450203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603

  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D

  301F0603 551D2304 18301680 147ACA59 7459B592 B37E603F 998D3E0F 7CFB668B

  7A301D06 03551D0E 04160414 7ACA5974 59B592B3 7E603F99 8D3E0F7C FB668B7A

  300D0609 2A864886 F70D0101 04050003 8181001E F3B38D42 5BB76289 B51FF270

  D66AB97A 9982A00D 38C397A7 7F64A4D6 0AD28172 A4BBFC53 85AE6AE5 562C6C47

  415C0E89 9688FDA8 7BE5C95D 41677235 3808DDA4 B665997D A84FFB47 20219BF8

  EBD381F2 BC7A48BA 295B5C19 382AE3F4 DC39457B C8A89A94 672B9CC0 7EE6E85F

  269A6044 EEE4EC94 559EE998 78568257 DC29AF

        quit

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

codec preference 4 g729br8

!

!

!        

!

!

license udi pid C3900-SPE100/K9 sn FOC15450QGQ

hw-module pvdm 0/0

!

!

!

username admin password 0 nwafh!@#$

!

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-31 service mgcp

!

controller E1 0/0/1

pri-group timeslots 1-31 service mgcp

!

!

!

!

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 172.16.151.50 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn contiguous-bchan

isdn bchan-number-order ascending

no cdp enable

!

interface Serial0/0/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn bchan-number-order ascending

no cdp enable

!

!

ip default-gateway 172.16.151.254

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 172.16.151.254

!

logging esm config

!

!

!

!

nls resp-timeout 1

cpd cr-id 1

!

!

control-plane

!

!

voice-port 0/0/0:15

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

voice-port 0/0/1:15

!

voice-port 0/2/0

!

voice-port 0/2/1

!

voice-port 0/2/2

!

voice-port 0/2/3

!

voice-port 0/3/0

!

voice-port 0/3/1

!

voice-port 0/3/2

!

voice-port 0/3/3

!

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 172.16.151.10 

ccm-manager config

!

mgcp

mgcp call-agent 172.16.151.10 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0

associate profile 2 register CFB00235e3668e0

associate profile 1 register mtp00235e3668e0

switchover method immediate

switchback method immediate

!

dspfarm profile 1 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

maximum sessions 1

associate application SCCP

shutdown

!

dspfarm profile 2 conference 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 10

associate application SCCP

shutdown

!

dial-peer voice 66666 pots

service mgcpapp

port 0/0/0:15

!

!

!

!

gatekeeper

shutdown

!

banner exec ^C

% Password expiration warning.

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.

It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.

username privilege 15 secret 0

Replace and with the username and password you want to

use.

-----------------------------------------------------------------------

^C

banner login ^C

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device.

This feature requires the one-time use of the username "cisco" with the

password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN

CREDENTIALS

Here are the Cisco IOS commands.

username   privilege 15 secret 0

no username cisco

Replace and with the username and password you want

to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE

TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the

QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp

-----------------------------------------------------------------------

^C

!

line con 0

exec-timeout 0 0

logging synchronous

login local

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

Integration CUCM with ERICSSON MX1

+++ Have you confirmed that timeslots configured on your controller match what is being used on the other end of the E1 ?

If yes and still not working try below,

+++ If you are the 'network' side, then you should probably set 'clock source internal' on the E1 controller.

+++ Under the serial interface of the pri enter 'isdn protocol-emulate Network'

Also, you have configured "isdn bchan-number-order ascending" and as per the config the channel that should be selected is starting from B1, but in the debug of the failed call we see that B31 is selected, this is weird and the call fails because there is no such channel as per the debugs.

Should it be an issue with certain B-channels, then there's a  service parameter in  CallManager, that can busy-out certain B channels, so those wouldn't be used. May be you can try to busy out certain B channels (those in which the call fails now). This can be done with the procedure given in the below link,

http://puck.nether.net/pipermail/cisco-voip/2005-July/006097.html

Do let know if any of the above fixes your issue.

Regards,

Gagarin

Regards, Gagarin Please rate all helpful posts.
New Member

Integration CUCM with ERICSSON MX1

Hi Gagarin ,

                Thankyou for your time & responces ..the issue has been resolve after we change CHANNEL IE TYPE *:CONTINOUS NUMBER TO TIMESLOTS  in  MGCP GATEWAY configuration ---INTERFACE INFORMATION in CUCM.

Integration CUCM with ERICSSON MX1

Glad to know that the issue is resolved

Regards,

Gagarin

Regards, Gagarin Please rate all helpful posts.
1092
Views
15
Helpful
5
Replies
CreatePlease to create content