Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

IPCC Express - Recording

Hi all,

I know, that similar issues has been discussed a few times - but unfortunately it seems that my issue is a bit different...

I run a IPCC express premium cluster and want to set up an agent based recording for some of my hotlines.

The configuration of my voice application, the IPCC script and the workflow settings are clear.

And I am also be aware, that in case of using VLANs, I have to use appropriate LAN cards which supports the promiscuous mode. (I verified this function with the NICQ.exe tool and with a packet capture app).

My actual problem is described as follows:

When I receive an incoming call at my test hotline's agent, I go off-hook. At the same time, CAD shows with a little red icon, that this call gets recorded and at my recording / monitor server, two files has been created. (<file name>.To.Raw.tmp and (<file name>.From.Raw.tmp with 0kB each).

After going on-hook, the file names has been changed to (<file name>.To.Raw and (<file name>.From.Raw with 1kB in size (or in more detail: 24Bytes).

All postings or documentations regarding this issue I read so far stated that there is obviously an issue that the RTP packets are not able to pass the TCP/IP stack at the CAD client and therefore not able to "reach" the CAD application.

But I tested it in two different szenarios:

1) With a hard phone (7961) connected to a desktop (SPAN to PC port enabled).

(Different Voice and Data VLAN)

2) With an IP Communicator at the CADs Notebook.

In both cases, I can sniffer all RTP packets between the agents phone and the callers phone at the agents PC. And I am also able to replay this VoIP stream.

But even though, I can't see any RTP packets sending from the CADs PC to the monitoring server...

To me it looks like, the CAD are not able to resend this stream to it's monitoring server (even if there is "some" communication between these both, because it creates these 24Byte files based on each call...)

Has anyone an idea?

Thanks in advance,



Re: IPCC Express - Recording

To narrow down the problem, could you test voice monitoring first? Can a supervisor successfully monitor an agent's call?


New Member

Re: IPCC Express - Recording


thanks for your prompt reply!

I tried to test the voice monitoring with a supervisors desktop.

After starting the monitoring, it took a few seconds. Then a pop up window appears stating an error message, that the monitoring session isn't working.

The message is actually in German, so I am afraid I can't give you the exact wording.

But it says that the supervisor desktop cannot receive speech from the agents IP Phone.

And after it, there are some explanations about some possible causes.

(E.g. Agents IP phone is not connected with agents PC. Or incompatible LAN card. No SPAN port configuration. Wrong VoIP monitor server...)

But as far as I can judge, everything from the above mentioned possible hints has been configured correctly.

Do you have an idea, how I can check, that every CAD related configuring is correct?

Thanks again,


New Member

Re: IPCC Express - Recording

UCCX 7.0 Premium running on VMWare.

(Demo / NFR versions from Cisco Marketplace)

I have EXACTLY the same problem !!!!

Tried IP Phone / CIPC.

On my Agent PC, can see RTP packets using sniffer.

CAD just does not seem to SEND the packets over to UCCX server.

Desktop Admin has also set the agent to use the only node as the UCCX server.

New Member

IPCC Express - Recording


I am facing the same problem. How did you resolve it?

Thank you


CreatePlease to create content