Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN PRI issues (Spain)

I'm having a hard time configuring an IDSN E1 PRI in our 2811 router.

I followed all the cisco configuration guides, tips, forums, etc, and nothing.

I think is something related with the isdn switch-type, framing, or something with the controller configuration. Remember this setup is for Spain.

This is what I've got so far:

card type E1 0 3

isdn switch-type primary-net5

network-clock-participate wic 3

network-clock-select 1 E1 0/3/0

voice-card 0

dspfarm

no local-bypass

controller e1 0/3/0

framing no-crc4

pri-group timeslots 1-8

linecode hdb3

interface Serial0/3/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

voice-port 0/3/0:15

dial-peer voice 1 pots

description PRIMARIO

destination-pattern .T

incoming called-number 902333302

direct-inward-dial

port 0/3/0:15

Any help is appreciated! I'm really stuck on this.

8 REPLIES

Re: ISDN PRI issues (Spain)

Can you post the results of "show isdn status"? It appears this is a fractional PRI and that you're using 8 channels. Does this configuration match the carriers config?

Brandon

Re: ISDN PRI issues (Spain)

Fairly generic problem description.

Generic troubleshooting steps:

'sh controller t1' - is it up? If not, physical problem.

'show isdn status' - is it multiple frame established? If not, 'debug isdn q921' and possibly check switch type. There can be some local variant (especially with BRI) for getting layer 2 up.

'debug isdn q931' for a failed call if your layer 2 is up. This will show if your dial plan or dial peers are configured correctly.

hth,

nick

New Member

Re: ISDN PRI issues (Spain)

Router#show

*Mar 24 07:21:44.407: %SYS-5-CONFIG_I: Configured from console by consoleisdn st

at

Global ISDN Switchtype = primary-5ess

ISDN Serial0/3/0:15 interface

dsl 0, interface ISDN Switchtype = primary-net5

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x00000000

Number of L2 Discards = 0, L2 Session ID = 0

Total Allocated ISDN CCBs = 0

Router#

Router#show controllers e1

E1 0/3/0 is down.

Applique type is Channelized E1 - balanced

Cablelength is Unknown

Transmitter is sending remote alarm.

Receiver has loss of signal.

alarm-trigger is not set

Version info Firmware: 20071011, FPGA: 13, spm_count = 0

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (847 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 847 Unavail Secs

Router#

I read a bit in internet, it appears to be a problem that my configuration is not matching the telco parameters? am I right?

Thanks again for the help!

Re: ISDN PRI issues (Spain)

Your T1 is down. Make sure 3 things are right:

clock source matches provider

line code matches provider

framing matches provider

If this is back-to-back between routers you need a T1/E1 crossover cable.

If this is to a smartjack, it should be a straight through cable.

hth,

nick

New Member

Re: ISDN PRI issues (Spain)

Good afternoon, thanks for all the replies! I still need help.

We talk to our provider and we have the "correct" paremeters, but we still can't work this out.

Router#show isdn stat

Global ISDN Switchtype = primary-net5

ISDN Serial0/3/0:15 interface

dsl 0, interface ISDN Switchtype = primary-net5

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x00000000

Number of L2 Discards = 0, L2 Session ID = 1

Total Allocated ISDN CCBs = 0

We tried everything, and I'm sure we're stuck on some detail we can't see. Our provider is not helping much, either.

Any more ideas? Thanks.

Re: ISDN PRI issues (Spain)

This is wiring or layer 1.

Layer 1 Status:

DEACTIVATED

No amount of ISDN configuration is going to help you now.

-nick

New Member

Re: ISDN PRI issues (Spain)

yes, sadly, I know.

The problem is, with our "old" pbx, it works. I'm only unplugging the jack on the "old" one, and plug in in the Cisco WIC. So (maybe) is not a cabling/jack/crossover cable issue.

Re: ISDN PRI issues (Spain)

The main thing to be aware of is that back-to-back requires a T1 cross over, but if you're connecting to a smartjack or an ISDN switch, it may be a straight through.

(This could be vice versa for your situation). Pins 1+4 and 2+5 are switched in the crossover scenario.

557
Views
0
Helpful
8
Replies