Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

LDAP sync, Directory URI and SIP dialing

note: CUCM version 9.1.2

I have an issue when dialing people from a Telepresence endpoint.

For phones, we have setup a specific phone service pointing to an external web server for Phone Directory.

Telepresence endpoints cannot use that service and point automatically to the default corporate directory.

Since we upgraded CUCM to version 9.1.2, the "Directory URI" parameter is now setup on end-users and their associated DN, as it is synced with LDAP.

So when we want to dial a user using the directory from a Telepresence endpoint it dials the SIP address: firstname.lastname@domain.com

The problem is that the "directory-URI" parameter pulled from LDAP is sip:firstname.lastname@domain.com

When dialing sip:firstname.lastname@domain.com from the endpoint, sip: is apparently stripped and firstname.lastname@domain.com is dialed and it never reach the end-user.

When dialing from a phone a Telepresence endpoint the URI displays as sip%3Afirstname.lastname@domain.comand when dialing that back (or diling it manualy) from the Telepresence endpoint, it then reaches the end-user.

If I add onto the end user DN, under the "directory-URI" parameter firstname.lastname@domain.com in addition to sip:firstname.lastname@domain.com then when dialing the end-user firstname.lastname@domain.com URI, the call completes.

But I don't want to to update our thousands of DNs, even with any of the bulk admin tools.

How can I get that working and make sure that the CUCM understand that firstname.lastname@domain.com is the same as sip:firstname.lastname@domain.com ?

Everyone's tags (3)
4 REPLIES
New Member

I've abou the same problem.

I've about the same problem. The only difference is that I've a SIP trunk to a VCS Control which is in the same SIP domain.

I've a SIP Route Pattern to that domain that points to the SIP trunk.

I would expect like a Route Pattern the CUCM gives priority to local registered devices before routing the call to the VCS. But this is not the case.

When I add the directory URI manually to the line then it works fine.

The trouble is that on the C-series registered devices on the CUCM the phonebook does not contain the DN's of the registered phones anymore but the SIP URI automatically loaded from the User profile...

rgds, Geert.

New Member

I think I found th esolution

I think I found th esolution to this problem.

On the CUCM Enterprise parameters adjust the following:

1. Adjust "Directory URI Alias Partition" to an existing partition, e.g. "PT_Internal"
2. Adjust "URI Lookup Policy" to "Case Insensitive"
 

This is partially documented in the CUCM v9.1 System guide under SIP URI dialing.

rgds, Geert.

 

New Member

I had already seen that part

I had already seen that part of the doc and applied the points 1 & 2 you propose.

It doesn't solve the issue.

It doesn't make the CUCM understand that firstname.lastname@domain.com is the same as sip:firstname.lastname@domain.com...

Today the only solution I can see is to manually add firstname.lastname@domain.com under the "directory-URI" parameter but this is not a viable solution. It's not possible for us to maintain that up to date manually.

New Member

It ends up being a bug in the

It ends up being a bug in the CUCM.

Caveat number are (depending on versions):

  • CSCUB73272: https://tools.cisco.com/bugsearch/bug/CSCub73272/?referring_site=ss
  • and CSCum90701: https://tools.cisco.com/bugsearch/bug/CSCum90701/?referring_site=ss
600
Views
0
Helpful
4
Replies
CreatePlease to create content