Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Logging- FreePBX to CUCM- Unauthorized Trunk w Device Mobility

Hello all...

My question\issue is 2 fold I guess...

I'm looking to find out why when I call my CUCM DN, enabled with Device Mobility (cellphone), it will not work when called from an extension from my FreePBX Asterisk box. It does not ring the configured cell phone as it should. This works fine when calling the same DN from another phone on the CUCM side, and, when I call in to my Asterisk system from my PSTN DID....which is weird why that works but calling from an "inside" Asterisk extension does not! The phones on each system are able to call eachother fine...I have a single SIP trunk set up between them. The Asterisk system acts like a gateway for PSTN calls to the outside world (SIP trunk provider)- the Cisco phones call out to PSTN fine also.

So..I fired up RTMT, and looked at a session trace. I think where it's stopping is the point where it WANTS to call the outside mobile- I get a 401 Unauthorized. See below.

2013/10/07 17:18:45.584|SIPT|21794532|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.14^192.168.0.3^*|26|b20ee00-25312535-2-500a8c0@192.168.0.5|401 Unauthorized

I was wondering also if there was another log or trace I can view\execute to get some more robust information as you do with Asterisk- like where it references the called and calling numbers, DID, etc..... that would be a further help to pin point what might be wrong.

Any help is appreciated--thanks in advance

Dennis

CUCM 8.6

Asterisk V 11.4

7 REPLIES
New Member

Logging- FreePBX to CUCM- Unauthorized Trunk w Device Mobility

How is your CUCM connected to FreePBX ? Is it directly connected or you have an intermediate device sitting there. Can you specify what is the call flow. Also, if you can attach CUCM details traces with calling, called party and time of call, it would provide more details on what is happening.

Logging- FreePBX to CUCM- Unauthorized Trunk w Device Mobility

have you tried to configure Asterisk to allow anonymous connections on your trunk between cucm and asterisk?  CUCM cant deal with authentication and a CUBE would need to sit in the middle to take care of that.


=============================
Please remember to rate useful posts, by clicking on the stars below.

=============================

Please remember to rate useful posts, by clicking on the stars below.

New Member

Logging- FreePBX to CUCM- Unauthorized Trunk w Device Mobility

minkdennis...

I believe the trunk connecting the two systems is anonymous- this is my Peer and User on the Asterisk side

Peer

type=peer

transport=udp

qualify=yes

insecure=port

host=192.168.0.5

allow=ulaw

User

insecure=port

host=192.168.0.5

context=from-trunk

allow=ulaw

New Member

Logging- FreePBX to CUCM- Unauthorized Trunk w Device Mobility

mkchandak....

CUCM is directly connected- sam LAN- same switch- nothing in between. Below is a call log for the call in question.

This is the flow basically

Free PBX extension- 1970- calls CUCM DN 3001- phone rings- I do not pick up- after 10 or so seconds the cell should ring- (Device Mobility)- it does not. I just let it ring some more and hangup.

See the Unauthorized after the second invite. Wish there was more info and clarification of what exactly is not authorized-- the asterisk extension? The trunk attempting to call the cell phone?? And like I said, it all works fine if I ring into Asterisk from my PSTN DID..... or from another CCUM registered phone. Any other logs I could be looking at? I'm fairly new to CUCM.

2013/10/09 17:41:52.117|SIPT|0|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.24^192.168.0.3^*|45|7f332e0a19c420b07dcb41ef3977c849@dtech.dnsalias.com|INVITE

2013/10/09 17:41:52.151|SIPT|0|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.24^192.168.0.3^*|46|7f332e0a19c420b07dcb41ef3977c849@dtech.dnsalias.com|100 Trying

2013/10/09 17:41:52.267|CC|SETUP|22487935|22487936|@dtech.dnsalias.com|3001|3001

2013/10/09 17:41:52.315|CC|OFFERED|22487935|22487936|1970|3001|3001|To_FreePBX|SEP0021A0857BE9

2013/10/09 17:41:52.320|SIPT|22487935|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.24^192.168.0.3^*|47|7f332e0a19c420b07dcb41ef3977c849@dtech.dnsalias.com|180 Ringing

2013/10/09 17:41:56.425|SIPT|22487936|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.24^192.168.0.3^*|48|9d0e2f80-2551cda4-1-500a8c0@192.168.0.5|INVITE

2013/10/09 17:41:56.428|SIPT|22487936|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.25^192.168.0.3^*|49|9d0e2f80-2551cda4-1-500a8c0@192.168.0.5|401 Unauthorized

2013/10/09 17:41:56.429|SIPT|22487936|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.25^192.168.0.3^*|50|9d0e2f80-2551cda4-1-500a8c0@192.168.0.5|ACK

2013/10/09 17:42:39.832|SIPT|22487935|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.26^192.168.0.3^*|51|7f332e0a19c420b07dcb41ef3977c849@dtech.dnsalias.com|CANCEL

2013/10/09 17:42:39.832|SIPT|22487935|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.26^192.168.0.3^*|52|7f332e0a19c420b07dcb41ef3977c849@dtech.dnsalias.com|200 OK

2013/10/09 17:42:39.837|SIPT|22487935|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.26^192.168.0.3^*|53|7f332e0a19c420b07dcb41ef3977c849@dtech.dnsalias.com|487 Request Cancelled

2013/10/09 17:42:39.839|CC|RELEASE|22487935|22487936|16

2013/10/09 17:42:39.841|SIPT|22487935|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.27^192.168.0.3^*|54|7f332e0a19c420b07dcb41ef3977c849@dtech.dnsalias.com|ACK

Logging- FreePBX to CUCM- Unauthorized Trunk w Device Mobility

apparently in FreePBX there is a general setting "allow anonymous inbound calls" somewhere, but you might want to post that on a more approproate forum.

http://www.freepbx.org/forum/general-help/incoming-call-from-sip-trunk-failing



=============================
Please remember to rate useful posts, by clicking on the stars below. 

=============================

Please remember to rate useful posts, by clicking on the stars below.

New Member

Logging- FreePBX to CUCM- Unauthorized Trunk w Device Mobility

Hi

It is only Cisco video phone(9971) is not able to make call through SIP trunk. Other Cisco phones can reach extension through SIP trunk. Still need to "allow anonymous inbound calls" on Asterisk ?

Rgds

Rajesh Kumar

New Member

Logging- FreePBX to CUCM- Unauthorized Trunk w Device Mobility

Rajesh....picking this up again...I know it's been a while. I tried allowing anonymous inbound calls on my Asterisk server...no difference. The call out to the mobile is never made\allowed ... again, Device Mobility enabled.

This is trace of a sucessfull call from Freepbx to the CUCM extension in question (3001). The difference here is I answered the call...before it would have rang the mobile. I still see the 401 Unauthorized from from FreePBX though...but then CUCM ACKs it, and sends the 200 OK anyway. Just frustrating why it won't ring the mobile.

I feel like I'm missing something- I tried different CSSs etc...and there is no digest auth on the SIP to trunk from CUCM to FreePBX....   any help guys...would love to solve this thing just on principle!  Dennis

2014/01/20 17:28:43.644|SIPT|0|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.1737^192.168.0.3^*|3345|66b9646933c17aa76683396d0e23fb5d@dtech.dnsalias.com|INVITE

2014/01/20 17:28:43.645|SIPT|0|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.1737^192.168.0.3^*|3346|66b9646933c17aa76683396d0e23fb5d@dtech.dnsalias.com|100 Trying

2014/01/20 17:28:43.647|CC|SETUP|24121072|24121073|@dtech.dnsalias.com|3001|3001

2014/01/20 17:28:43.650|CC|OFFERED|24121072|24121073|1970|3001|3001|To_FreePBX|SEP0021A0857BE9

2014/01/20 17:28:43.652|SIPT|24121072|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.1737^192.168.0.3^*|3347|66b9646933c17aa76683396d0e23fb5d@dtech.dnsalias.com|180 Ringing

2014/01/20 17:28:47.667|SIPT|24121073|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.1737^192.168.0.3^*|3348|3916ff00-2dd1a31f-119d-500a8c0@192.168.0.5|INVITE

2014/01/20 17:28:47.668|SIPT|24121073|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.1738^192.168.0.3^*|3349|3916ff00-2dd1a31f-119d-500a8c0@192.168.0.5|401 Unauthorized

2014/01/20 17:28:47.669|SIPT|24121073|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.1738^192.168.0.3^*|3350|3916ff00-2dd1a31f-119d-500a8c0@192.168.0.5|ACK

2014/01/20 17:28:48.631|SIPT|24121072|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,56,1.6273^192.168.0.42^SEP0021A0857BE9|3351|66b9646933c17aa76683396d0e23fb5d@dtech.dnsalias.com|200 OK

2014/01/20 17:28:48.633|SIPT|24121072|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.1739^192.168.0.3^*|3352|66b9646933c17aa76683396d0e23fb5d@dtech.dnsalias.com|ACK

2014/01/20 17:28:55.415|SIPT|24121072|UDP|OUT|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,56,1.6276^192.168.0.42^SEP0021A0857BE9|3353|66b9646933c17aa76683396d0e23fb5d@dtech.dnsalias.com|BYE

2014/01/20 17:28:55.418|SIPT|24121072|UDP|IN|192.168.0.5|5060|To_FreePBX|192.168.0.3|5060|1,100,230,1.1740^192.168.0.3^*|3354|66b9646933c17aa76683396d0e23fb5d@dtech.dnsalias.com|200 OK

2014/01/20 17:28:55.418|CC|RELEASE|24121072|24121073|16

1661
Views
0
Helpful
7
Replies
CreatePlease login to create content