Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Looking for a little help with CUE/CME

I pretty much have it working the way I want it to for just the basics. I am doing this for study purposes in prep for CCNA Voice, just to get a basic idea of the way things work.

Incoming works fine, outdialing works fine althought having to dial 11 digits even for local calls is a pain but that a callcentric limitation. I was toying with the idea of a translation rule to add 1+area code to any 7 digit number dialed. For another day perhaps.

Calling main extension (1000) from inside rolls to voicemail if not answered. Logging into and checking/navigating voicemail from any phone works fine.

Problem is on external DID calls, it does not roll to voicemail, instead it rolls back to callcentric "not available" message on no answer or busy.

Configs of CME router and CUE config (running on AIM) are included for review. It has to be something small I am missing..

Thanks.

Everyone's tags (3)
5 REPLIES
Hall of Fame Super Silver

Re: Looking for a little help with CUE/CME

What codes is the service provider sending the call as?

Your dial peer pointing to CUE is hard coded to G711, and you do not have a default inbound dial peer which means default dial-peer 0 is used that uses G729. Try adding the following:

dial-peer voice 901 voip

incoming called-number .

if that does not work please provide "debug ccsip messages" output.

HTH,

Chris

New Member

Re: Looking for a little help with CUE/CME

Thanks. I tried adding

dial-peer voice 901 voip

incoming called-number 19042393637

Still a no go. Below is a debug of an incoming call.

CME-Router#debug ccsip messages
SIP Call messages tracing is enabled
CME-Router#
Sep  4 21:56:22.281: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:17772968537@10.232.1.3:5060 SIP/2.0
v: SIP/2.0/UDP 204.11.192.34:5080;branch=z9hG4bK-6fa166237516869a60540ecd413f690c
f: "Johnson A & B" <19042200415>;tag=3555784581-986133
t: <>19042393637@ss.callcentric.com>
i: 6284152-3555784581-986103@msw1.telengy.net
CSeq: 1 INVITE
Max-Forwards: 9
m:
Supported: timer
c: application/sdp
l: 317

v=0
o=NexTone-MSW 17460 32142 IN IP4 204.11.192.34
s=sip call
c=IN IP4 204.11.192.34
t=0 0
m=audio 63464 RTP/AVP 0 18 101
a=maxptime:20
a=sendrecv
a=fmtp:101 0-15
a=rtpmap:101 telephone-event/8000
a=fmtp:18 annexb=no
a=rtpmap:18 G729/8000
a=rtpmap:0 PCMU/8000
a=silenceSupp:off - - - -
a=setup:actpass

Sep  4 21:56:22.289: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 204.11.192.34:5080;branch=z9hG4bK-6fa166237516869a60540ecd413f690c
From: "Johnson A & B" <19042200415>;tag=3555784581-986133
To: <>19042393637@ss.callcentric.com>
Date: Tue, 04 Sep 2012 21:56:22 GMT
Call-ID: 6284152-3555784581-986103@msw1.telengy.net
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0

Sep  4 21:56:22.293: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 180 Ringing
Via: SIP/2.0/UDP 204.11.192.34:5080;branch=z9hG4bK-6fa166237516869a60540ecd413f690c
From: "Johnson A & B" <19042200415>;tag=3555784581-986133
To: <>19042393637@ss.callcentric.com>;tag=B122B44-B51
Date: Tue, 04 Sep 2012 21:56:22 GMT
Call-ID: 6284152-3555784581-986103@msw1.telengy.net
CSeq: 1 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
Allow-Events: telephone-event
Contact: <17772968537>
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Sep  4 21:56:32.301: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 302 Moved Temporarily
Via: SIP/2.0/UDP 204.11.192.34:5080;branch=z9hG4bK-6fa166237516869a60540ecd413f690c
From: "Johnson A & B" <19042200415>;tag=3555784581-986133
To: <>19042393637@ss.callcentric.com>;tag=B122B44-B51
Date: Tue, 04 Sep 2012 21:56:22 GMT
Call-ID: 6284152-3555784581-986103@msw1.telengy.net
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Diversion: <17772968537>;reason=no-answer
Contact: <3220>
Content-Length: 0


Sep  4 21:56:32.377: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:17772968537@10.232.1.3:5060 SIP/2.0
v: SIP/2.0/UDP 204.11.192.34:5080;branch=z9hG4bK-6fa166237516869a60540ecd413f690c
f: "Johnson A & B" <19042200415>;tag=3555784581-986133
t: <>19042393637@ss.callcentric.com>;tag=B122B44-B51
i: 6284152-3555784581-986103@msw1.telengy.net
CSeq: 1 ACK
Max-Forwards: 15
l: 0

Sep  4 21:56:41.289: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:19042393637@alpha2.callcentric.com:5070 SIP/2.0
v: SIP/2.0/UDP 204.11.192.34:5080;branch=z9hG4bK-9c30dd4c18a97141ae7e47fd851af0b9
f: "Johnson A & B" <19042200415>;tag=3555784581-986133
t: <>19042393637@ss.callcentric.com>;tag=B122B44-B51
i: 6284152-3555784581-986103@msw1.telengy.net
CSeq: 1 ACK
Max-Forwards: 9
l: 0

New Member

Re: Looking for a little help with CUE/CME

Made some changes to the config. Learning more as I go but still no roll to VM

CME-Router#term len 0
CME-Router#sho run
Building configuration...

Current configuration : 8597 bytes
!
! Last configuration change at 22:46:32 eastern Tue Sep 4 2012
! NVRAM config last updated at 22:56:44 eastern Tue Sep 4 2012
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-Router
!
boot-start-marker
boot system flash flash:c3745-adventerprisek9-mz.124-15.T14.bin
boot-end-marker
!
enable secret 5
!
no aaa new-model
clock timezone eastern -5
clock summer-time eastern recurring
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.22.100.1 172.22.100.10
!
ip dhcp pool Voice
   network 172.22.100.0 255.255.255.0
   option 150 ip 172.22.1.154
   default-router 172.22.100.1
   dns-server 68.94.156.1 68.94.157.1
!
!
ip name-server 68.94.156.1
!
multilink bundle-name authenticated
!
!
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
sip
  registrar server expires max 3600 min 600
!
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 5
rule 1 /^9/ //
!
voice translation-rule 6
rule 1 /1000/ /17772968537/
rule 2 /3637/ /17772968537/
!
voice translation-rule 1111
rule 1 /^904239\(....\)$/ /\1/
rule 2 /17772968537/ /3637/
!
!
voice translation-profile OUT
translate calling 6
translate called 5
!
voice translation-profile PSTN_Incoming
translate called 1111
!
!
!
!
!
!
username cisco privilege 15 secret 5
archive
log config
  hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.232.1.3 255.255.255.0
duplex auto
speed auto
!
interface Service-Engine0/0
ip unnumbered FastEthernet0/1.100
service-module ip address 172.22.100.253 255.255.255.0
service-module ip default-gateway 172.22.100.1
!
interface FastEthernet0/1
no ip address
speed 100
full-duplex
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 172.22.1.154 255.255.255.0
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip address 172.22.101.1 255.255.255.0
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip address 172.22.100.1 255.255.255.0
!
router rip
version 2
network 10.0.0.0
network 172.22.0.0
network 192.168.1.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.232.1.1
ip route 172.22.100.253 255.255.255.255 Service-Engine0/0
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:gui
!
!
!
!
!
!
tftp-server flash:/phone/7906-7911/apps11.8-2-2ES1.sbn alias apps11.8-2-2ES1.sbn
tftp-server flash:/phone/7906-7911/cnu11.8-2-2ES1.sbn alias cnu11.8-2-2ES1.sbn
tftp-server flash:/phone/7906-7911/cvm11sccp.8-2-2ES1.sbn alias cvm11sccp.8-2-2ES1.sbn
tftp-server flash:/phone/7906-7911/dsp11.8-2-2ES1.sbn alias dsp11.8-2-2ES1.sbn
tftp-server flash:/phone/7906-7911/jar11sccp.8-2-2ES1.sbn alias jar11sccp.8-2-2ES1.sbn
tftp-server flash:/phone/7906-7911/SCCP11.8-2-2SR1S.loads alias SCCP11.8-2-2SR1S.loads
tftp-server flash:/phone/7906-7911/term06.default.loads alias term06.default.loads
tftp-server flash:/phone/7906-7911/term11.default.loads alias term11.default.loads
tftp-server flash:/phone/7921/APPS-1.0.1.SBN alias APPS-1.0.1.SBN
tftp-server flash:/phone/7921/CP7921G-1.0.1.LOADS alias CP7921G-1.0.1.LOADS
tftp-server flash:/phone/7921/GUI-1.0.1.SBN alias GUI-1.0.1.SBN
tftp-server flash:/phone/7921/SYS-1.0.1.SBN alias SYS-1.0.1.SBN
tftp-server flash:/phone/7921/TNUX-1.0.1.SBN alias TNUX-1.0.1.SBN
tftp-server flash:/phone/7921/TNUXR-1.0.1.SBN alias TNUXR-1.0.1.SBN
tftp-server flash:/phone/7921/WLAN-1.0.1.SBN alias WLAN-1.0.1.SBN
tftp-server flash:/phone/7936/cmterm_7936.3-3-12-0.bin alias cmterm_7936.3-3-12-0.bin
tftp-server flash:/phone/7940-7960/P00308000400.bin alias P00308000400.bin
tftp-server flash:/phone/7940-7960/P00308000400.loads alias P00308000400.loads
tftp-server flash:/phone/7940-7960/P00308000400.sb2 alias P00308000400.sb2
tftp-server flash:/phone/7940-7960/P00308000400.sbn alias P00308000400.sbn
tftp-server flash:/phone/7941-7961/apps41.8-2-2ES1.sbn alias apps41.8-2-2ES1.sbn
tftp-server flash:/phone/7941-7961/cnu41.8-2-2ES1.sbn alias cnu41.8-2-2ES1.sbn
tftp-server flash:/phone/7941-7961/cvm41sccp.8-2-2ES1.sbn alias cvm41sccp.8-2-2ES1.sbn
tftp-server flash:/phone/7941-7961/dsp41.8-2-2ES1.sbn alias dsp41.8-2-2ES1.sbn
tftp-server flash:/phone/7941-7961/jar41sccp.8-2-2ES1.sbn alias jar41sccp.8-2-2ES1.sbn
tftp-server flash:/phone/7941-7961/SCCP41.8-2-2SR1S.loads alias SCCP41.8-2-2SR1S.loads
tftp-server flash:/phone/7941-7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phone/7941-7961/term61.default.loads alias term61.default.loads
tftp-server flash:/phone/7945-7965/apps45.8-3-1-22.sbn alias apps45.8-3-1-22.sbn
tftp-server flash:/phone/7945-7965/cnu45.8-3-1-22.sbn alias cnu45.8-3-1-22.sbn
tftp-server flash:/phone/7945-7965/cvm45sccp.8-3-1-22.sbn alias cvm45sccp.8-3-1-22.sbn
tftp-server flash:/phone/7945-7965/dsp45.8-3-1-22.sbn alias dsp45.8-3-1-22.sbn
tftp-server flash:/phone/7945-7965/jar45sccp.8-3-1-22.sbn alias jar45sccp.8-3-1-22.sbn
tftp-server flash:/phone/7945-7965/SCCP45.8-3-2S.loads alias SCCP45.8-3-2S.loads
tftp-server flash:/phone/7945-7965/term45.default.loads alias term45.default.loads
tftp-server flash:/phone/7945-7965/term65.default.loads alias term65.default.loads
!
control-plane
!
!
!
voice-port 4/0/0
!
voice-port 4/0/1
!
!
!
!
!
dial-peer voice 901 voip
translation-profile outgoing OUT
destination-pattern 9.T
voice-class codec 1
session protocol sipv2
session target dns:callcentric.com
incoming called-number 19042393637
dtmf-relay sip-notify rtp-nte
!
dial-peer voice 3220 voip
destination-pattern 3220
b2bua
voice-class codec 1
session protocol sipv2
session target ipv4:172.22.100.253
dtmf-relay sip-notify
no vad
!
dial-peer voice 1000 voip
description ** Incoming call from SIP trunk **
translation-profile incoming PSTN_Incoming
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
incoming called-number .%
dtmf-relay rtp-nte
no vad
!
!
sip-ua
credentials username 17772968537 password realm callcentric.com
authentication username 17772968537 password 7 realm callcentric.com
no remote-party-id
retry invite 4
retry response 3
retry bye 2
retry cancel 2
retry register 5
timers register 250
mwi-server ipv4:172.22.100.253 expires 86400 port 5060 transport tcp
registrar dns:callcentric.com expires 3600
sip-server dns:callcentric.com
!
!
!
telephony-service
load 7960-7940 P00308000400
load 7961 SCCP41.8-2-2SR1S
load 7965 SCCP45.8-3-2S
load 7936 cmterm_7936.3-3-12-0
max-ephones 10
max-dn 100
ip source-address 10.1.1.1 port 2000
calling-number local secondary
timeouts interdigit 2
url services http://172.22.100.253/voiceview/common/login.do
url authentication http://172.22.100.253/voiceview/authentication/authenticate.do
cnf-file perphone
time-zone 12
voicemail 3220
max-conferences 4 gain -6
moh music-on-hold.au
web admin system name admin secret 5
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern .T
secondary-dialtone 9
create cnf-files version-stamp 7960 Sep 04 2012 18:10:30
!
!
ephone-dn  4
number 8000 no-reg primary
mwi on
!
!
ephone-dn  5
number 8001 no-reg primary
mwi off
!
!
ephone-dn  6  dual-line
number 3637 secondary 9042393637 no-reg both
label Ext. 3637
description (904) 239-3637
name Johnson
call-forward busy 3220
call-forward noan 3220 timeout 30
hold-alert 30 originator
!
!
ephone  1
device-security-mode none
mac-address B4A4.E328.FE5D
type 7965
button  1:6
!
!
!
ephone  2
device-security-mode none
mac-address B4A4.E329.0242
type 7965
button  1:6
!
!
!
ephone  3
device-security-mode none
mac-address 001B.D4C6.975D
type 7960
button  1:6
!
!
!
ephone  4
device-security-mode none
mac-address D485.6498.A2FC
type CIPC
button  1:6
!
!
!
line con 0
logging synchronous
line 26
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line aux 0
line vty 0 4
password
login
!
scheduler allocate 20000 1000
ntp clock-period 17180279
ntp server 147.135.0.1
ntp server 207.7.148.214
ntp server 4.53.160.75
ntp server 169.229.70.201
ntp server 199.4.29.166
!
end

CME-Router#q

Hall of Fame Super Silver

Re: Looking for a little help with CUE/CME

You need to bind SIP to one of the interfaces, do this:

voice service voip

sip

  bind control source-interface Loopback0

  bind media source-interface Loopback0

Chris

New Member

Re: Looking for a little help with CUE/CME

Thanks. I try that tonight when I get home.

Tony

1380
Views
10
Helpful
5
Replies