Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Mobile voice access not functioning

Hi All,

I am trying to configure the MVA feature on a H323 Gateway. I have configured the MVA Directory in CUCM and the dial-peer for incoming pots number and the voip dial-peer pointing to the Directory number. I have also loaded the VoiceXML application using the command "service MVA http://Publisher-IP:8080/ccmivr/pages/IVRMainpage.vxml". I am unsure about the VoiceXML application. Will adding the above command do the trick? Is there anything else I am supposed to do? Please suggest. I can see the call landing on the router and getting connected for a brief msec of time and then immediate disconnect tone. Just to add Mobile Connect is working as desired. The configuration is mentioned below.



package callfeature

param med-inact-det enable

param med-inact-disc-cause 16

param med-inact-action disc


service MVA http://Publisher-IP:8080/ccmivr/pages/IVRMainpage.vxml


service FaxMailOnramp flash:app_faxmail_onramp.


service FaxDetect flash:app_fax_detect.

param voice-dtmf 1

param prompt

param fax-dtmf 2

param mode default-voice


dial-peer voice 601 pots

service mva

incoming called-number 9464



dial-peer voice 602 voip

destination-pattern 9471

session target ipv4:X.X.X.X << Publisher IP

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad


New Member

Re: Mobile voice access not functioning

Hi Folks,

I have been able to get the VoiceXML script invoked by clearing out and readding the MVA service in application; reset of the pots and voip dial-peer and reset of the Cisco Unified Mobile Voice Access service.

But, now I am not able to get calls connected from the remote destination device. I can login using my PIN through the IVR prompt and select "1" to make a call. As I enter the digits and press the # sign, hear the lady say "your call cannot be completed as dialled".

Thought, it could be a CSS issue, tried with various options but still same problem. On the RDP, I am applying same CSS that has been applied to Rerouting CSS.

Any clue?

New Member

Re: Mobile voice access not functioning

Attaching the VXML script that has been generated by Publisher.

New Member

Re: Mobile voice access not functioning

Hi Folks,

Modified the "Mobile Voice Access Partition" to ensure it contains the partition that is assigned on "Inbound CSS" on Gateway and it works now. Will test the feature access codes tomorrow. Remember, I got stuck wherein I can place a call on hold from the remote destination device using *81 but to resume it *83 does not work. It keeps the called party on hold forever and I have to end the call. Any ideas?

New Member

Re: Mobile voice access not functioning

Hello , can you send the screen from your config of mva, I need configured that,but to my not me this working