Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Personal Communicator1.2, presence server=invalid credentials

CCM5.1.2, CUPS6.0.1, Personal communicator1.2

configured CCM and CUPS as per doc and all passed the 'troubleshooter' in CUPS but the personal communicator failes Presence server connection with the status 'Failed to connect - invalid credentials'. the status from 'Server health' is green for 'Logon server, Voice mail, WEB conferencing and LDAP'.

follows the log file,

2007-08-25 22:01:23,296 [0x560] DEBUG LCWabiSinks - (WABIMSG_ONREGSTATE) OnProxyRegistrationState: SubID=26 proxyID=52 proxySlot=0 state=10 fail=401 'Unauthorized', fromGraveyard=false

2007-08-25 22:01:23,296 [0x560] ERROR LCWabiSinks - (WABIMSG_REGSTATE11) ********* CUPS (abc.abc@test.local) (slot 0) REGISTER STATE: FAILED!! code=401, reason=Unauthorized *********

2007-08-25 22:01:23,296 [0x560] DEBUG LCPersonManager - (MWMSG_PMI_WABIREGISTRATIONSTATUS)

PMWabiAccountManager::OnWabiAccountRegistrationStatus(false)

2007-08-25 22:01:23,296 [0x560] DEBUG LCConnection - CUPC_PRESENCE reportResult(ERROR): reason=INVALID_CREDENTIALS, functionality=NONE

2007-08-25 22:01:23,296 [0x560] DEBUG LCConnection - CUPC_PRESENCE setReason(): [NONE] --> [INVALID_CREDENTIALS]

2007-08-25 22:01:23,296 [0x560] DEBUG LCConnection - CUPC_PRESENCE reportResult(): connection error!

Advise please,

6 REPLIES
Bronze

Re: Personal Communicator1.2, presence server=invalid credential

This error can occur when the "Authentication Module Status" under the "Service Parameters" is set to On.

To resolve the issue, go to System - Service Parameter - choose the CUPS server and Service as Cisco UP SIP Proxy. And in this page, check if the "Authentication Module Status" is On or Off. If it is On, you need to set it to Off and Save.

Also check if you have "User must reset password at next login" enabled for the user account on CUCM . In this case, make sure you either remove that, or that you log in via the CCM user pages and change the password first.

New Member

Re: Personal Communicator1.2, presence server=invalid credential

Thanks it worked for me.

Re: Personal Communicator1.2, presence server=invalid credential

Jamie,

5 points for an excellent find.

New Member

Re: Personal Communicator1.2, presence server=invalid credential

This setting change solved the probelme for me too. I was just wondering what exactly it does.

Thanks for posting the solution though , happy to rate this.

Martin

Red

Re: Personal Communicator1.2, presence server=invalid credential

That is not the best solution and NOT recommended by Cisco.

There are three solutions:

The best solution:

Configure digest credential on CUCM > End User. To make sure this configuration populated to CUPS, you might need to restart "Cisco UP Sync Agent" on CUPS side.

This is the most secure one.

The Ok solution:

On CUPS, configure incoming ACL to include all CUPC computer's IP range.

This is a less secure solution.

The worst "solution":

Turn off "authentication module" in service parameters.

This is very insecure and have a wide-opened door for hackers.

For more details, see:

http://www.lulu.com/content/5552336

Michael

http://htluo.blogspot.com/

New Member

Re: Personal Communicator1.2, presence server=invalid credential

Digest Credentials Not configured for the UserID on CUCM end user configure page could also cause this problem.

287
Views
60
Helpful
6
Replies
CreatePlease to create content