Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Phone Services Missing From Add New Services Dropdown Box

Hello All,

CallManager: v10.5.2.13900-12

I just created 2 new IP Phone Services in CUCM for an Agent's CallCenter Login. I then went back into the list of all IP Phone Services and the Service is there, so it was created/saved correctly...

Then, I went into the Phone's Configuration and went to Subscriber/Unsubscribe Services. From the new window I clicked the drop-down box to select the service I just created, which its name begins with a "T". And for some reason the list stops somewhere in the middle of the Services that begin with an "S". So I tried to click the "Find" button, but nothing happens.

Tried this in Firefox and Chromium, with the same exact results.

Any idea what could be going on with this? Any help would be greatly appreciated!


Thanks in Advance,
Matt

Everyone's tags (1)
3 REPLIES

Can you dummy rename it by

Can you dummy rename it by prefixing like AAA to the start of the name so it appears on top alphabetically?

also try IE

Please rate if useful

Please remember to rate useful posts, by clicking on the stars below.

New Member

Hey Dennis, thanks for the

Hey Dennis, thanks for the reply...

Yea, it's a strange issue.

So I just attempted this in IE11 (*and also Chrome) and I get the same result. The list just stops somewhere like halfway through the S's. So I right clicked the page and clicked view source, and in the Source code I can see that the list goes all the way to Z, with one of our Agent's logins (*Server Name="ZacharyLogin"), which makes this even stranger.

I guess I can try adding an "A" to the start of the Service Name, but I suspect this isn't expected behavior even though I'm getting the same results in Firefox, Chromium, IE11 and Chrome. And since the list in each Web Browser stops on the same name, maybe there is some limit on object in the dropdown box. I'm curious to see if when I add the "A" to the start of the Service Name if the second to last name in the list will become the very last name in the list...

Also, what's the "Find" button supposed to do on that page, because as long as I can remember, with working with CUCM, that "Find" button never really did anything when you clicked it... Any idea?

But, thanks again for the reply, much appreciated... Any other thoughts?

Thanks Again,
Matt

New Member

I added the "A" to the start

I added the "A" to the start of the Service Names and I was able to successfully add them to that IP Phone because they now showed at the top of the dropdown list. Then, after I subscribed the service to the IP Phone, I removed the "A" from the start of the name to make it so it would display the way it's supposed to.

And as stated in my previous comment, I checked what was now the last Service in the dropdown box and the 2nd to last service did become the last one in the list, so maybe there is a numerical limit on how many will display (*maybe its a Bug?)... Weird huh..!

Also, I checked the Source Code view again, and it looks like the object on the page that lists ALL of the Phone Services to "Z" is an object called "serviceDescriptionList". However, looking further down in the source code I found what looks like the actual elements/options of the dropdown box, and that only lists until the "S"s like the dropdown box actually shows.


Thanks,
Matt

48
Views
0
Helpful
3
Replies
CreatePlease to create content