Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Presence 7 and CUPC7 problem

I am trying to configure CUPC but I could not. On CUPC I used help> show server health, I found problem in presence.

Also in CUP I used:

Diagnositics>> System Troubleshooter in SIP Proxy Troubleshooter I found the following error:

Invalid Proxy Domain service parameter value (either the value is empty or is set to the default)

the value still default


I tried to change the value many times but no result, once I typed new domain name I got message box contains:

Proxy Domain: WARNING: For this change to take effect, the Cisco Presence Engine will automatically restart. The restart will take several minutes, during which time the Cisco Presence Engine service will drop any existing transactions and will not accept any new incoming requests.

when I have tried to save I got the following:

Federation Routing CUP FQDN: Please provide a valid fully-qualified domain name (FQDN) for the 'Federation Routing CUP FQDN' Parameter. (For example,

The FQDN can contain up to 255 of the following characters:

- any upper or lower case letter (a-zA-Z),

- any number (0-9),

- the hyphen (-) or the dot (.)

The dot serves as a domain label separator. Domain labels must not start with a hyphen. The last label (for example, .com) must not start with a number. Hostname.Abc.1om serves as an example of an invalid FQDN.

Click on the service parameter name or scroll to the top of the page and click the yellow question mark (?) to see service parameter help.

Anyone can help me????????


Re: Presence 7 and CUPC7 problem

Both "Proxy Domain" and "Federation Routing CUP FQDN" has to be in the valid format.

For example, set "Proxy Domain" to "". Then set "Federation Routing CUP FQDN" to "".


New Member

Re: Presence 7 and CUPC7 problem

Thank you for your help,

but still the CUPC not registered.

and form server Health the problem in Presence.

I got the following messages:

Presence.primary.port= 5060

Presence,Primary.Protocol= TCP

Presence.Primary.address= PresenceName

Presence.MostRecentListenPort=5002X (it is change)

Before, I did not configure the domain name. So, after changing the Proxy Domain and Federation Routing CUP, I change the domain via CLI

set network domain

the server asked me to restart all servers in Cluster ( but I just have one Presence Server so I restarted, Shall I restart the CCM-Pub and Sub??

Thank you.

New Member

Re: Presence 7 and CUPC7 problem

I found the problem it is for Digest Credentials

but still the CUPC not registered with with CCM

The problem now in the next field in server health...


Desk Phone CTI

Device Name: Not Registered

Line ID: Not Registered


Re: Presence 7 and CUPC7 problem

You don't have to change domain name via CLI.

Please note "SIP domain" and "DNS domain" is a little bit different. Though in the ideal world, they should be the same.

After you set the SIP domain, CUPC will try to derive the CUPS servers's FQDN with a "formula":

1) Look at CUPS > System > Server. See if the server name is in hostname/FQDN or IP address. If it's IP address, CUPC will try to connect to that IP address. If it's hostname/FQDN, continue.

2) If it's a hostname, CUPC will derive the FQDN with this name and the SIP domain (configured in service parameters).

3) If it's a FQDN, CUPC will compare it with the SIP domain. If the FQDN contains the SIP domain, CUPC will use FQDN as is. If not, CUPC will treat it as "hostname" and append SIP domain to it (see #2 above).

See my blog for more details:


New Member

Re: Presence 7 and CUPC7 problem

Thank you Michael,

You have great blog, good luck.

Next Problem :)

It seems OK, now I can see that the CUPC registered,but I could not see the status of the users

I create a call from one phone to my Hardware phone which is controlled by CTI and (Presence user) and I used Corporate directory from other phone and search about the user I could not see that the user have call or not or other presence features..


Re: Presence 7 and CUPC7 problem

There are two kind of status for a user - "Availability" (a.k.a. "Reachability") and phone presence. Which one you're not seeing?

There are two presentation for phone presence - BLF (Busy Lamp Field) and CUPS. Where you expect to see the phone presence? On CUPC or on phone's LCD screen?


New Member

Re: Presence 7 and CUPC7 problem

First of all, I really appreciate your support.

Second thing, I am sorry if my questions seem silly because this is my first deployment for presence and I could not find resources for presence except your book.

By the way today I ordered your book it seems very helpful. but it needs time to deliver.

regarding the status, what I knew that I can see the status of the user on Both (Phone LCD and CUPC)

for example, I did today the following scenario:

Phone A Controlled via CTI (CUPC user)

Phone B and Phone C Normal IP Phones.

I place call from Phone B to A. (call connected now between A and B).

In phone C>> Directory >> Corporate directory>> Search CUPC user

I found the user but I did not see the status of the user.

Also, In CUPC I added one contact, I could not see the status of this person on my CUPC.

Could you please advise me if the integration between CUPS and LDAP is a must for these features. I did not integrate CUPS with LDAP because my CCM is not integrated with LDAP.

New Member

Re: Presence 7 and CUPC7 problem

One more thing, I did not integrate the CUP with LDAP, because I did not integrate CCM with LDAP.

can I Integrate CUP with LDAP and leave CCM as it is without integration????

Is it a must to integrate with LDAP to slove my previous problem (The status of users).


Re: Presence 7 and CUPC7 problem

It's alright. Developer built thing complicated so engineers can have jobs. :)

The presence you're seeing on IP Phone > Corporate Directory is called BLF (busy lamp field). It's totally different from CUPS presence. In corporate directory, you can only see BLF, you cannot see user status (availability). If you'd like to see user availability on phone, you need to configure IPPM (IP Phone Messenger).

Confused enough?

So to make things simpler, I'd recommend you focus on CUPC and forget about the phone's corporate directory.

On CUPC, what did you expect to see but not seeing?

Regarding the LDAP,

1) There's no such a thing called "CUPS integrated with LDAP". Even though you configure "LDAP server" on CUPS, it's actually being used by CUPC.

2) You may have both CUCM and CUPC integrated with LDAP.

3) You may have CUPC integrated with LDAP but not CUCM.

4) You may have CUCM integrated LDAP but not CUPC (though it's very weird to do so).


New Member

Re: Presence 7 and CUPC7 problem

Confused enough? (Thank you for your confusing :) I told you this my first implementation for Presence)

OK, I do not need to see the status on the phone, all what I need to see the status on the CUPC, but I could not?

As I told you before, when I added a contact person on CUPC I could not see the status of this person ( I don't know if this is because I just add one user, which is used via my CUPC)

So, could you please tell me what is the key to see the status of users on CUPC.

again thank you for your support


Re: Presence 7 and CUPC7 problem

Ok. One thing at a time.

I'm assuming you tried to troubleshoot "Availability" first. Which means, the other person was logged in and online, but you didn't see his online status.

To troubleshoot "Availability", the key point is the user ID. The user ID of the contact needs to match the user ID of the CUCM end user.

There are three different ways to add a contact to CUPC contact list:

1) If you have LDAP configured, you may perform a LDAP search in CUPC and right-click on the search result to add a contact. The user ID was determined by the attributes of LDAP and the user ID mapping configuration on CUPS > Application > Cisco Unified Personal Communicator > Settings.

If there's no LDAP configured for CUPC, you cannot use 'search' function. You may use the following options:

2) On CUPC > Contacts > Add Contact > Create a New Contact. With this option, the contact created does not have any "Availability" or "phone presence" status. Because there's no way to enter a user ID with this method.

3) Go to CUPS User Options page > User Options > Contacts. With this method, you may add contact to CUPC contact list. If the user ID matches with CUCM end user ID, you should be able to see "Availability" status.


New Member

Re: Presence 7 and CUPC7 problem

I think I have now a major problem,

Because I tried to add user from user page >> user option >> contacts >> find

I am not able to find any user ID, and I have two users and each user related to different CUPC.

but in the same time from Administrator page >> User Management >> end user I can see all users in CCM.

one more thing in UserPage>> contacts >> add contact

I have the following feilds that I should fill:

contact (required item)

domain ( contain the domain of the company like required item)

Nick Name:

If I tried to add any user I will got the following message:

Add failed. One of the required fields on the page has the same value as an entry that already exists in the database. Please check the corresponding Find List page to verify your entry does not exist.

One more thing :)

( I am sorry I asked you alot of questions... so thank you)

I tried to use instant messaging I already add the service in CCM and the phones subscribe to the service and I can see from UP >> Diagnostics >> Presence Viewer >> User ID search >>

I can see the IP Phone and CUPC, regarding the CUPC I can see supports instant messaging, but I have ? near the IP Phone.

and If I tried to add user from IP phone (inside instant messaging service)

I can search and find the user but once I am trying to add I gor message contains:

Invalid, Duplicate or non-existing contact name: USERNAME. Or the max allowed number of contacts was reached

at the end not one thank you but

100000000000000000000 * thanks


New Member

Re: Presence 7 and CUPC7 problem


I am going through the exact scenario of yours. Did you finally get this wortking? Can you please post what actions did you undertake to get this going?

Thanks in advance,


CreatePlease to create content