Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Set Dial_Peer Destination pattern to 5 digits

Hello Everyone,

I have an issue regarding setting of dial-peer destination pattern to 5 digits. In my organization we have IP Phone 7906 and 6921. All the IP Phone dial numbers are of four digits (1001, 1002, 1003, 1004, 2013, 2045..and so on).

Now i want to have the digits to five i.e. 10011, 10023, 30321, 80322.. and so on. I have tried to set the dial-peer in following manner to achieve 5 digits of IP Phone number.

Here is my configuration

dial-peer voice 2018 pots

destination-pattern 8....

port 0/0/0

forward-digits 4

In the above configuration i have set destination-pattern to 8.... which means 8 with four digits (5 in total).

Is the configuration correct? Am i missing further configuration to achieve 5 digits of IP Phone number? Please help me.

Thanks

7 REPLIES
Hall of Fame Super Silver

Set Dial_Peer Destination pattern to 5 digits

Sure as long as you need to strip the 8 before sending the call to the phone, the question here is what is the call flow as this is a POTS dial peer which would imply you are sending the call out to PSTN.  What system are you using?

Chris

Cisco Employee

Re: Set Dial_Peer Destination pattern to 5 digits

Hello

By default in pots dial-peer it's strip the qualified digit match

dial-peer voice 2018 pots
destination-pattern 8....
port 0/0/0
forward-digits 4

As per your dial-peer configured you have destination pattern 8...., so here it will strip the 8 and as a matter of fact of fact you have forward digit 4 configured under this dial-peer it will send only 4 digit .


If you want achieve and to send 5 digit the. Configured either forward digit all or no digit strip


Sent from Cisco Technical Support iPhone App

Br, Nadeem Please rate all useful post.
New Member

Re: Set Dial_Peer Destination pattern to 5 digits

Thanks for your response. If i make the forward digit to all or not digit strip, will it effect the current working IP Phones? Since i have other configuration as follows :

control-plane

!

!

voice-port 0/0/0

connection plar opx 1001

caller-id enable

!

voice-port 0/0/1

connection plar opx 1002

caller-id enable

!

voice-port 0/0/2

connection plar opx 1001

caller-id enable

!

voice-port 0/0/3

connection plar opx 1002

caller-id enable

!

!

!

mgcp profile default

!

!

dial-peer voice 1990 pots

destination-pattern 90.......

port 0/0/0

forward-digits 8

!

dial-peer voice 1991 pots

destination-pattern 9[2-6].....

port 0/0/0

forward-digits 6

!

dial-peer voice 1992 pots

destination-pattern 91.......

port 0/0/0

forward-digits 8

!

dial-peer voice 1993 pots

destination-pattern 97.......

port 0/0/0

--More-- forward-digits 8

!

dial-peer voice 1994 pots

destination-pattern 90.......

port 0/0/1

forward-digits 8

!

dial-peer voice 1995 pots

destination-pattern 9[2-6].....

port 0/0/1

forward-digits 6

!

dial-peer voice 1996 pots

destination-pattern 91.......

port 0/0/1

forward-digits 8

!

dial-peer voice 1997 pots

destination-pattern 97.......

port 0/0/1

forward-digits 8

!

dial-peer voice 1998 pots

destination-pattern 90.......

port 0/0/2

forward-digits 8

!

dial-peer voice 1999 pots

destination-pattern 9[2-6].....

port 0/0/2

forward-digits 6

!

dial-peer voice 2000 pots

destination-pattern 91.......

port 0/0/2

forward-digits 8

!

dial-peer voice 2001 pots

destination-pattern 97.......

port 0/0/2

forward-digits 8

!

dial-peer voice 2002 pots

destination-pattern 90.......

port 0/0/3

forward-digits 8

!

dial-peer voice 2003 pots

destination-pattern 9[2-6].....

port 0/0/3

forward-digits 6

!

--More-- dial-peer voice 2004 pots

destination-pattern 91.......

port 0/0/3

forward-digits 8

!

dial-peer voice 2005 pots

destination-pattern 97.......

port 0/0/3

forward-digits 8

!

dial-peer voice 2006 pots

destination-pattern 81..

port 0/0/0

forward-digits 3

!

dial-peer voice 2007 pots

destination-pattern 81..

port 0/0/1

forward-digits 3

!

dial-peer voice 2008 pots

destination-pattern 81..

port 0/0/2

forward-digits 3

!

dial-peer voice 2009 pots

destination-pattern 81..

port 0/0/3

forward-digits 3

!

dial-peer voice 2010 pots

destination-pattern 95.....

port 0/0/0

forward-digits 6

!

dial-peer voice 2011 pots

destination-pattern 95.....

port 0/0/1

forward-digits 6

!

dial-peer voice 2012 pots

destination-pattern 95.....

port 0/0/2

forward-digits 6

!

dial-peer voice 2013 pots

destination-pattern 95.....

port 0/0/3

forward-digits 6

!

dial-peer voice 2014 pots

destination-pattern 98.....

--More-- port 0/0/0

forward-digits 6

!

dial-peer voice 2015 pots

destination-pattern 98.....

port 0/0/1

forward-digits 6

!

dial-peer voice 2016 pots

destination-pattern 98.....

port 0/0/2

forward-digits 6

!

dial-peer voice 2017 pots

destination-pattern 98.....

port 0/0/3

forward-digits 6

The line highlighted on BOLD uses 4 digits i.e. 2014, 7777,9999, 8001 and so on. Can you please give me some configuration example to achieve 5 digits.

Regards

Cisco Employee

Re: Set Dial_Peer Destination pattern to 5 digits

no It won't, If you could provide us the exact call-flow and topology with requirement/issue you are facing i might be able to given some concrete solutions, however the one which i have given example it does not have any impact it will send only 5 digit to the destination that's it.


Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.
New Member

Re: Set Dial_Peer Destination pattern to 5 digits

Sorry Nadeem, i didnt get you. Are you asking me to send my CCME router configuration? If yes then please find below:

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.01.22 17:23:21 =~=~=~=~=~=~=~=~=~=~=~=

sh run

Building configuration...

 

Current configuration : 42559 bytes

!

! Last configuration change at 17:02:31 UTC Wed Jan 22 2014

! NVRAM config last updated at 17:02:32 UTC Wed Jan 22 2014

! NVRAM config last updated at 17:02:32 UTC Wed Jan 22 2014

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ROUTERCCME

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

enable secret 5 $1$oAsG$UbrxBP0dpE.h3RBBp7WFt1

!

no aaa new-model

clock timezone UTC 6 6

!

no ipv6 cef

ip source-route

ip cef

!

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.11.2 192.168.11.20

!

ip dhcp pool IPTELEPHONES

network 192.168.11.0 255.255.255.0

option 150 ip 192.168.11.1

default-router 192.168.11.1

!

!

ip domain name yourdomain.com

multilink bundle-name authenticated

!

!

!

!

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1859121955

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1859121955

revocation-check none

rsakeypair TP-self-signed-1859121955

--More-- !

crypto pki trustpoint TP-self-signed-2189781093

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2189781093

revocation-check none

rsakeypair TP-self-signed-2189781093

!

!

crypto pki certificate chain TP-self-signed-1859121955

certificate self-signed 01

3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 31383539 31323139 3535301E 170D3132 31323135 30343034

33395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38353931

32313935 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100B906 FB652ED9 BD551AD0 69725244 F33BB857 54C2F40B 213D854B 9012AE9B

E3B97C50 73F732F3 8437E7D2 D8A2BD69 129EF339 BAC197F2 6C2D7845 03D0FE53

8CEB792C 23592F49 1ACBF9F0 0BE293F9 27F85572 58FC2D0D 3AD69181 B31B5018

05AD5448 D019F625 C7BE11F7 E4A5B335 4EA557D4 331331FE 9382C335 CBEE7558

2A4D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

551D2304 18301680 14FE54A5 2918FF1E 55C69F1F 5F5176EC 62F7F6A0 85301D06

03551D0E 04160414 FE54A529 18FF1E55 C69F1F5F 5176EC62 F7F6A085 300D0609

2A864886 F70D0101 05050003 81810094 79481070 567946DC A43F56D8 CCFC2F19

30E7E026 E7AE9120 9D64B469 9FCDB942 731E3F42 C51BFF12 8E87273B C515E9A9

BC604B43 07CB6461 D8245059 604D5242 93B7338A E02B3431 94370F40 ED45A2BD

48C08475 1BEFA7BD 2FADD309 369BEC2C 7EFE9B8D 976CA6A7 95CD3F3D 03D252D2

2DBF4071 4ED187B5 13085802 5373E3

quit

crypto pki certificate chain TP-self-signed-2189781093

voice-card 0

!

!

!

!

!

!

!

license udi pid C3900-SPE150/K9 sn FOC16484F21

license accept end user agreement

license boot module c3900 technology-package datak9

hw-module pvdm 0/0

!

!

!

username tashi password 7 08354D5D011057474359

!

redundancy

!

!

!

!

--More-- !

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description Link to CORESWITCH 1

ip address 192.168.11.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

!

ip forward-protocol nd

!

no ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 192.168.11.10

!

!

!

!

!

nls resp-timeout 1

cpd cr-id 1

!

snmp-server community Bdbl2288 RO

snmp-server host 192.168.1.98 Bdbl2288

tftp-server flash:CP7902040000SCCP040701A.sbin

tftp-server flash:CP7905040000SCCP040701A.sbin

tftp-server flash:CP7912040000SCCP040701A.sbin

tftp-server flash:P00303020214.bin

tftp-server flash:P00305000301.sbn

tftp-server flash:P00403020214.bin

tftp-server flash:S00103020002.bin

--More-- tftp-server flash:cmterm_7920.4.0-01-08.bin

tftp-server flash:apps11.1-0-2-12.sbn

tftp-server flash:cnu11.3-0-3-12.sbn

tftp-server flash:cvm11.7-2-2-12.sbn

tftp-server flash:dsp11.1-0-2-12.sbn

tftp-server flash:jar11.7-2-2-12.sbn

tftp-server flash:SCCP11.7-2-3S.loads

tftp-server flash:term06.default.loads

tftp-server flash:term11.default.loads

!

control-plane

!

!

voice-port 0/0/0

connection plar opx 1001

caller-id enable

!

voice-port 0/0/1

connection plar opx 1002

caller-id enable

!

voice-port 0/0/2

connection plar opx 1001

caller-id enable

!

voice-port 0/0/3

connection plar opx 1002

caller-id enable

!

!

!

mgcp profile default

!

!

dial-peer voice 1990 pots

destination-pattern 90.......

port 0/0/0

forward-digits 8

!

dial-peer voice 1991 pots

destination-pattern 9[2-6].....

port 0/0/0

forward-digits 6

!

dial-peer voice 1992 pots

destination-pattern 91.......

port 0/0/0

forward-digits 8

!

dial-peer voice 1993 pots

destination-pattern 97.......

port 0/0/0

--More-- forward-digits 8

!

dial-peer voice 1994 pots

destination-pattern 90.......

port 0/0/1

forward-digits 8

!

dial-peer voice 1995 pots

destination-pattern 9[2-6].....

port 0/0/1

forward-digits 6

!

dial-peer voice 1996 pots

destination-pattern 91.......

port 0/0/1

forward-digits 8

!

dial-peer voice 1997 pots

destination-pattern 97.......

port 0/0/1

forward-digits 8

!

dial-peer voice 1998 pots

destination-pattern 90.......

port 0/0/2

forward-digits 8

!

dial-peer voice 1999 pots

destination-pattern 9[2-6].....

port 0/0/2

forward-digits 6

!

dial-peer voice 2000 pots

destination-pattern 91.......

port 0/0/2

forward-digits 8

!

dial-peer voice 2001 pots

destination-pattern 97.......

port 0/0/2

forward-digits 8

!

dial-peer voice 2002 pots

destination-pattern 90.......

port 0/0/3

forward-digits 8

!

dial-peer voice 2003 pots

destination-pattern 9[2-6].....

port 0/0/3

forward-digits 6

!

--More-- dial-peer voice 2004 pots

destination-pattern 91.......

port 0/0/3

forward-digits 8

!

dial-peer voice 2005 pots

destination-pattern 97.......

port 0/0/3

forward-digits 8

!

dial-peer voice 2006 pots

destination-pattern 81..

port 0/0/0

forward-digits 3

!

dial-peer voice 2007 pots

destination-pattern 81..

port 0/0/1

forward-digits 3

!

dial-peer voice 2008 pots

destination-pattern 81..

port 0/0/2

forward-digits 3

!

dial-peer voice 2009 pots

destination-pattern 81..

port 0/0/3

forward-digits 3

!

dial-peer voice 2010 pots

destination-pattern 95.....

port 0/0/0

forward-digits 6

!

dial-peer voice 2011 pots

destination-pattern 95.....

port 0/0/1

forward-digits 6

!

dial-peer voice 2012 pots

destination-pattern 95.....

port 0/0/2

forward-digits 6

!

dial-peer voice 2013 pots

destination-pattern 95.....

port 0/0/3

forward-digits 6

!

dial-peer voice 2014 pots

destination-pattern 98.....

--More-- port 0/0/0

forward-digits 6

!

dial-peer voice 2015 pots

destination-pattern 98.....

port 0/0/1

forward-digits 6

!

dial-peer voice 2016 pots

destination-pattern 98.....

port 0/0/2

forward-digits 6

!

dial-peer voice 2017 pots

destination-pattern 98.....

port 0/0/3

forward-digits 6

!

!

!

!

gatekeeper

shutdown

!

!

telephony-service

no auto-reg-ephone

max-ephones 240

max-dn 600

ip source-address 192.168.11.1 port 2000

system message BDBL

cnf-file location flash:

load 7906 SCCP11.7-2-3S

time-zone 40

time-format 24

date-format dd-mm-yy

max-conferences 12 gain -6

moh music-on-hold.au

multicast moh 239.7.17.57 port 2000

transfer-system full-consult

login timeout 5

after-hours block pattern 1 90.......

after-hours block pattern 2 97.......

after-hours block pattern 3 91.......

after-hours block pattern 4 95.....

after-hours block pattern 5 98.....

after-hours day Sun 00:00 23:59

after-hours day Mon 00:00 23:59

after-hours day Tue 00:00 23:59

after-hours day Wed 00:00 23:59

after-hours day Thu 00:00 23:59

after-hours day Fri 00:00 23:59

--More-- after-hours day Sat 00:00 23:59

create cnf-files version-stamp 7960 Jan 21 2014 09:58:21

!

!

ephone-dn 1 dual-line

number 1001 secondary 324687

name Operator

call-forward busy 1002

call-forward noan 1002 timeout 10

huntstop channel

no huntstop

!

!

ephone-dn 2 dual-line

number 1002 secondary 333865

name operator

huntstop channel

no huntstop

!

!

ephone-dn 3 dual-line

!

!

ephone-dn 4 dual-line

number 1004

name Operator

!

!

ephone-dn 5 dual-line

number 8001

name Thimphu Main Branch

!

!

ephone-dn 6 dual-line

number 8002

name Thimphu Branch

huntstop channel

no huntstop

!

!

ephone-dn 7 dual-line

number 8003

name Paro Branch

huntstop channel

no huntstop

!

!

ephone-dn 8 dual-line

number 8004

name Wanduephodrang Branch

huntstop channel

no huntstop

--More--

ROUTER_CCME#exit

Thanks

Cisco Employee

Re: Set Dial_Peer Destination pattern to 5 digits

Hello Tashi

Actually I wanted to know the call-flow Topology

when A Phone calling Phone B what all entities are involved ? where are these phones register?


Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.
Cisco Employee

Set Dial_Peer Destination pattern to 5 digits

Basically the question comes down to this:

Do you realize that changing what/how many digits you send for calling from your ISR, will have implications on what the other side will receive and how to handle the calls accordingly????

Are you responsible for the other... ISR?? CUCM?? whatever it is you're going to call, and have you also planned on how to adjust the configuration there???

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
273
Views
0
Helpful
7
Replies
CreatePlease login to create content